Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 23 reacties
Bron: Amd

ATi CrossFireX logo (75 pix) AMD heeft nieuwe Linux-drivers voor zijn ATI Radeon-videokaarten uitgebracht. De download is 94MB groot en kan voor zowel 32bit- als 64bit-omgevingen worden gebruikt. Versie 10.4 is geschikt voor Radeon HD2400 en hoger, de FireStream 9170, 9250 en 9270, en de embedded E2400 en E4690. Verder worden versies 6.7 tot en met 7.5 van X.org, Linux-kernel 2.6 en hoger, en glibc-versies 2.2 of 2.3 ondersteund. Nieuw in deze release is de voorlopige ondersteuning voor de binnenkort te verschijnen versie 10.04 van Ubuntu. Het changelog toont verder enkele bugfixes en een korte lijst met bekende problemen waarvoor nog geen oplossing is:

Support for New Linux Operating Systems
  • Ubuntu 10.04 early look support
Resolved Issues
  • Changes to the color gamma value are now retained in Catalyst Control Center and reflected on the display after X-server restart
  • System will now resume properly after hibernation/suspend mode
  • Flickering corruption no longer observed while running OpenGL applications with CrossFire enabled
  • [RHEL4u8] DisplayPort display will now light up after being hotplugged
  • [SUSE 11.1] Enabling more than 4 single independent desktops no longer causes black screen hang on starting X
Known Issues
  • Enabling Hybrid Crossfire may result in error in dmesg after starting X
  • Screen may go blank if the other monitor is unplugged in dual-head mode
  • "X.org -probeonly" may cause screen corruption or the system to fail to respond
  • [Catalyst Control Center] Some systems may intermittently stop responding when changing scaling options
  • System may fail to display error message when improper values are used in "aticonfig --tv-geometry" resulting in invalid "TVHSizeAdj" and "TVVSizeAdj" values in xorg.conf file
  • Segmentation fault may occur when running "Quake 4" and "Enemy Territory: Quake Wars" at 1280x1024 or resolutions higher than current desktop resolution
  • Resuming from sleep may cause the display number overlay to become corrupted
  • RHEL: "Size and Position" adjustments might not be retained after X restart or after system resumes from sleep
  • 1080i30 and 1080i25 HDTV modes may fail to apply for HDMI/DVI/DP displays
ATi Catalyst  Linux Display Driver logo (410 pix)
Moderatie-faq Wijzig weergave

Reacties (23)

Eindelijk X.org 7.5 support! De Fedora 12 gebruikers zullen nu ook wel blij zijn na een half jaar zonder Catalyst drivers te draaien.
Yihaaa! inderdaad. radeon drivers herkende de chipset van mijn 5850 niet dus ik moest terug naar vesa drivers, waarbij het maar niet lukte van widescreen te gaan. Daarmee was Fed effectief gehandicapt voor een half jaar...
Ik kan nergens vinden dat deze drivers ook werken met de ATI Mobility Radeon HD 5165? Klopt dat? Of bied Ubuntu daarvoor zelf ondersteuning met drivers?
Ik wordt wel een beetje moedeloos van ATI. Ik gebruik al 10 jaar Linux i.c.m. nvidia, al die tijd heb ik niet zoveel ellende gehad als in mijn half jaar met ATI. Ik hoop dat de kwaliteit en de snelheid verbetert anders wordt het de volgende keer weer nvidia.
Ik wordt wel een beetje moedeloos van ATI. Ik gebruik al 10 jaar Linux i.c.m. nvidia, al die tijd heb ik niet zoveel ellende gehad als in mijn half jaar met ATI
Precies hetzelfde verhaal hier.

Ik moet nog wat extra tweaken, maar de 2D performance met fglrx is out-of-the-box echt embarmelijk. Het resizen van een venster is extreem laggy, duurt ongeveer 2 seconden voordat de gnome-terminal geresized is. Voor dagelijks gebruik is dat gewoon onwerkbaar.

Ik heb een (3 jaar oud) Notebook met een NVidia mobile erin en daar is alles gewoon snappy. Mijn desktop met Intel Dual Core, 8GB geheugen, ATI 4870 icm fglrx voelt aan alsof ik Windows Vista probeer te draaien op een Pentium III .

Ik denk dat het terug naar de open source driver word voor mij.

[Reactie gewijzigd door JUDGExKTF op 30 april 2010 14:50]

Dan doe je iets fout.
Resizen van welk venster dan ook gaat hier prima. Het probleem dat jij beschrijft kun je op eenvoudige wijze verhelpen. De oplossing staat ongetwijfeld beschreven in de docs van je distro, anders geldt mijn tip om een topic op het forum te openen nog steeds.
En wat erikdenv hierboven zegt; check de gentoofora even, daar is veel kennis en ervaring op gedocumenteerd.
Bij mij werkt het niet heel traag, ik heb er voornamelijk last van gehad dat de drivers niet werkten met de nieuwere versies van Xorg. Ook ondersteunt de ATI (volgens mij) geen breedbeeldresoluties in tekstmodus. Dat deed de nvidia wel.

[Reactie gewijzigd door erikdenv op 4 mei 2010 09:17]

Hoi, ik begrijp dat je problemen ondervind bij het gebruik van ATIkaarten in combinatie met linux. Als je een topic opent in het forum met je probleembeschrijving kan iemand je misschien helpen.

Ik gebruik met veel plezier een hd4870 met de catalystdriver onder opensuse, en heb ook goede ervaringen met andere distributies.

[Reactie gewijzigd door dragunova op 30 april 2010 11:28]

Hallo, ik heb een Radeon 5770 en moet dus met de Catalyst werken. De drivers die ik nodig heb zijn/waren niet erg stabiel en konden niet overweg met nieuwere versies van Xorg.
Dit lijkt dus met deze release opgelost, hij draait al twee uur stabiel :-)
Voor de rest red ik me wel m.b.v. het Gentoo forum, ik had alleen met nvidia minder problemen.

[Reactie gewijzigd door erikdenv op 30 april 2010 19:51]

ik denk dat dragunova bedoelde dat je niet hier, maar in het forum even je problemen kenbaar moet maken. Dit zodat hij of andere tweakers hun kennis met je kunnen delen.
Dat is heel attent maar ik kijk liever op het Gentoo forum. Dat is internationaal en (zonder beledigend te willen zijn) het niveau is daar hoger. Hier is het vooral Ubuntu en aanverwanten waarover gepraat wordt.
Wordt nu de 5000 mobility series al ondersteund dan?
Ik wil graag linux op m'n nieuwe laptop zetten, maar bij het installeren zegt hij keihard dat mijn videokaart niet herkend word.
Ik hoor positieve geluiden over de nieuwe Gallium3D driver. Voor gebruikers van oudere kaarten (R300) zou deze driver ook een goed alternatief moeten zijn.
Er wordt alleen nog weinig over geschreven. Ik ben benieuwd naar de nieuwe OpenSuse11.3 met een 2.6.34 kernel. Deze heeft ook betere KMS support voor R600 kaarten.
Er komt nog een hoop aan als ik de berichten op Phoronix moet geloven.
SInds de ingebouwde radeon driver redelijk fatsoenlijke ondersteuning voor 3d vernelling biedt heb ik geen catalyst drivers meer nodig. Daarnaast biedt de OS radeon driver ondersteuning voor KMS en werkt compiz wel naar behoren.

Als je niet naar maximale performance zoekt en je kaart wordt indersteund door de OS driver, wat is dan nog het nut van het instaleren van de catalyst driver?
Omdat veel mensen op zoek zijn naar iets meer dan "redelijk fatsoenlijke ondersteuning voor 3d vernelling" :).

Maar ff serious, Op dit moment zijn er behoorlijk veel functies die niet door de opensource variant worden ondersteund. In mijn geval bijvoorbeeld opencl functies die voor het programmeren relevant zijn.

Gebruik zelf nu ook de opensource driver, maar ben gelijk ook de eerst die over stapt naar catalyst als deze enigzins in de buurt komt van nvidia's driver kwaliteit.

Wie weet met het laatste nieuws van valve of de unigine engine dat linux gpu drivers een ontwikkel boost krijgen.
De snelheid (wat betreft 3D functionaliteit) van de opensource drivers is een stuk minder dan die van de closed source drivers. Het zal nog wel een tijdje duren voordat opensource drivers qua 3D performance in de buurt komen van closed source drivers.
"Ubuntu 10.04 early look support"
Zijn ze een beetje laat mij. Vandaag is de deadline van ubuntu.

Goede morgen: het is driver ipv software
Het werkt al langer met 10.04 maar nu is het "officieel".

@Lima
Ik draai al een paar weken zonder problemen de versie van fglrx die door ubuntu worden meegeleverd met 10.04, het probleem waar ik ooit melding van maakte met hun build van fglrx is ook weg. (wine render probleem)

[Reactie gewijzigd door Keeper of the Keys op 29 april 2010 14:24]

ik hoop dat tegen de final uitkomt alles dan ook naar behoren werkt...anders is het weer zo een grmbl waarom draai ik nu weer ubuntu gevoel...
Irritant dat er 0,0% support is voor oudere kaarten. Gelukkig is er nog de open source driver, maar ik vind het jammer. Het zit niet eens depricated nog in de binairy.
Waarom zou je deze binary blob in willen hebben voor oudere kaarten als de open source drivers stukken beter zijn?
OpenGL 2 om Heroes of Newerth te kunnen spelen op een r500 :)
OpenGL 2.0 ondersteuning voor bijvoorbeeld XBMC

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True