Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 24 reacties
Bron: Download Site SUN

Dankzij eddydonkers kwamen wij te Changelog

Lees meer over

Versienummer:1.4.0_01
Besturingssystemen:Windows 9x, Windows NT, Windows 2000, Linux, Windows XP, Linux x86, Solaris
Website:Download Site SUN
Download:http://java.sun.com/j2se/1.4/download.html
Moderatie-faq Wijzig weergave

Reacties (24)

Het spijt me zeer, maar ik vind deze software update toch wel heel erg slecht. Java is al niet makkelijk voor normale gebruikers en als deze mensen ook nog zo vaag geinformeerd worden, wordt het er geen haar beter op.

Een paar punten:

Allereerst gaat het om versie 1.4.0_01 en niet om versie 1.4.0.0.1. Wellicht gezeur, maar toch ;) . Deze laatste versie bevat trouwens alleen kleine, soms dringende, bug-fixes ten opzichte van de 1.4.0 versie die een tijd geleden uitkwam.

Ten tweede draai je met een Java Runtime geen .java bestanden. .java bestanden zijn namelijk Java source files en die moeten toch echt eerst gecompileerd worden. De Java Runtime voert daarom .class bestanden uit, maar bijvoorbeeld ook .jar bestanden, wat simpel gezegd een verzameling .class bestanden is.

Verder is de lijst operating systems wel heel erg enthousiast. Sun maakt alleen Java Runtime voor Microsoft Windows, Linux en Solaris. Je zult op de site van Sun tevergeefs zoeken naar downloads voor AIX, DOS, FreeBSD, HPUX, Irix, MacOS Classic, MacOS X, OpenBSD en OS/2.

Van deze lijst operating systems bestaan in sommige gevallen overigens wel implementaties, maar die worden door andere bedrijven verzorgd zoals bijvoorbeeld IBM en Apple. Omdat 1.4.0 nog heel erg nieuw is, zijn deze nog geen van allen bij deze versie aangekomen en zal je het dus moeten doen met een 1.3 versie in de meest positieve situatie.

Tot slot dan nog even de informatie voor de gewone gebruiker: je kunt deze Java 2 Runtimes van Sun inderdaad prima installeren op je Microsoft Windows PC of wat dan ook. Ze vertegenwoordigen de nieuwste versie van Java, waarop als het goed is de meeste Java applicaties en applets zullen werken. De Java 2 Runtime kan als plugin gebruikt worden in Netscape 6/7, Mozilla en Microsoft Internet Explorer (alles wordt automatisch geinstalleerd voor deze browsers). Microsoft mag hun eigen Java Virtual Machine niet meer verder ontwikkelen, dus dat is helaas een doodlopende weg geworden. Als je nog geen Java hebt (omdat je bijvoorbeeld Windows XP hebt) is dit dus een goede keuze.

Voor meer informatie over Java en Windows XP kan je naar de FAQ gaan van Windows Operated Systems op de GoT.
Nou, een heel vakkundig verhaaltje, ook erg leerzaam, maar helaas worden er op allerlei websites Java applets gebruikt die alleen normaal draaien in de Java Virtual Machine (als ik het goed zeg) die van Microsoft komt en door dat bedrijf zo bescheiden 'Microsoft Virtual Machine' wordt genoemd :Z

Wat ik hiermee bedoel is dat, ondanks dat Java van Sun komt en is, en ondanks dat dit de nieuwste versie is, het NOG MAAR DE VRAAG IS of dit inderdaad voor de gemiddelde consument de beste keuze is i.v.m. compatibility.

(Ik zou het ook graag anders zien maar de praktijk is nu eenmaal zo... net zoals Netscape door IE is verslagen - zie www.tweakers.net/nieuws/22207.)
Tja, helaas is het inderdaad zo dat er in het verleden veel programmeurs zijn geweest die hun applets alleen hebben getest in de Microsoft JVM of zelfs work-arounds specifiek voor deze JVM in de code hebben opgenomen. Dat is erg vervelend en het vormt ook zeker een probleem als je wilt overstappen op een JVM van Sun.

Het bijzondere aan deze situatie (tov van het browser-verhaal) is echter dat Microsoft hun product al tijden niet meer mag onderhouden na verschillende rechtzaken met Sun over aanpassingen (of dat nu verbeteringen zijn mag iedereen voor zich beoordelen) die Microsoft heeft opgenomen in hun implementatie. Hierdoor is er een product ontstaan wat eigenlijk al tijden enorm achterhaald is ten opzichte van de stand van zaken van Java op dit moment.

Omdat de Microsoft JVM dus een stopgezet product is zie je steeds meer sites die een recentere JVM vereisen of in ieder geval hun applet ook testen onder de recentere JVMs. Dat neemt uiteraard niet weg, dat er nog steeds problemen kunnen zijn met oude en slechte applets (en uiteraard altijd op jouw favoriete site ;) ).
Mocht je het ECHT nodighebben vanwege een of andere krukkige pagina die alleen werkt met een antieke JVM: nadat je de java-plugin hebt geinstalleerd kun je deze altijd nog ff disablen door een checkbox in de settings van je browser ff uit te zetten (NS, IE; Opera nog niet maar dat boeit niet want die heeft geeneens een "oude" JVM van zichzelf).
Het mooie aan de virtual machine van microsoft was dat hij automatisch meegeinstalleerd werd en geen download hoefde te doen van een paar mb om een JAVA progje te draaien.

Omdat veel mensen geen breedband hebben en niet eens weten wat java is en dus gewoon snel naar een andere site surfen als het niet gelijk werkt, lijkt het mij logisch dat men voor dat ding van microsoft kozen.
(btw. ik zeg dus helemaal niet dat vm van microsoft beter is)
Erg jammer dan SUN er niet voor gezorgd heeft dat de laatste java-plugin gewoon in de windows Servicepacks en Autoupdate terecht is gekomen; met al die rechtszaken tegen Microsoft hadden ze toch op z'n minst zoiets voor elkaar moeten krijgen.
De meeste mensen met Windows XP hebben Javan toch al op hun PC staan omdat als je naar een site gaat die Java nodig heeft XP meteen vraagt om het te downloaden :)

En bij Windows Update staat tie ook in de lijst :)
Dan krijg je de inferieure Microsoft Java client toegestuurd. Deze neemt naar mijn mening veel te veel processortijd in beslag en crashed zelfs als ik hem tevaak opstart.
Dat ligt dan aan jouw PC want bij mij doet tie het perfect :)
Maar aankomende Service Pack vliegt die er toch uit in favor voor die van Sun
In favor voor Sun?? jij bent gek. Ze geven de versie 1.1.4 mee. Die is geloof ik al een jaar of 3 tot 4 oud en is dus nog een Java 1 API terwijl 1.3 en 1.4 Java 2 zijn.
Inderdaad. Zodra je XP hebt geinstalleerd en je start IE op krijg je de MSN pagina te ziek. En rara wat gebeurt er, je krijgt een popup om JVM te installeren. :Y)
Hoera :*)

is het eigenlijk aangeraden om dit te installeren als "gewone" gebruiker :?

edit: lol wie zit me hier als grappig te modden? was een first post hoor :Y) (was hier beetje leeg dus wou het hier wat opvulleh)
Nou ja waarom niet?

Er zijn een hoop bugs opgelost dus het is nooit zinloos. :)
m'n vraag was een beetje of dit voor developers of end-users was... heeft mbravenboer ondertuusen verduidelijkt hieronder :)

geef die man maar snel +4 behulpzaam !
nee ik denk het niet, voor gewone gebruikers is ms java goed genoeg.
Ik vond de vorige versie van de sun java runtime zwaar k** > 600 mb geheugen gebruiken!! en niet eens compatible te zijn met alle java vensters. (dit komt weer omdat veel geprogrammeerd word voor ms java en niet de echte java)
tering, zo'n changelog voor een 0.0.1 upgrade :D
Heeft iemand misschien mirror want ik krijg hem niet helemaal gedownload. Getright stopt telkens bij 96%.

Edit: Het lag aan Getright. Ik heb hem nu gedownload zonder Getright.
WTF doet dit ding eigenlijk? M'n bankprogramma werkte niemeer na installatie hiervan.. na removal doet't weer perfect.
Zoals ik al eerder zei: :Z deze versie van java is al een maand uit ofzo... Waarom dan nu dit bericht? Maar ja mijn bericht was verwijderd hier...

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True