Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 10 reacties
Bron: nV News, submitter: cold

Nvidia heeft nieuwe Display Drivers voor Linux, FreeBSD en Solaris op zijn ftp-server beschikbaar gesteld. De nieuwe drivers hebben versienummer 185.19 bèta meegekregen en kan voor x86- en x86-64-systemen worden gedownload. Deze stuurprogramma's bieden onder meer ondersteuning voor de Quadro FX 580- en 3800-kaarten en de GeForce GTS 250-videokaart. Verder zijn er nog een aantal bugs uit de drivers gehaald. Welke dat precies zijn, kan hieronder gelezen worden:

Release Highlights:

  • Added support for the following new GPUs:
    • Quadro FX 3800
    • Quadro FX 1800
    • Quadro FX 380
    • Quadro FX 580
    • GeForce GTS 250
    • GeForce GT 140
    • GeForce GT 130
    • GeForce 9600 GSO 512
  • Fixed SDI presentation time queries returning unexpected values.
  • Removed the 'AllowDFPStereo' X config file option, which is now enabled by default.
  • Fixed a bug that caused certain programs to hang when multiple threads call functions in libdl at the same time.
  • Fixed a driver crash when OpenGL applications use an extremely large number of textures.
  • Text rendering to PseudoColor windows with the glyph cache enabled no longer causes GPU errors.
  • The X driver now allows pixmaps smaller than 32x32 pixels to be placed in video memory.
  • Fix a problem that prevented the driver from retraining a DisplayPort link after a device is hotplugged.
  • nvidia-bug-report.sh now automatically gzips the resulting log file.
  • Fix VDPAU to eliminate some cases of GPU hangs when decoding H.264 video on G84, G86, G92, G94, G96, or GT200 GPUs, and supplying a DPB missing some reference frames.
  • The VDPAU presentation queue now syncs to VBLANK in the blit path. The environment variable VDPAU_NVIDIA_SYNC_DISPLAY_DEVICE selects which display to sync to when TwinView is enabled; see the README for details.
  • On systems using integrated graphics, VDPAU now uses system RAM instead of video RAM for many purposes. This should prevent "out of resources" problems in most cases, even when the video RAM carve-out is configured as low as 128M.
  • Added support for Quad-Buffered Stereo in the main plane simultaneously with the Color Index Overlay; i.e., both Stereo GLX FBConfigs and Color Index Overlay FBConfigs can be advertised and used at the same time, though no single GLX FBConfig contains both Stereo and Overlay capabilities.
Versienummer:185.19 bta
Releasestatus:Beta
Besturingssystemen:Linux, BSD, Linux x86, Solaris, Linux AMD64
Website:nV News
Download:ftp://download.nvidia.com/XFree86/Linux-x86/185.19/
Licentietype:Voorwaarden (GNU/BSD/etc.)
Moderatie-faq Wijzig weergave

Reacties (10)

Zojuist geinstalleerd op Ubuntu Jaunty Beta...
Vind het altijd eng, als die tijdens het uninstalleren van de vorige driver een foutmelding geeft, 1 of andere file die geen symbolic link is ofzo??

Maar verder werkt die gewoon, heb ervoor gekozen om niet config file niet te updaten...had bij de vorige update toen gelijk geen werkende driver meer.
Zou je eens uit kunnen leggen hoe je zo'n driver onder Ubuntu installeert? Hier ben ik helaas nog niet achter.
Ik zal beschrijven hoe ik het heb gedaan,

-Download NVIDIA-Linux-x86-185.19-pkg1.run
Dan moet je je Xserver uitschakelen, dmv:
-ctrl-alt-f1
-tik dan in "sudo /etc/init.d/gdm stop, en dan je wachtwoord.
-en dan tik je in "sudo sh NVIDIA-Linux-x86-185.19-pkg1". Gewoon de hele tijd op OK klikken, en zo werkte het bij mij.. Ik kreeg overigens ook nog de foutmelding dat hij geen verbinding kon maken met de server van nvidia, maar dat maakt niks uit.
Een tip: maak van tevoren een backup van /etc/X11/xorg.conf. Mocht je configuratiefile dan verkeerd overschreven worden, dan kan je je backup terugzetten.
De Nvidia Installer maakt al een backup voor je.
zoek in het menu eens naar "Hardware Drivers" dit programma kan Nvidia installeren. Kubuntu komt hier overigens zelf ook mee als er een update is met een notificatie in de tray, dit zal in Ubuntu niet anders zijn.

[Reactie gewijzigd door DummyXL op 11 april 2009 09:17]

Waarschijnlijk is je symbolic link niet heel erg belangrijk, dit komt wel vaker voor. Wil je het echt zeker weten zul je toch even op de exacte foutmelding moeten zoeken.

Configuratie hoef je in principe ook niet bij te werken, veel bijzonders staat er doorgaans ook niet in deze configuratie wat gerelateerd is aan de nvidia driver (wat definities dat Xorg de driver moet gebruiken). Het meeste gaat tegenwoordig toch steeds meer naar automatische detectie....
Nog schokkende venters onder KDE 4 met deze versie?? als je het vergroot/verkleind?
Dat was tot nu toe bij mij nog wel het geval en dat is storend. ;(
Ik heb nu geen mogelijkheid om het te testen vandaar dat ik het hier vraag.
@cumulus007: dat zou kunnen maar dan wordt het tijd dat het KDE team hier mee bezig gaat het werkt echt niet lekker, maar ik kan mij herinneren dan KDE Nvidia de "schuld" hiervan had gegeven omdat de drivers niet goed werkte met KDE 4 (ati is wel goed)

[Reactie gewijzigd door DummyXL op 10 april 2009 20:11]

Dat schijnt iets te zijn bij Qt en/of KWin, ligt dus niet aan Nvidia.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True