Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 10 reacties
Bron: Nvidia, submitter: Chrissieboy

Nvidia heeft nieuwe Linux Display Drivers voor x86- en AMD64/EM64T-systemen beschikbaar gesteld. De nieuwe stuurprogramma's hebben versienummer 180.29 meegekregen en zijn van de nodige verbeteringen voorzien. Zo ondersteunen de Linux Display Drivers voortaan ook de GeForce 9300 GE- en Quadro NVS 420-videokaarten en is het mogelijk om op GeForce 8-videokaarten en nieuwer OpenGL 3.0 te draaien. De release highlights van versie 180.29 staan hieronder gepost:

Release Highlights

  • Added support for the following GPUs:
    • GeForce 9300 GE
    • Quadro NVS 420
  • Added support for OpenGL 3.0 for GeForce 8 series and newer GPUs.
  • Fixed a bug that caused VDPAU to display a green screen when using the overlay-based presentation queue with interlaced modes.
  • Fixed a bug that prevented VDPAU from working correctly after X server restarts on some GPUs.
  • Improved VDPAU's handling of mode switches; eliminated a crash in its mode switch recovery code and a hang in the blit-based presentation queue.
  • Fixed a bug that caused VDPAU to crash when using DisplayPort devices.
  • Fixed a potential hang in VDPAU when using the blit-based presentation queue on systems with multiple GPUs not in SLI mode.
  • Implemented missing error checking of layer data in VDPAU's VdpVideoMixerRender function.
  • Improved VDPAU's handling of setups with multiple GPUs, if a subset of the GPUs cannot be supported due to resource limitations.
  • Improved GPU video memory management coordination between the NVIDIA X driver and VDPAU.
  • Fix potential hang in VDPAU when the overlay is already in use.
  • Improved workstation OpenGL performance.
  • Fixed an X driver acceleration bug that resulted in Xid errors on GeForce 6 and 7 series GPUs.
  • Updated the X driver to consider GPUs it does not recognize supported, allowing it to drive some GPUs it previously ignored.
  • Added the ability to run distribution provided pre- and post-installation hooks to 'nvidia-installer'; please see the 'nvidia-installer' manual page for details.
  • Updated the X driver's metamode parser to allow mode names with periods (i.e. '.'s).
  • Fixed a problem in VDPAU that prevented the overlay-based presentation queue from being used on displays connected by component video.
  • Fixed various problems in VDPAU that caused visual corruption when decoding certain MPEG-2 video streams.
  • Fixed a crash in VDPAU caused by certain invalid MPEG-2 streams, in 64-bit drivers for some GPUs.
  • Fixed an X driver performance problem on integrated GPUs.
  • Fixed a stability problem with OpenGL applications using FSAA.
  • Fixed an initialization problem that caused some AGP GPUs to be used in PCI compatibility mode.
  • Fixed a bug that could result in stability problems after changing clock settings via the Coolbits interface.
  • Fixed a problem with hotkey switching on some recent mobile GPUs.
  • Worked around a power management regression in and improved compatibility with recent Linux 2.6 kernels.
Versienummer:180.29
Releasestatus:Alpha
Besturingssystemen:Linux, Linux x86, Linux AMD64
Website:Nvidia
Download:http://uk.download.nvidia.com/XFree86/Linux-x86_64/180.29/NVIDIA-Linux-x86_64-180.29-pkg2.run
Bestandsgroottes:20,00MB t/m 20,70MB
Licentietype:Voorwaarden (GNU/BSD/etc.)
Moderatie-faq Wijzig weergave

Reacties (10)

OK... ik heb via nvnews.net en met de ppa van andersk zowel de 180.29 drivers van NVIDIA als mplayer met VDPAU support weten te installeren.

Een "mplayer -vc help | grep vdpau" geeft een OK bij alle codecs, maar geen van de codecs die ik probeer in combinatie met "-vo vdpau" en wat hd samples (vmw en h264) resulteert in goed afspelen. OF mplayer crasht met een error, of het eerste frame van de video verschijnt en verder niets :S.

[edit]
Hmmm.... turns out dat mijn GeForce 8500GT alleen maar 2 h.264 en verder mpeg1/2 profilen ondersteunt :). In ieder geval werkt het met een 3-tal mkv filmpjes die ik op internet heb gevonden.

In ieder geval erg impressive! Ook mooi om te zien dat erin het XBMC team inmiddels werk onderweg is voor VDPAU. Een versie met VDPAU support werkt al heel basic :).

[Reactie gewijzigd door eymey op 15 februari 2009 22:12]

Hmmm... een mooie reeks verbeteringen!!! Ik heb nu nog steeds een losse NVIDIA kaart in een AMD AM2/ 690G based systeem zitten vanwege de nog steeds net te slecht werkende ATI support en met VDPAU erbij met al een paar bruikbare implementaties loopt NVIDIA alweer voor.

Nu moet alleen VDPAU support nog mainstream worden in mplayer en andere video players :)
Het zit al in de nieuwe mplayer en ook in MythTV, Xine, VLC en FFmpeg.
Zitten die dan ook al in de main stream releases van deze respectievelijke projecten?

Ik weet wel dat iemand Ubuntu packages bijhoudt van de pakketten, maar dan nog met behulp van patches.
Releasestatus: Alpha

Is het wel slim om deze dan te installeren? Ubuntu 8.10 draai ik,
een 8400mg
Hangt er vooral vanaf wat je nu draait. Je kunt hem altijd installeren, kijken of je geen negatieve dingen ondervindt en anders weer terugdraaien. Over het algemeen heb ik goede ervaringen met de releases die hieraan vooraf gingen. Maar ik gebruik mijn systeem dan weer niet als desktop, enkel als HTPC.
Is het wel slim om deze dan te installeren? Ubuntu 8.10 draai ik,
een 8400mg
Voor de 180.x serie is er ook een stable release: 180.22.
Voor Compiz-GNOME is er niet veel nieuws onder de zon voor normaal dekstopgebruik. Alleen VDPAU, natuurlijk, ten opzichte van de 177.x versie.
Voor KDE4.x (Kubuntu) gebruikers is er in de 180.x serie grote voorsprong gemaakt in de performance met de comopisitor KWin, ten opzichte van de 177.x versie.

Versie 180.11 zit in intrepid-updates dus zal je al moeten kunnen installeren via simpele restricted hardware drivers tool in Ubuntu. Verder is er een PPA van andersk die je de 180.29 geeft. :) Beetje nettere manier dan de .pkg van NVIDIA uitpakken. :)
Jammer dat er op de page een build-error aangegeven wordt voor de 180.29 package :)

Ik vraag me af wat dit is:
Fixed an X driver performance problem on integrated GPUs
Ik heb namelijk op een van mijn MythTV boxen een behoorlijk performance probleem en 180.22 hielpen daar niet echt mee.
Jammer dat er op de page een build-error aangegeven wordt voor de 180.29 package :)
Hij build(t) niet goed voor alle architectures. Voor i386 en amd64 prima.
Om maar even een helpende hand te bieden, de 180.11 driver kan in Intrepid makkelijk geinstalleerd worden middels dit commando:

sudo apt-get install nvidia-glx-180

Ik vind het zelf niet slim om drivers te installeren zonder DKMS support, omdat je dan problemen krijgt bij het upgraden van je kernel. En dit gebeurt zo af en toe wel eens als je de reguliere updates bijhoudt van Ubuntu.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True