Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 28 reacties
Bron: Amd

AMD logo (60 pix) Twee dagen na het uitkomen van versie 8.1 van de ATi Catalystdrivers voor Windows is dat nu ook voor Linux het geval. Sinds versie 7.11 wordt het versienummeringssysteem, wat door Amd voor de ATi Catalyst drivers onder Windows wordt gebruikt, nu ook voor de Linuxvariant toegepast: het eerste nummer voor het jaartal, gevolgd door de maand van uitgave. Versie 8.1 van de Linux-driver kan overweg met versies 6.7 tot en met 7.3 van X.org, Linux Kernel 2.6 en hoger en glibc 2.2 of 2.3. Linux Kernel 2.4 en XFree86 4.3 worden niet langer ondersteund. De laatste versie die dat deed was versie 8.42.3. De release notes van Catalyst Linux Display Driver 8.1 zien er als volgt uit:

New Supported Operating Systems
  • RedHat Enteprise Linux 5.1
  • RedHat Enteprise Linux 4.6
  • Ubuntu 7.10 (Gutsy Gibbon)
Resolved Issues
  • Corruption will no longer be noticed in the lower right corner of the display or on the mouse pointer after the system is running for a long period of time
  • Connecting a display device that supports 1680x1050 to a system running Linux will no longer result in a maximum display resolution of 1280x1024 only being available
  • Custom mode lines in xorg.conf will no longer be ignored by the fglrx driver
  • Suspending to RAM or DISK on kernel version 2.6.23 or later no longer fails
Known Issues
  • On workstation hardware 3D applications will be corrupted if the screen width is not an integer multiple of 64 pixels, for example with a 1680x1050 wide screen display. Further details can be found in topic number 737-31720
  • There is no support for video playback on the second head in dual head mode. Further details can be found in topic number 737-26985
  • Desktop corruption may be noticed when dragging the overlay/video when using dual-display mode. Further details can be found in topic number 737-29578
  • A black screen may be observed on some hardware when switching to the console or leaving the X window system when a Vesa framebuffer console driver is used. Further details can be found in topic number 737-30687
  • Display flicker may be noticed when the gnome screen-saver starts
  • Diagonal tearing may be noticed when playing a video file using a video player that utilizes the XVideo extension
  • Video playback may look blocky when playing a video file using a video player that utilizes the XVideo extension
  • Video Playback may display wrong colors and additional shadow images when cropping or expanding a video file using a video player that utilizes the XVideo extension
  • Building RPM packages for Mandriva may fail
[break]
ATi Catalyst Linux Display Driver logo (410 pix)

Lees meer over

Versienummer:8.1
Releasestatus:Final
Besturingssystemen:Linux, Linux AMD64, Linux IA-64
Website:Amd
Download:https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-8-01-x86.x86_64.run
Bestandsgrootte:50,20MB
Licentietype:Voorwaarden (GNU/BSD/etc.)
Moderatie-faq Wijzig weergave

Reacties (28)

Worden de HD 3870 en HD 3850 nu dan wel ondersteund? Staat iig niet op de lijs tin de site. Mijn OpenSUSE doet vrij weinig sinds ik laatst ATI drivers er op gooide met het idee dat de laatste driver wel support zou hebben... Not dus. En ja, ik ben een noob op Linux gebied dus voor in OpenSUSE er weer opnieuw opgooi wil ik wel weten of de driver al werkt op mn HD 3870...
Als je naar de ATI driver download pagina gaat kun je links het OS selecteren, midden de product family en rechts type. Dan zie je dat b.v. onder Windows XP de X1950 en HD38x0 er bij staan en onder Linux niet.

Ik wacht dus ook nog steeds op Linux support voor mijn X1950 XTX (PCIe), tot nu toe blijft het beeld in grafische mode zwart en is alleen een vage 400x300 achtige textmode beschikbaar op de single user console. Het rare is dat de splashscreen van Kubuntu (7.10) met het balkje wel werkt, alleen gaat daarna alles op zwart. Ik zou al blij zijn om daarmee aan de gang te kunnen, nu kan ik beter via ssh op een andere bak werken..

Edit: @GENETX: dat dacht ik ook dus heb ik ook geprobeerd fb/vesa driver te gebruiken i.p.v. ati in xorg.conf en in alle gevallen gebeurt hetzelfde. Ook verschillende VESA console modes met vga=nnn op de kernel regel hebben als resultaat of zwart scherm of een hele lage textmode resolutie met iets van een kwart van het scherm zichtbaar, en niet eens links boven, dus onbruikbaar.

Ik vermoed dat ATI de 1950 en 38x0 reeksen als gamer kaarten beschouwt (die ook nog eens niet zo veel worden verkocht als de mainstream kaarten) en als zodanig een lage prioriteit hebben voor wat betreft Linux ondersteuning. Wel jammer dat ook de basics niet werken.

[Reactie gewijzigd door aTmosh op 19 januari 2008 20:52]

Ja, heb wel iemand gezien op internet die zei dat het wel werkte op zijn HD 3870..

Iig kan ik jou stuk wel verklaren: De driver wordt pas op het laatst geladen. Loadscreen is dan ook prima op de standaard universele VESA driver. Zerlfde voor de console. Echter niet wanneer X.org wordt gestart met de driver, dan wekrt hij neit en blijft het zwart. Same here.
lol, de x1950 is al zeer lang ondersteunt
de hd38xx is ondersteunt sinds de 8.11 7.11 release, deftige support kwam bij de 8.12 7.12 release

en als het dan nog niet werkt, kan je ook nog de OSS driver gebruiken die ook beide kaarten ondersteunt

//edit
gefixed, ik bedoelde idd 7.11 & 7.12
Ik denk dat die install scripts niet meer door ati gemaakt worden maar door de mensen @ phorogit waardoor support voor nieuwe distributies verbeterd is

[Reactie gewijzigd door oeLangOetan op 21 januari 2008 14:01]

Eh, hoe wil je bij Catalyst boven de 8.1 komen als dit de eerste maand is van het jaar? 8.11 en 8.12 worden pas over 10 en 11 maanden uitgegeven. Je zal wel 7.11 en 7.12 bedoelen. Op GoT is er ook iemand met een HD38x0 kaart en werkt prima onder zijn Ubuntu.


Een ding vind ik wel vreemd. Waarom nu pas zeggen dat er Gutsy support is terwijl hij het altijd al deed? Bedoelen ze dat de installer nu op Gutsy draait? Want ik installeer eigenlijk altijd via 'bash ./atidriver.run --buildpkg Ubuntu/gutsy' en werkt prima. Staat ook zo op de Ubuntu howto site.
Nog steeds flicker in OpenGL apps met een AIGLX/Compiz-Fusion setup. Idem voor video afspelen en scrollen is nog steeds even traag :'(
Connecting a display device that supports 1680x1050 to a system running Linux will no longer result in a maximum display resolution of 1280x1024 only being available
Ik probeerde laatst even een wat oudere versie... en ik liep hier tegen aan (kwestie van lezen, want het was een known issue), maar ben blij dat dit opgelost is!!!

Lekker dat er nu ook support for Gutsy is... !
Zal een monitor van 1920x1200 dan terugschakelen naar 1680x1050 of lager?
Support voor Gutsy is er nu dan, maar ik kan verschillende programma's ineens niet meer opstarten. ('BadAlloc (insufficient resources for operation)') Wel prettig dat het beeld rechtsonder nu gewoon goed blijft. Morgen eens kijken op het forum of iemand meer mijn fout heeft.
Die had ik gisteren ook... Ik denk dat er een foutje in een Xorg module is geslopen. Er was vanochtend (Australische tijd) een update en ik heb er nu geen last van die BadAlloc...

Update op de driver zelve: installeert prima, alleen ik kan geen fglxrinfo of de control center opstarten, omdat ik dan een soort van kernel hangup krijgt, waar het beeld bevriest en niets meer reageert behalve uitzetten (ok, geen SysRq geprobeerd, maar geen zin in ;))
hehe, 1 maand op 2x1280x1024 was erg.... |:( begon er al bijna aan te wennen 8)7 Gelukkig nu weer een desktop van 3360x1050 en direct rendering :>

Installatie op Mandriva 2008.0 x86-64 ging feilloos, had wel een rebootje nodig om de direct rendering aan de gang te krijgen.
De drivers zijn een stuk beter dan de 7.11 (7.12 heb ik overgeslagen omdat mijn 1680x1050 monitor niet de volle resolutie gaf). De drivers zijn veel sneller (ruim de dubbele framerate, 2D scrollen is veel sneller als de computer zwaar belast is). Alleen het opstarten duurt wat langer.

Ook het flikkeren van video samen met beryl is een stuk minder. Het is nog niet goed, maar wel beter.

Overigens kan ik iedereen aanraden om de optie "TexturedVideo" aan te zetten. Je hebt dan namelijk 4 video overlays in plaats van 1. Dat werkt ook op een bord waar geen avivo in zit, ik draai het op een 9600XT. De video overlay wordt dan met de 3D hardware geregeld in plaats van met de AGP overlay.

Er is nog wel een weg te gaan maar het lijkt erop dat de aandacht die AMD aan drivers besteedt vruchten af begint te werpen.
Wel vaag trouwens. Ik had de vorige driver gewoon geinstalleerd op mijn X800 op Feisty en ik had prima 1680x1050 beeld. Ik hoor hier allemaal mensen met problemen enzo. Ik zit nu alleen te kloten met deze 8.1 op Hardy te krijgen (niet officieel gesupport enzo).
Het heeft er mee te maken of 1680x105 in de officiele VESA lijst zit die de kaart met DDC uit de monitor haalt. Zat de officiele VESA mode in de gewone lijst dan werkte het. Stond hij in de lijst met 'Future modes' dan werkte het niet. De 7.12 driver keek alleen in de eerste lijst (misschien ook nog kaartafhankelijk, dat weet ik niet), de 8.1 kijkt altijd in beide.

Toen mijn monitor uit kwam had Vesa nog geen officiele mode voor 1680x1050, vandaar dat die er nog als 'future mode' in staat. Vesa wacht altijd welke modes er echt boven komen drijven voor ze iets standaardiseren. Tegen de tijd dat iedereen er al vanaf stapt doet Vesa ook eens iets....
inmiddels geprobeerd maar op mijn X1600 was ik direct weer DRI support kwijt. M.a.w. geen GoogleEarth om maar wat te noemen. Met de december editie werkt dat wel dus teruggerold.
En nog steeds bedroevendheid met deze drivers......

Ik heb twee PC's met een Asus M2a-VM hdmi met een onboard Radeon 1200 nogwat chip.... en het hoogtepunt met deze driver versie is dat m'n pc gewoon crasht als X probeert up te komen. Een paar keer flikkeren van het beeld en vervolgens kan ik de aan/uit knop gebruiken.....

Nee, dan blijf ik toch nog maar een tijdje de Geforce 8500GT kaart van NVIDIA van m'n ouders lenen (die gebruiken 'm toch niet :D). Erg zonde van de vele aansluitmogelijkheden van het moederbord, maar in ieder geval heb ik drivers die zonder gezeik werken.....

En ja, ik weet dat AMD nu hard bezig is om de drivers te verbeteren, maar dat levert me tot nu toe nog steeds geen betrouwbaar en bruikbaar systeem op....
Onder OpenSuSE 10.3 x64 levert deze driver hier op de Asus M2A-VM HDMI geen problemen meer op. De 3D performance is matig maar dit is voor het eerst in lange tijd dat ik bruikbare ATI drivers heb. Scherm corruptie lijkt weg te zijn, GLX ondersteuning werkt ook, AMDCCCLE ook. Op 1280*1024 werkt het allemaal wel redelijk hier en dat was met voorgaande versies wel anders.

Zo gauw de performance van de RadeonHD drivers beter wordt switch ik maar vooralsnog is deze driver de best presterende optie voor gebruik van onder andere Virtualbox.
Al 2 x een zwart scherm gehad en "no signal" met die nieuwe drivers.
Heel appart. In het begin deed hij het nog wel.. Na de unlock bij overdrive en een herstart die schermen. Denk dat ik maar een drivertje terug ga.. Of die CCC verwijder.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True