Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 21 reacties
Bron: Amd, submitter: rutger83

AMD logo (60 pix) Advanced Micro Devices heeft onlangs nieuwe display drivers voor Linux uitgebracht. Ze hebben versienummer 8.31.5 meegegeven, kunnen hun werk doen op alle kaarten vanaf de Radeon 9500. Anders dan dat we van ATi gewend waren is er nu slechts één download, die geschikt zijn voor zowel een 32-bits als een 64-bits omgeving. De downloadgrootte daarentegen is gegroeid naar zo'n 55MB. Hieronder zijn de belangrijkste zaken uit de release notes te vinden:

System Requirements
  • XOrg 6.7, 6.8, 6.9, 7.0, or 7.1; XFree86 version 4.3
  • Linux kernel 2.4 or higher
  • glibc version 2.2 or 2.3
  • POSIX Shared Memory (/dev/shm) support is required for 3D applications
  • The AMD Proprietary Linux driver no longer provides precompiled Kernel Modules; all installations require GCC compiler and kernel-headers or kernel-source in order to enable 2D and 3D acceleration.
Resolved Issues
  • Setting the display resolution to 400x300 or less no longer results in the mouse pointer not being able to move across the entire desktop.
  • The graphics driver no longer hangs the system shortly after the X Server is started on Red Hat enterprise Linux 3 system running Uniprocessor kernels.
  • Playing a media file under any distribution with X Server 6.9 or greater no longer results in a brief pause or video tearing when resizing the video window or running the mouse pointer over the video player window.
  • Using aticonfig to set the TV format to PAL-COMB-N no longer fails to update the X Server configuration file.
Known Issues
  • Attempting to install the AMD Proprietary Linux driver on distributions that have updated certain 3D components outside of the stock XOrg 6.8.2 may result in the driver not initializing 3D applications properly.
  • Loading the XVideo Extension on 64-bit Xorg 6.9+ systems causes the X Server to segfault on launch with Radeon X1K products.
  • A system hang may occur when attempting to resume from hibernation mode.
[break]
ATi Catalyst Linux Display Driver logo (410 pix)

Lees meer over

Alle 25 producten

Versienummer:8.31.5
Besturingssystemen:Linux, Linux AMD64, Linux IA-64
Website:Amd
Download:https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-8.31.5-x86.x86_64.run
Bestandsgrootte:55,70MB
Licentietype:Voorwaarden (GNU/BSD/etc.)
Moderatie-faq Wijzig weergave

Reacties (21)

De combinatie fglrx + AIGLX (+ Beryl) is nog steeds een no-go, want ze vertikken het bij AMD/ATi om een fatsoenlijke ondersteuning voor de Composite Extension van X.org te maken. Dus AIGLX blijft alleen voorbehouden aan NVIDIA-gebruikers. We wachten maar weer op de volgende..! :(
Ik gebruik XGL/Beryl op ubuntu dapper met ATI X1400 mobile. AIGLX mag ook geen probleem geven.

Wil niet spammen, maar heb een howto op mijn blog geplaatst hiervoor als je dat wat lijkt : http://www.decafranky.be
Ik gebruiken
?
Op je blog-howto staan trouwens geen nieuw dingen hoor, alles wat belangrijk is om te weten staat in feite hier: http://wiki.beryl-project.org/

En FYI: de 'fglrx' driver is van ATi en closed source, de 'radeon' driver is open source.

O en je kan je eigen posts gewoon aanpassen hoor ;)
ieps :-)

Omtrent linux howto's zal je nooit de eerste zijn om te posten. Zelf als eerste met nieuwigheden afkomen is beetje onmogelijk :-)

Reden waarom ik het gedaan heb, is omdat er tientallen zoniet hondertallen howto's bestaan omtrent xgl, helaas loopt het bij de meeste niet goed. Zelf heb ik een combinatie van meerdere howto's samengevat dewelke perfect werken op ATI.

Wat fglrx driver betreft : is idd deze van ATI & closed
decafranky dot be
Wat ontzettend kort door de bocht.

want ze vertikken het bij AMD/ATi om een fatsoenlijke ondersteuning voor de Composite Extension van X.org te maken

3 of 4 versies geleden was X.Org nog niet eens officieel ondersteund, die Composite Extension is ook net nieuw. De meeste drivers zijn pas net aangepast.
ATI heeft niet de beste support voor linux, maar er worden grote stappen vooruit gezet. En voor 90% (99%?) van de mensen leveren ze nu een functioneel werkende driver die een beetje performance bied. Dat is veel meer dan dat ze een jaar geleden aanboden.
Bijvoorbeeld: Waar Ubuntu 6.06 nog een speciale install nodig had voor ATI fglrx, heeft 6.10 hem al standaard in de multiverse zitten.

ATI is geen first-mover op linux gebied, dat is bekent, maar om te zeggen dat ze vertikken om support te bieden. Ze hebben al gereageerd dat er wat problemen zijn met die extensie en hun driver ontwerp. Dus linux wordt echt niet genegeerd, hooguit krijgt het niet de resources die een linux fanboy zou willen.
Waar Ubuntu 6.06 nog een speciale install nodig had voor ATI fglrx, heeft 6.10 hem al standaard in de multiverse zitten.
Of niet natuurlijk. De procedure is al jaren hetzelfde. Ik weet niet waar jij deze wijsheden vandaan haalt :?

De performance van de Ati-drivers (open-source en fglrx) is trouwens nog steeds zwaar kut te noemen. Nvidia heeft het allemaal veel beter geregeld.
Dus linux wordt echt niet genegeerd, hooguit krijgt het niet de resources die een linux fanboy zou willen.
Dus gewoon normale support willen (zoals nvidia al jaren geeft) maakt je een fanboy? lijkt me eerder dat JIJ je hier een fanboy toont omdat je schijnbaar alles maar pikt van de fabrikant (overigens zou ik mensen zoals jij graag als klant hebben)
Niet helemaal waar. Als je een oudere kaart hebt (bijv 9200SE), kan je de radeon drivers gebruiken. Deze zijn open-source en werken wel goed in combinatie met aixgl en beryl. :)
Ze zijn open source, maar niet van ATI zelf. Ze zijn ook heel wat trager dan fglrx (de ATI drivers).

Zolang ATI geen volwaardige specs voor hun kaarten leveren zitten we wat gevangen. ATI heeft ook net nu support voor veel oudere kaarten opgegeven waardoor je nooit het maximum uit die kaarten gaat halen als je AIGLX wilt draaien, want dan moet je wel de open source drivers gebruiken.
Dat dacht ik ook in Fedora Core 6, ff "desktop effects'' aanklikken en hoppa klaar; viel wat tegen :'( ...
het werkt wel met de mesa indirect GLX drivers, op 1 scherm dan, dual head kan je het vergeten
XGL werkt prima toch??
# POSIX Shared Memory (/dev/shm) support is required for 3D applications
# The AMD Proprietary Linux driver no longer provides precompiled Kernel Modules; all installations require GCC compiler and kernel-headers or kernel-source in order to enable 2D and 3D acceleration.
Zal ik daar last van krijgen als ik deze drivers op Ubuntu Dapper of Edgy zal willen installeren?
Lijkt me niet, Je kan ze zonder moeite compileren.
Op Dapper heb je daar 'build-essentials' voor nodig en op Edgy zijn alle compilerbenodigheden standaard al geinstalleerd.
Vergeet niet, je pkg maitainers zullen dit waarscijnlijk voor je doen dus je zult binnenkort vast een pkg drvan kunnen installeren (mits je een gepkgede kernel hebt)

Als je je eigen kernel hebt gebouwd, zul je de tools wel geinstalleerd hebben, teven wil je op dat moment toch je eigen driver wel compileren.
The AMD Proprietary Linux driver no longer provides precompiled Kernel Modules; all installations require GCC compiler and kernel-headers or kernel-source in order to enable 2D and 3D acceleration.
Betekent dit nu dat de driver (gedeeltelijk?) open source is geworden? En zo ja, welke licentie hanteren ze? Als dat GPL is is dat groot nieuws.

SciTech b.v. heeft net hun SNAP grafische driver framework in de verkoop gedaan vanwege de steeds slechtere medewerking van ATI en nVidia. Het zou frappant tijdig (en best stoer) zijn van AMD om die policies nu om te draaien (en eindelijk goede Linux ondersteuning te bieden).

Edit: @Ronald hieronder:
Dat weet ik, en juist daarom mijn vraag. De API glue moet al open source zijn geweest, dus als er sprake is van binary->source dan is dat niet logischerwijze (tenminste een gedeelte van) de driver zelf?

Even later: ik heb het opgezocht en die melding zit er al weer voor de 9e keer in (sinds 8.23.7), de laatste versie waar het niet in zat is 8.22.5 uit februari.

Volgens de FAQ:

Q4: Is complete driver source code available?

A4: Some of the technologies supported in our driver are protected by non-disclosure agreements with third parties, so we cannot legally release the complete source code to our driver. It is NOT open source. We do, however, include source code for the control panel and certain other public segments. We also actively assist developers in the Open Source community with their work, so if you absolutely require an open source driver for your graphics card, we can recommend using drivers from the DRI project, Utah-GLX project, or others.


Mijn vraag wordt dan: is het pas sinds 8 maart 2006 (8.23.7) zo dat de API glue open source is? Dat kan ik me nauwelijks voorstellen, dus wat is er dan sindsdien open source geworden? Of is het alleen zo dat naast de source men ook een precompiled module aanbood en dat sinds maart niet meer doet, maar alleen in source vorm? Maar goed, ik zou dit op een Linux forum moeten vragen :)
Zowel bij Ati als nVidia is de driver al jaren een Pre-compiled object, gecombineerd met een heeeeel klein stukje opensourcecode die het Pre-compiled object linked aan de huidige kernel.
ik begrijp er steeds minder van :'(

ik draai radeon mobility 8.30.03 op een amd laptop
die is niet meer te vinden.
Maar wel de 8.29.06 alleen van de radeon gewoon is er een update naar 8.31.5
waar zijn de updates van de mobility versie gebleven ?????
kan iemand mij vertellen of er grote verschillen bestaan tussen de laptop x700 en de gewone x700 (amd64) ati drivers
Waarom staat mijn x1800 GTO er niet bij.

Goed leuk dat ze linux drivers verbeter hulde alleen zou ik het ook erg fijn vinden als ATI (AMD) nog wat verder keek en ook begon aan de ondersteuning van de BSD's.
Ik heb in mijn 3 primaire computers 4 ATi kaarten zitten en eigenlijk wil ik ze allemaal naar linux en bsd verhuizen maar dat gaat niet tenminste ik heb het geprobeerd maar.
Alleen mijn 9500 lukt het een beetje mee de x1800 gto is a no-go.

(Zeker mijn mediacenter met Theater 550 pro niet)
Volgens mij is er nu weer een nieuwe versie die ook de Xorg 7.2 ondersteunt in SuSE 10.2
Ik heb het nog niet getest met 10.2 maar zag het in de releasenote https://a248.e.akamai.net...s/linux/linux_8.32.5.html

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True