Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 27 reacties
Bron: ATi, submitter: Carnifex

ATi logo (kleiner) ATi heeft enkele dagen geleden alweer nieuwe display drivers voor Linux uitgebracht. Ze hebben versienummer 8.28.8 meegegeven, kunnen hun werk doen op alle kaarten vanaf de Radeon 8500 en zijn beschikbaar voor een 32-bits en 64-bits omgeving als closedsource-driver. Naast enkele bugfixes zijn de meest noemenswaardige veranderingen ondersteuning voor ATi's Pairmode en zijn er geen aparte downloads voor iedere processor, maar 'ziet' de installer welk model 32- of 64-bits processor er in de machine zit. Het volledige changelog ziet er als volgt uit:

New Features
  • Display Switching Support for IBM/Lenovo Thinkpad Products
  • ATI Pairmode Support
  • Retaining Display Device State Between Restarts
  • New Product Support
    • Radeon Xpress 1200
    • Radeon Xpress 1250
    • Radeon Xpress 1300
  • Unified Linux Proprietary Linux Driver
Resolved Issues
  • Connecting a Dell Widescreen UltraSharp 2405FPW to the DVI port of any supported ATI product installed in a system running the X Server no longer results in the display failing to provide an image.
Known Issues
  • Attempting to install the ATI Proprietary Linux driver on distributions that have updated certain 3D components outside of the stock XOrg 6.8.2 may result in the driver not initializing 3D applications properly.
  • A system hang may occur when attempting to resume from hibernation mode.
  • Loading the XVideo Extension on 64-bit Xorg 6.9+ systems causes the X Server to segfault on launch with ATI Radeon X1K products.
  • Users with X Server X.org 7.1 can not play any video using XV. The ATI AVIVO Video adaptor is not present.
[break]De volgende downloads zijn beschikbaar:
*ATi Driver Installer version 8.28.8 voor 32-bits versie van Linux
*ATi Driver Installer version 8.28.8 voor 64-bits versie van Linux[break]
ATi Linux Driver logo

Lees meer over

Alle 25 producten

Versienummer:8.28.8
Besturingssystemen:Linux, Linux AMD64, Linux IA-64
Website:ATi
Download:https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=300
Bestandsgrootte:51,40MB
Licentietype:Voorwaarden (GNU/BSD/etc.)
Moderatie-faq Wijzig weergave

Reacties (27)

Voor installatie onder Ubuntu 6.06 klik hier
Super! Tnx! *O*

Net wat ik zocht :) :D ze werken prima hier!
Wat een gedoe zeg, dat zie ik een beginner echt niet zomaar voor elkaar krijgen. (no flame intended). Dat moet toch makkelijker kunnen?
automatix (boor ubuntu dus)
Met automatix kun je wel de Nvidia drivers installeren maar niet de ATI drivers (helaas)
Mag ik je erop attenderen dat het afgeraden wordt om Automatix te gebruiken? Het progseltje maakt wel vaker een aantal kunstsprongen en kan zo je gehele systeem breken. Gebruik is op eigen risico!
Wat een gedoe zeg, dat zie ik een beginner echt niet zomaar voor elkaar krijgen. (no flame intended). Dat moet toch makkelijker kunnen?
Tja, je bent een Tweaker of je bent het niet ;)
Om ATi drivers in SUSE Linux (aka openSUSE) en/of SLED 10 te krijgen, kun je de installation source of add-on http://www2.ati.com/suse toevoegen. Hierna kun je de drivers gewoon via YAST/YUM installeren of updaten

Oh en klikken op de link geeft geen resultaten... in YAST wel ;)
(Bron: Moosy)
Goeie tip! Ik heb met SuSe 10 echt heel lang zitten klooien om de 3D en openGL ondersteuning aan te krijgen. Uiteindelijk heb ik het aan de praat gekregen via deze coolsolutions Maar wat je zegt klinkt veel eenvoudiger en beter up-to-date te houden. Zal er nog even over denken of ik zal overstappen, ben al blij dat het eindelijk werkt.
Hmm.. ik krijg nog steeds alleen de [edit]8.26 bij de automatische update van Ati... de installation source staat gewoon op refresh, dus die zou moeten updaten...
en zijn er geen aparte downloads voor iedere processor, maar 'ziet' de installer welk model 32- of 64-bits processor er in de machine zit.
...
De volgende downloads zijn beschikbaar:
ATi Driver Installer version 8.28.8 voor 32-bits versie van Linux
ATi Driver Installer version 8.28.8 voor 64-bits versie van Linux
:Z
Dit klopt toch?

Hij kijkt welk model 32bits processor er in zit

of

Hij kijkt welk model 64bits processor er in zit
ATI Pairmode Support
Unified Linux Proprietary Linux Driver
Weet iemand wat dit inhoud?
Unified Linux Proprietary Linux Driver

zal wel, de manier van coden zijn, zodat het op alle linux-en werkt (althands dat zullen ze proberen)

ATI Proprietary Linux Driver Features

The ATI Proprietary Linux driver provides TV Output support for ATI graphics cards that support TV out. The ATI Proprietary Linux driver also allows for the following monitor arrangements:

* Single Head Mode (single display)
* Clone Mode (same content on both screens)
* Mirror Mode (same content on both screens, with identical display resolution and refresh rates)
* Big Desktop (one desktop stretched across two screens)
* Dual Head (separate instances of X running on each screen)
Unified Linux Proprietary Linux Driver

Dit is de 32 en 64 bit versies in een package pleuren zodat de gebruiker niet meer moet kiezen maar de computer bepaald welk deel hij moet installeren. (Alsof de gebruiker niet weet of hij een 32 of 64 bit proc heeft)

Zo hebben ze dus mooi de grootte verdubbeld(50 MB nu ipv 30 dervoor)
Zo hebben ze dus mooi de grootte verdubbeld(50 MB nu ipv 30 dervoor)
En ik maar denken dat 60 het dubbele is van 30 :*)
Sorry als dit een domme vraag is maar deze drivers werken toch ook met Xorg 7.0 want ik heb nu FC5 en ik heb nog geen poging durven doen om ATi drivers te installeren.

Als deze drivers werken met Xorg 7.0 welke versie kan ik dan het beste nemen qua prestaties met mijn overgeclockte Radeon 9550 SE (300 MHz / 200 MHz) :9 Ik heb een gewone ouderwetse x86 machine :Y)
Xorg 7.0 wordt al vanaf de 8.27.* serie ondersteunt en lijkt me dus dat deze ook gewoon werkt met deze versie. Het klopt inderdaad dat dit bij de 8.26.* serie nog niet werkte.
Ok bedankt voor je snelle antwoord. Ik heb inmiddels Fedora Core 5 aan het draaien (werk ik nu op) dus ik ga het snel proberen ! ;)
Om even dezelfde vraag te stellen, die ik bij de vorige versie in de meuktracker had geplaatst (versie 8.27.10):

Wat is het verschil van deze drivers en die ik van livna af haal?!? (Ik gebruik FC4...)
Geen,
buiten dat het veel makkelijker te installeren, veel kleiner, in een handig formaat(rpm) en makkelijker te updaten is.
Je moet meestal wel een paar dagen wachten tot hij beschikbaar is.(en dus je kernel update even uitstellen tot het package voor de nieuwe kernel beschikbaar is)
(voor FC5 is hij al beschikbaar en hij werkt perfect icm xgl).
Werken deze drivers ook met een ATI IGP345M kaart (chip)?
Ik probeer namelijk al een hele tijd 3D hardware acceleration aan de praat te krijgen op m'n
HP Pavilion ZE5415 EA, met SuSE 10.0.
maar totop heden geen suc6
De drivers zijn bij mij probleemloos geinstalleerd onder Fedora Core 5 / x86_64, alleen duurt het opstarten (vanuit runlevel 3) naar XGL ongeveer 30 sec. i.p.v. 10 sec bij driver versie 8.27.10

Glxgears geeft een resultaat van +/- 260 (!!!) fps, bij 8.27.10 was dit nog 3200+ fps (bij versies daarvoor 8400+ fps) en dat op een ATI X800XL :?

En ja: direct rendering staat aan en werkt prima, want spellen als UT2004, Doom3 & Quake4 doen het prima
jammer dat er nog steeds geen ondersteuning is voor de IGP serie (Radeon GPU's in laptops) ik heb het ooit eens werkend gehad, maar als ik het nu probeer te installeren onder ubuntu geeft het weer geen resultaat.. gewoon maar weer afwachten dus :)
jammer dat er nog steeds geen ondersteuning is voor de IGP serie
Dus ook aan deze drivers heb ik weer nix :(
Beetje jammer weer van ATI

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True