Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 19 reacties
Bron: Kernel.org

xiphoid Delen

Lees meer over

Versienummer:2.2.20
Besturingssystemen:Linux, Linux x86
Website:Kernel.org
Download:http://www.kernel.org/pub/linux/kernel/v2.2/linux-2.2.20.tar.gz
Moderatie-faq Wijzig weergave

Reacties (19)

Ik zat al een hele tijd te wachten daarop, de 2.4 kernel heeft voor een normale installatie 32 MB RAM nodig (kan ook minder maar ik heb geen zin om dat allemaal uit te zoeken). Mijn personal servertje heeft maar 24 MB RAM. Dus die draait nog mooi op 2.2 voor de komende tijd.
Mijn server draait Postfix imap apache openssh op kernel 2.4.5
Am5x86 133 met 16mb ram

waar jij bovenstaande onzin vandaan haalt weet ik niet, de kernel boot al met 4 mb ram of zelfs minder
misschien bedoelt-ie het installeren van een distro met daarin kernel 2.4.5, en niet het naderhand compileren/gebruiken van iets uit kernel 2.4.x serie.
mischien, ligt dus niet aan de kernel maar aan de distro. Bovengenoemde server draait overigens geen 'distro' maar Linuxfromscratch gecompileerd door me athlon en daarna lekker gecopieerd
Jullie hebben gelijk, het is de distro, (redhat 7.0) en heb de standaard installatie gedaan.werkte goed en heb er verder niet naar gekeken. :+

Ik ga wel proberen om de nieuwe kernel er op te zetten
beetje vaag verhaal. Mijn server gebruikt meestal minder dan 20 MB Ram en draait kernel 2.4.7. Er zit dan trouwens wel ongeveer evenveel in de swap, maar dat maakt ook niet zoveel uit...
56kb/s en dan weer een download van een kleine 30 mb..
oo wat vind de KPN mij toch lief
30MB? :?

linux-2.2.20.tar.bz2 02-Nov-2001 08:41 15.0M

De helft dus maar...
het antwoord hierop is simpel. Download slechts de patch.

patch-2.2.20.tar.bz2
zorg dat je een schone 2.2.19 tree hebt, extract schoon uit de bzip of make mrproper.

cd linux
bzcat ../patch-2.2.20.bz2 | patch -p1

klaar is clara, nieuwe kernel met slechts 3 mb download
Deze post heeft waarschijnlijk 1 minuutje geduurd, was toch weer.... 6KBx60= 360KB.
Nou, als je dan nog iets van 90 posts zet heb je je hele kernel binnen ;)

* 786562 TheGhostInc
* TheGhostInc vraagt zich af waarom ze de 2.2 kernel nog zo lang meelaten lopen, 2.4 is nu echt heel acceptabel, en het ectra geheugen gebruik is ook niet waar. 2.4 draait prima met 16/24MB (ja, dat doe ik zelf <http://www.tweakers.net/meuktracker/g/s/smile.gif> )
Tsja, wat dacht je van software die specifiek voor een 2.20 kernel geschreven is. (Zo loop ik zelf altijd een versie (.2 versiepunten dus, expirimentele kernels doet ik niet aan) achter op de laatste release. En om eerlijk te zijn bevalt me dat prima. - Sterker nog mijn gateway/proxy draait zelfs nog op 2.0, maar die gebruik ik toch niet [meer] als werkstation.

Zo herinner ik mezelf een Oracle installatie op Linux op m'n werk. We probeerden dat toen op een (toen redelijk nieuwe) 2.2 kernel te doen. Liep van geen kanten, installatie mislukt volkomen... Daarne met een 2.0 kernel geprobeerd en hij liep als een zonnetje.
[overbodig] De KPN vind je liever als je even wacht tot het maandag middag is :)

Wat is 30mb nou tegenwoordig.


On Topic,
er zijn genoeg snelle mirrors waardoor jij je downstream zo vol mogelijk kan laten lopen waardoor je in zo een kort mogelijke tijd de rommel binnen heb. Het is wel de moeite waard hoor. Deze upgrade. Dus verspilling van tijd & bandbr. is het zeker niet.
Zoals TheGhostInc al zegt:
waarom nog een 2.2 kernel?

Ik draai nu 2.2.19, maar nu ik toch weer ga updaten, vraag ik me af of het niet beter is om een van de laatste 2.4 kernels te nemen :?
waarom nog een 2.2 kernel?
omdat-ie gewoon goed werkt
...of het niet beter is om een van de laatste 2.4 kernels te nemen
dat kan, maar lees dan wel goed ../Documentation/Changes door, want waarschijnlijk moet je een aantal zaken upgraden. Dit is de 'requirements list' voor 2.4.5:
[code]
Gnu C 2.91.66 # gcc --version
Gnu make 3.77 # make --version
binutils 2.9.1.0.25 # ld -v
util-linux 2.10o # fdformat --version
modutils 2.4.2 # insmod -V
e2fsprogs 1.19 # tune2fs
reiserfsprogs 3.x.0b # reiserfsck 2>&1|grep reiserfsprogs
pcmcia-cs 3.1.21 # cardmgr -V
PPP 2.4.0 # pppd --version
isdn4k-utils 3.1pre1 # isdnctrl 2>&1|grep version
[/code]
Het zal je misschien verbazen, maar er is nog hardware die niet aan de praat te krijgen is in 2.4.x Ik heb bijvoorbeeld een netwerkaart (ASIX 88140 100Mbit builtin HUB) waar hele brakke drivers bij waren meegeleverd. Nar zelf in de code te strepen heb ik het ding goed werkend gekregen in 2.2.16. voor mij is het interresant om over te stappen op 2.2.20, omdat hij het daar waarschijnlijk nog wel net doet.

Er zijn nu waarschijnlijk mensen die denken "weggooien die kaart en flikker er een "echte" kaart in, di t is echter zonde, omdat het ding het verder goed doet en onder 2.2.16 ik alles kan doen wat ik moet doen.
o.a. ivm de vunr. in .19 is het raadzaam te upgraden.

Op dit item kan niet meer gereageerd worden.