Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 20 reacties
Bron: Amd

ATi CrossFireX logo (75 pix) AMD heeft nieuwe Linux-drivers voor zijn ATI Radeon-videokaarten uitgebracht. De download is 96MB groot en kan voor zowel 32bit- als 64bit-omgevingen worden gebruikt. Versie 10.6 is geschikt voor Radeon HD2400 en hoger, de FireStream 9170, 9250 en 9270, en de embedded E2400 en E4690. Verder worden versies 6.7 tot en met 7.5 van X.org, Linux-kernel 2.6 en hoger, en glibc-versies 2.2 en 2.3 ondersteund. Nieuw in deze release is ondersteuning voor Red Hat Enterprise Linux versie 5.5 en OpenGL versies 3.3 en 4.0. Daarnaast is het 2d-weergavegedeelte herschreven, wat onder andere tot prestatieverbeteringen heeft geleid. Het changelog toont verder één bugfix en een lijst met bekende problemen waarvoor nog geen oplossing is.

New Features

Support for New Linux Operating Systems

This release of ATI Catalyst Linux introduces support for the following new operating system:
  • RHEL 5.5 production support
Official support for OpenGL 4.0 and OpenGL 3.3
  • ATI Catalyst 10.6 delivers official support for OpenGL 4.0 on the ATI Radeon HD 5000 Series
  • ATI Catalyst 10.6 delivers official support for OpenGL 3.3 on the ATI Radeon HD Series
2D performance enhancements

ATI Catalyst 10.6 delivers a new architecture for 2D acceleration. The new 2D architecture delivers fast windows resizing with Compiz/Visual-Effects and general 2D performance improvements in all AMD supported Linux distributions.

Resolved Issues

The following section provides a brief description of resolved issues with the latest version of the ATI Catalyst Linux software suite. These include:
  • "Xorg -probeonly" no longer causes screen corruption or the system to fail to respond

Known Issues

The following section provides a brief description of known issues associated with the latest version of ATI Catalyst Linux software suite. These issues include:
  • OpenCL 1.0 conformance tests have not been run with this version of the ATI Catalyst Driver Suite in conjunction with the ATI Stream SDK v2.1. If you require an OpenCL 1.0 conformant driver, we recommend that you install the ATI Catalyst 10.5 Driver Suite
  • Desktop arrangement area may appear empty and fail to display the icon number when Catalyst Control Center is relaunched after disabling or hot-unplugging the secondary display
  • Disabling the primary display in clone/dual-head mode may cause Catalyst Control Center not to launch properly after X restart
  • Applying display rotation using Catalyst Control Center or XRandR may result in display turning blank with mouse cursor while rotating the display
  • X-server may fail to start, or unusual behaviour may be observed, after applying various HDTV formats of 1080i30/25/p50 standard and optimized modes on DVI/DP displays
  • CrossFire might not be enabled properly on the first Gemimi card, with Anti-Alias 8x displaying no visual changes, under a 2 Gemini multi-adapter configuration
  • Xserver may fail when applying "Maintain Aspect Ratio" option from GPU scaling at maximum resolution
  • [SUSE] Desktop corruption may be visible after applying rotation using Catalyst Control Center and restarting X
  • Enabling a second ASIC without a monitor connected may result in black screen and X window not launching when startx is executed
  • System may fail to display error message when improper position values are used in "aticonfig --tv-geometry" resulting in invalid "TVHPosAdj" and "TVVPosAdj" values in xorg.conf file
  • [Ubuntu 10.04] X segmentation faults on startup on multi-ASIC systems
  • Switching to clone mode by pressing Fn+F4 might not function properly after connecting an external VGA monitor
  • Segmentation fault may occur when running "Quake 4" and "Enemy Territory: Quake Wars" at 1280x1024 or resolutions higher than current desktop resolution
ATi Catalyst  Linux Display Driver logo (410 pix)
Moderatie-faq Wijzig weergave

Reacties (20)

Ik snap echt niet waarom die lijst met known issues zo lang blijft, het lijkt wel of er niets aan gedaan wordt.
Het 2D-gedeelte van de driver is herschreven.
Misschien dat voor deze release daar de meeste energie in is gestoken.
Dat zou mooi zijn want daar schijnen heel lang issues mee geweest te zijn, zoals hele trage responsetijden bij het verslepen van een vesntertje.
Als dat nu helemaal opgelost is zou dat een aanzienlijke verbetering zijn ten opzichte van de vorige releases.
Dat kan vertrouwen scheppen bij mensen die voornamelijk die 2D-functionaliteit gebruiken, zoals in de zakelijke sector. Daar zijn heel veel desktopjes die een goedkoop, energiezuinig videokaartje nodig hebben. En als daar dus de 2D-functionaliteit is zoals ie moet zijn voldoen zulke kaartjes volledig aan de verwachtingen.
Dat zou een mogelijke verklaring kunnen zijn.
Nou niet met het verslepen van vensters, alles werkte prima behalve het vergroten/verkleinen van vensters en het maximaliseren, dat ging nogal traag en dus blijkbaar ook zonder hardware versnelling.

Ik heb deze driver nu prima aan het draaien onder Ubuntu 10.04 met kernel 2.6.34 en ik moet zeggen dat die 2d versnelling een hele opluchting is.
Bij de Geforce-drivers is dat ook zo hoor. Check de PDF's maar.
Heb ze genstalleerd op Lucid, lijkt goed te draaien allemaal, helaas ligt de performance in games nog steeds ver onder de Windows versie, zo'n 20 tot 30%, maar het gaat de goede kant op.
Dit is onder andere afhankelijk van welke wine versie je gebruikt, je wine instellingen, of je compiz ondertussen draait, welke dll's je ge-override hebt (zoals DirectX etc.).

Ik heb het zelf nog niet getest sinds ik mijn ATI kaart heb maar met Nvidia kaarten had ik in ieder geval in EVE Online weinig tot geen performance verlies :)
Werkt perfect! Eindelijk vensters vergroten etc. zonder enorme lag.
Als ik een video ging afspelen en die fullscreen ging zettten, duurde het altijd heel lang voordat die overging op fullscreen. Nu gaat het instantly! De drivers zijn nog steeds niet helemaal goed, maar er zit eindelijk ontwikkeling in.
En heb jij nog last van tearing bij video's? Ik draai Lucid met een HD5650 en ik krijg mijn tearing niet weg.
hier was ik ook benieuwd naar.
2D performance enhancements

ATI Catalyst 10.6 delivers a new architecture for 2D acceleration. The new 2D architecture delivers fast windows resizing with Compiz/Visual-Effects and general 2D performance improvements in all AMD supported Linux distributions.
eindelijk!! Dit is nou precies waarom zo veel mensen voor nVidia kiezen ipv ATI als ze linux willen draaien, gewoonweg omdat de performance op je desktop zo belabberd was. Ik ga dit binnenkort zeker testen, ik hoop dat het wat uithaalt! Maar als ik de comments hierboven zie dan heb ik al goede hoop:
quote: Phas0r
Ik heb deze driver nu prima aan het draaien onder Ubuntu 10.04 met kernel 2.6.34 en ik moet zeggen dat die 2d versnelling een hele opluchting is.
Heeft ATI nu al eens een Ubuntu repository opgezet zodat je makkelijk kan upgraden? Dat handmatig installeren is zo onhandig.
Even geduld hebben. Binnen een paar dagen zal dat er wel op staan. Dan kan je gewoon via hardware drivers het aanvinken en installeren
@NickPen: Ik heb ook een HD5650! Ik heb helemaal nergens last van. Eerlijk gezegd weet ik niet precies wat onder 'tearing' verstaan wordt. Mijn video's (zelfs 1080p content) spelen heel vloeiend af.
Al geprobeert xv als video output in te stellen? Die werkt bij mij het beste.
Gebruik Mplayer.. en niet uit de repo's gewoon zelf compilen :)

[Reactie gewijzigd door robin007bond op 21 juni 2010 22:28]

ben benieuwd of een 4850+samsung syncmaster nu wel een fatsoenlijke resolutie kunnen geven zoals op de doos van de hardware staat geschreven; 2048x1152, zal me benieuwen.
wat gebruik je? vga, hdmi of dvi? dvi kan alleen met dual link zulke resoluties
Ga hem straks proberen, draai nu de open-source driver (Lucid) omdat mijn Big Desktop broken is.
"Versie 10.5 is geschikt voor Radeon HD2400 en hoger, de FireStream 9170, 9250 en 9270,.. "
Neem aan dat het 10.6 moet zijn.
vanavond deze drivers maar eens proberen. Wordt er gek van dat heel linux vastloopt bij het starten van diverse 3D applicaties.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True