Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 12 reacties
Bron: Amd

ATi CrossFireX logo (75 pix)

AMD heeft nieuwe Linux-drivers voor zijn ATI Radeon-videokaarten uitgebracht. De download is 83MB groot en kan zowel voor 32bit- als 64bit-omgevingen worden gebruikt. De systeemeisen voor versie 10.2 zijn ongewijzigd. Ze zijn geschikt voor Radeon HD2400 en FireGL V3600 en hoger, versies 6.8 tot en met 7.4 van X.org, Linux-kernel 2.6 en glibc-versies 2.2 of 2.3. Wat er precies in versie 10.2 veranderd is kunnen we je helaas niet vertellen, de link naar het pdf-document waarin de release notes te vinden zijn is op moment van schrijven helaas dood.

ATi Catalyst Linux Display Driver logo (410 pix)
Moderatie-faq Wijzig weergave

Reacties (12)

Voor mij de slechtste driver in tijden. Desktop effects crashen namelijk bij mij, en worden vervolgens volledig uitgeschakeld. AMD weet van dit probleem, maar ik ben bang dat het nog wel een paar driver versies gaat duren voordat het opgelost is...

(ubuntu 9.10, 64 bits met gnome)

[Reactie gewijzigd door The Flying Dutchman op 19 februari 2010 11:12]

opensource drivers proberen (xf86-video-ati)? Die werken namelijk inmiddels prima samen compiz en de 3d acceleratie werkt ook aardig. Ze missen nog wel powerplay helaas. Werken prima op mijn HD4650 in elk geval :)

Ik heb altijd een soort van "lag" bij het verkleinen en vergroten van vensters met de officile ati drivers.

[Reactie gewijzigd door BastiaanN op 19 februari 2010 11:54]

Geen opensource drivers voor mij. Ik wil OpenGL 3.2 en OpenCL. Beetje hobby om daar leuke dingetjes voor te programmeren. Ik denk niet dat ik ooit op de opensource drivers overstap. Het is fantastisch dat daar zo aan gewerkt wordt, maar qua 3d performance zal het nooit de closed source drivers' performance halen.
Ik denk eigenlijk dat het qua pure performance de closed source driver zal overschrijden. Die closed source driver hangt van ellende, hacks en legacy aan elkaar terwijl ze van de open source driver iets moois kunnen maken wat nieuwe ontwikkelingen als gallium3d volledig kan benutten. Ook denk ik dat de OpenGL ondersteuning van die driver veel vollediger zal worden als wat de closed source driver nu kan, gezien OpenGL altijd al open was en nieuwe versies als 3.2 dus makkelijk in een open driver toegevoegd kunnen worden.
Op het moment mist het features ja, Rome is ook niet op 1 dag gebouwd, maar opmerkingen als "ik zal nooit overstappen" getuigen van weinig inzicht in de ontwikkelingen. Volgens mij was het juist de bedoeling van AMD om hun driver-ontwikkeling goedkoper te maken door gewoon de specs vrij te geven en de open source community zelf de drivers te laten maken. Scheelt hun tijd en geld :+ Ik denk dat ze met deze closed source driver gaan kappen zo gauw de open driver op hetzelfde niveau is.
Als de desktop effect crashen en worden uitgeschakeld mag je blij zijn, bij mij blijft KDE voor eeuwig hangen op de splash na het inloggen...

Ik heb goede hoop dat dit wel is opgelost in de volgende versie, aangezien het iets is wat in het verleden wel heeft gewerkt, ze hebben vooral moeite met *nieuwe* features.
Bij mij werkt compiz gewoon hoor. Installeren en draaien met die hap.

(openSUSE 10.2 met KDE)
Ik hoorde dat er directX code inzit voor 2d acceleratie (http://www.phoronix.com/s...?page=news_item&px=Nzk5MQ)? wat krijgen we nou?
Er zit geen directx code in. Het enige feit dat in dat artikel staat is dat er een variabele is met "Direct2D" in de naam, wat helemaal niks zegt. De rest is allemaal speculaas. Er is op Linux niks om DX drivers voor te schrijven, er is geen DX api voor zo'n driver om tegenaan te praten. En afgezien daarvan zouden ze het copyright van MS breken door dat soort dingen in te bouwen, en die hebben het niet zo op Linux.

[flamebait] Het enige waar je misschien aan zou kunnen zien dat het om windows code gaat is de opmerking in het artikel dat de nieuwe 2d acceleratie problemen oplevert. Windows associeer ik zelf met "problemen", dus daar zou de link kunnen liggen... [/flamebait]
Heb nu twee computers met ati-videokaarten die niet meer ondersteund worden door deze drivers (radeon 9800 en 9600). Eentje draait een oude versie van Ubuntu met de fglrx-drivers, en eentje draait ubuntu 9.10 met de open source-drivers. Bij die laatste zijn de performance echt om te huilen: onwerkbaar. Degene met fglrx-driver draait echter zonder veel problemen spellen als world of warcraft, maar moet noodgedwongen een oude distro draaien.
Toch wil ik in mijn nieuwe computer weer een ati-videokaart: goede prijs en open source-drivers itt nvidia.
Hier toevallig wow-spelers die ervaring hebben met recente radeon-kaarten?

@knakworst, een intel IGP is te langzaam voor wat ik wil doen, dat is dus geen optie voor mij.

[Reactie gewijzigd door nearo op 21 februari 2010 22:06]

Waarom neem je gewoon niet een intel IGP. Werkt uitstekend.
Ubuntu 9.10
Catalyst 10.2
Volledig gepatchte WoW-versie in OpenGL mode
HIS HD5780

- Compiz crashed volledig
- Halvering van FPS tov Windows (DirectX op Windows, dat wel)
- 2e beeldscherm wordt uitgeschakeld bij het stoppen van het spel
- (fout van Blizzard) nog steeds geen hardware cursor :(
hij staat in de verkeerde categorie.

edit: ow er is al een gathering draadje aangemaakt.

[Reactie gewijzigd door buzzert_nl op 19 februari 2010 11:25]

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True