Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie

Door Redactie Tweakers

SBLive onder NT4 met SP4

12-11-1998 • 06:00

2 Linkedin

Inleiding

Wie in het gelukkige bezit is van die geweldig klinkende CreativeLabs SoundBlaster Live! (VE/FULL) geluidskaart, moet heel erg opletten als ie Windows NT4 draait.

Als je op de machine de drivers hebt geïnstalleerd, en vervolgens de ServicePack 4 update van WinNT er overheen kwakt staat je een zeer onaangename verrassing te wachten: NT zal met geen mogelijkheid meer starten. De enige serieuze optie die dan nog over blijft als je onder NTFS draait is een format en een reinstall. Ik denk niet dat de gemiddelde puteraar daar nou zoveel zin in heeft.
Helaas, de eerste keer kwam de waarschuwing voor mij te laat. Gelukkig was ik nog niet ver met de installatie van alle software, dus de verloren tijd viel mee...

Op 3 november (nou ja... de links op de Creative site werkten niet, dus het werd 4 nov) is er een nieuwe driver gekomen. Deze driver zou het probleem hebben opgelost.

* De installatie

Om te beginnnen: Lees dit artikel eerst HELEMAAL door, anders staat je een hoop ellende te wachten.

Mijn advies is om alles uit de voeren onder het Administrator account. De echte onvervalste Administrator (dus geen eigen naam met administrator rechten, en ook niet Admin. Echt ADMINISTRATOR. Mijn ervaring is dat de installatie van SP4 anders wel eens lastig kan gaan doen, en daar zit je niet op te wachten.

OK, dan nu aan de slag...

Als eerste heb je de nieuwe drivers nodig, die kun je halen op http://www.soundblaster.com/registereddownload/download2.asp.
Als je nog niet eerder je gegevens hebt opgegeven, of je hebt je cookies niet aan staan, dan moet je (opnieuw) je gegevens invoeren. Hierna moet je de betreffende driver downloaden.

Dit artikel is gemaakt aan de hand van de "Sound Blaster Live! driver update for Windows NT4.0 (English language) SBL-NTWEB-1-US (Revision 2) - Release date 11/03/98", het kan zijn dat er als je dit leest al een nieuwe versie is.

En natuurlijk ook SP4. Die is o.a. hier te krijgen: ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/nt40/ussp4/ of op de alternatieve site ftp://198.105.232.37/fixes/usa/nt40/ussp4/

Dan nu de rest: Ik ga ervan uit dat je op dit moment SP3 en de originele drivers hebt geinstalleerd.

- De-installeer alle Creative software. dit doe je via ControlPannel/Add Remove Software, en dan de 3 (in een enkel geval 4) programma's waar "Creative" voor staat uninstallen. Als dit gedaan is herstarten.

- Delete nu de hele directory "C:\Program Files\Creative" , als hij dat weigert, is er nog een programma dat actief is: AHQTB.exe

is dit het geval, ga dan naar taskmanager, en ga naar de tab Processes. hier moet je dan die applicatie beeindigen. Daarna kun je alsnog de directorie deleten.

- Ga naar ControlPanel/Multimedia en ga dan naar de Tab Devices. hier haal je "audio for creative sb live" en vervolgens "midi for creative sb
live" weg. LET OP: blijf van "midi for creative s/w synth", anders gaat je systeem naar een 100% CPU Load, en kun je je systeem resetten (op de harde manier). Als de devices weg zijn zal ie wederom willen herstarten. Doe dit.

Verder...

- Installeer SP4. Tenzij je er erg op tegen bent zou ik er voor kiezen om alles - Dus ook Mikroschoft Incontinent Imploder 4.0 - Te installeren. Dit gaat wel even duren. Belangerijk is dat je dit dus onder het ADMINISTRATOR account doet. Je zult - zeker als je IE er ok bij installeert - enige malen moeten herstarten.

- Als dit geheel nu klaar is komt het riskante werk. Doe dit echt volgens deze procedure, want anders kom je het systeem niet meer in!

Installeer van de CD de SB software: Als je wil de "Creative Keytar" en "Creative Rythmania", maar in ieder geval "Soundblaster Live!".
van de laatste groep kun je alles installeren, hoewel ik het afraad de SBLive Tour te installeren. (je kunt hem ook van de CD af draaien, en hij schijnt soms problemen op te kunnen leveren).

Aan het einde hiervan krijg je de vraag of je wil herstarten, !!! DOE DIT NIET !!!. Mocht het om de een of andere reden lijken alsof het systeem hangt, doe er dan alles aan om het systeem overeind te houden. Bij mij kwamen er geen problemen, maar het schijnt dat de CD installatie soms aan het einde lijkt te hangen. Druk CTRL-ALT-DEL, ga naar taskmanager, en je zult onder "Applications" dan 2 setups zien en nog een 3e applicatie. Beeindig deze 3e applicatie en de setup zal direct weer tot leven komen en de laaste stapen afronden.

- Installeer meteen de 3 november drivers update. Ook hier zou de installatie op een 95% kunnen blijven hangen. Als dit gebeurt, kijk dan VERDOMDE goed uit, en voer - alleen dan dus - het volgende punt uit.

- Dit dus alleen uitvoeren als voorgaande stap fout ging
Binnen taskmanager kill je de hangende applicatie (upinct.exe ofzoiets). Vervolgens gaat de setup verder. kort daarop krijg je te zien dat ie klaar is Druk vooral niet op OK, of het close buttontje boven aan (op straffe van herinstallatie) Wederom ga je naar taskmanager en KILL de setup applicatie.
voer vervolgens weer de originele driver installatie van de CD uit, (gewoon overschrijven, niet uninstallen, en vervolgens weer de update er over...

deze stappen blijf je net zo lang uitvoeren tot de update in een ruk door loopt.

Het klinkt maf... nou ja... zeg maar krankzinnig, maar met een stuk of 3 herhalingen lukte het bij mij wel...

Hiermee is de installatie compleet. Na een herstart moet de geluidskaart nu gewoon werken.

Deze procedure is gebaseerd op de SBL-NTWEB-1-US (Revision 2) Drivers van Creative van 3 November, en is getest op de US versie van NT4 met (uiteraard) de US servicepack 4. Voor andere taalversies heb je uiteraard een andere servicepack nodig.

Doe deze operatie alleen als je zeker weet dat je geen bestanden zal missen als iets fout gaat, want tot mijn grote schrik blijkt ook bij volgen van deze methode een foutje snel gemaakt te zijn, en het is echt THE ABSOLUTE END voor je NT4 installatie. (maak desnoods een Immagecast of Ghostfile aan voor je begint! Van Ghost kun je hier een 30-dagen-trial versie krijgen.)

PS: Deze oplossing werkt alleen op Single-CPU machines. Volgens de newsgroepen van Creative lossen deze drivers het probleem onder Multi-CPU systemen niet op.

Reinder Gerritsen

- Met dank aan de velen die hun advies op de NEWS groups hebben gegeven, met name Paul Luck

- Special thanx to all of the news groups who gave their advice, especially Paul Luck

Nieuws, en hoe het ook kan.

In december 98 zijn vernieuwde drivers uitgekomen die niet of in ieder gevan minder vaak bij 95% kappen tijdens installatie. bovendien zouden deze drivers ook geschikt moeten zijn voor Multi CPU systemen. (hoi hoi hoi).
Er zijn echter in de nieuwsgroepen geruchten dat er een memory leak in de decemberdrivers zit... dit is niet door Creative bevestigd, maar ik heb er al vaker over gehoord. zelf heb ik er niets van gemerkt, maar dat hoeft niets te zeggen

* Hoe kan het ook?
meermalen heb ik de vraag gekregen: "maar wat nu als ik NT4 net vers heb geinstalleerd?"
Da's dan mazzelen. installeer in dit geval eerst de originele drivers, en direct daar over heen de update drivers van december. Vervolgens installeer je direct SP4. Tot mijn stomme verbazing werkt dit.
Letop: in theorie zou je dit dus ook onder SP3 kunnen doen (eerst de drivers en de update installen en daarna pas naar SP4) maar het blijkt in dit geval nogsteeds niet 100% zeker goed te gaan. Dat risico kun je bij een verse install nog net wel doen. mocht het fout gaan dan is er tenminste niet zo erg veel verloren.

Story In English

To our dutch readers:
hoewel geen gebruik op WoT heb ik besloten de hoofdpunten van het artikel wegens de ENORME hoeveelheid vraag toch maar in het engels te vertalen. dit is inweze dus alleen maar in het kort wat er eerder ook is verteld: je hoeft het niet te lezen.


Wecome to Webmagix World of Tweaking. Due to overwhelming request here is the story in short for you who can't read the dutch article.


You've to do it under an administrator account and best if that account also is called ADMINISTRATOR, cause serveral install programs (including those of ms) will kick the bucket if it's another name...

If you're running without SP yet (ie you've got an absolutelyclean install),
it's quite easy:
- install the original drivers,
- update with the december updatepack (nov is also an option, but has less support)
- after reboot install SP4.

If you're running already SP3 or 4:

- in case of SP3 de-install all Creative applications, delete the installed
directorie (c:\program files\creative) It is possible it will refuse because an application is active. this is AHQTB, whitch you can terminate through taskmanager.
- reboot
- in Control Pannel/Multimedia delete the entry's for audio for creative sb live and next midi for creative SB live. do NOT toutch midi for creative s/w synth: this causes a Load of 100%, and results in a complete lockup. (no good)
- restart
- install SP4 and reboot when asked to.
=============
now along for both SP3 and 4:
- Install the SB software from the original driver pack. It is advised not to install SBLive Tour. At the end of this DO NOT RESTART. Say you'll do that later.
- Install the dec. update (don't use the nov. update cause there is a chance it'll hang at 95% during install, and that just might be enough to reinstall your complete NT.
- After this you should be able to restart. Be sure installaton of both the
original and updated driver are completed COMPLETELY.

while installing it might be possible both with installing the original drivers as with the updated drivers that installation hags at 95% (adding registry key's.) if this happens, use tastmanager to kill the not responding
setup. (you'll find several instances running.) after this setup will smoothly finish. But don't be fooled since something went wrong, and that's just the destructive part. Just rerun and repeat untill all went right. If
you don't succeed, try reinstalling the originals again and then again the
update... as soon as you have SP4 installed and installation of the update failed and you restart: YOU'RE TOAST...

The fact that this installation goes wrong proves again that Creative is using current users as some kind of Beta-Testing idiot's.... hell we're now PAYING them to be their testing personell.... you might say I'm getting
rather furious about this kinda crap, since Creative is NOT the only one doing this...

I hope you succeed with this. Ive tested both methods, and I got it to work, so it is possible. However, I've also got reactions that it wouldn't work with them. be sure you've backed up erything you can't miss... (I used GHOST to completely dump the NT partition to file before trying, and was glad I did since it saved me a LOT of time.)

Wat vind je van dit artikel?

Geef je mening in het Geachte Redactie-forum.

Reacties (2)

Wijzig sortering
Die elledige teringtroep van Creative werkt dus niet nooit never op mijn SMP systeem... en ik heb een AWE64 en een Live!

Troep troep troep.
geen problemen met mijn sblive onder nt4.o met sp5 <img src=http://www2.hku.nl/~femme/wot/forum/interface/smilies/wink.gif width=15 height=15>

Op dit item kan niet meer gereageerd worden.


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2022 Hosting door True