Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 12 reacties
Bron: Kernel.org, submitter: Tomsworld

Naast development kernel 2.5.50 kun je ook gebruik maken van kernel versie 2.4.20. Dit is de nieuwste stable versie die onlangs werd uitgebracht. Hieronder staat de samenvatting van het changelog:

final:

- 2.4.20-rc4 was released as 2.4.20 with no changes.


Summary of changes from v2.4.20-rc3 to v2.4.20-rc4
============================================

:
o Changed EXTRAVERSION to -rc4
o Cset exclude: ralf@dea.linux-mips.net|ChangeSet|20021030170645|00078

:
o The BLKGETSIZE ioctl expects an unsigned long argument

Adrian Bunk :
o Fix ips driver .text.exit errors

Kai Germaschewski :
o ISDN: Fix the fix

Oleg Drokin :
o Do not allow to mount reiserfs with blocksize != 4k

Paul Mackerras :
o PPC32: Fix arch/ppc/Makefile so it builds on POWER3
o PPC32: Ignore SIGURG if not caught

Rui Sousa :
o Emu10k1 bugfixes

Moderatie-faq Wijzig weergave

Reacties (12)

Ik heb nu op mijn servertje 2.4.7-10 draaien, die standaard bij RH 7.2 zit. is het nu aan te raden om te updaten?.. het draait nu prima namelijk..
Het is zeker aan te raden omdat er een ernstige bug wordt opgelost met betrekking tot de stabiliteit. Zie voor meer info ergens op het forum :)
stabiel issie wel, had laatst een uptime van 100 dagen, zonder probleem.. zolang nuon zijn werk maar doet..
Het ging om de bug waarbij een user een scriptje kan uitvoeren waarna de kernel een lekkere kernel panic geeft. Dit is eventueel met SSH makkelijk van buitenaf te doen, of met PHP en CGI. Juig niet te hard zou ik zeggen, maar upgraden die hap. In dit geval kan je niet af gaan op if it ain't broken, don't fix it principe aangezien het zeker wel broken is < 2.4.20 ;)
Er zijn altijd wel weer een boel (security) fixes, vooral als je van 7-10 naar 20 gaat. En als je je netjes aan de howto/manual houdt, dan kan er eigenlijk niks verkeerd gaan (je kunt altijd weer booten met je oude kernel).
Er zijn altijd wel weer een boel (security) fixes, vooral als je van 7-10 naar 20 gaat. En als je je netjes aan de howto/manual houdt, dan kan er eigenlijk niks verkeerd gaan (je kunt altijd weer booten met je oude kernel)
Hmm... wel als je hem zelf toevoegt, maar als je straks simpelweg de distro-rpm installeert ben je je oude kernel wel kwijt.. Helemaal leuk als je een dualboot hebt, lilo gebruikt en je nieuwe bootsector naar je windisk wil zetten voordat je die hebt gemount.. :P
Als het lekker draait waarom zou je dan updaten? Je server doet wat je wil en zoveel nieuws onder de zon is die nieuwe kernel niet.
Ah prima, zitten hier ook de modules voor de E1000 in ? (intel gbit controller)

edit: ja dus:

onder ./drivers/net/e1000 :)
Als ik naar de` module naam kijk dan zou ik zeggen Ja. Als je een list met modellen nodig hebt mail me even.
OpenWall security hardening patch voor 2.4.20: hier. GrSecurity patch is nog niet uit...
Niet echt veel fixes, maar wel weer relaxed dat er 'n nieuwe versie uit is!
Die fixes die hier staan zijn die van RC4 ten opzichte van RC3..
deze lijst laat toch wel flink wat aanpassingen zien:
http://www.uunetnl.lkams.kernel.org/pub/linux/kernel/v2.4/ChangeLog-2. 4.20 ;)

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True