Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 42 reacties
Bron: Joomla!, submitter: Maffie500

Joomla! logo (60 pix)Versie 2.5 van Joomla is uitgebracht, een grote update vanaf versie 1.7. Joomla is een dynamisch, in php geschreven contentmanagementsysteem, dat kan worden gebruikt om bijvoorbeeld een weblog, website of collaboratiesite te maken. Om het programma in het Nederlands te gebruiken, kun je onder andere op Joomla Community terecht. In versie 2.5 zijn onder andere de installatie en het updaten verder vereenvoudigd. Daarnaast is de zoekfunctionaliteit flink verbeterd en is er ondersteuning voor nieuwe databases toegevoegd. Meer informatie over de verbeteringen in versie 2.5 is in de aankondiging te vinden.

Joomla 2.5 - Nieuwe mogelijkheden. Simpel updaten!

Met Joomla 2.5 heeft de community de nadruk gelegd om het installatie en update proces van Joomla zo eenvoudig en duidelijk mogelijk te maken.

Gebruikers kunnen eenvoudiger en met grotere regelmaat naar de laatste versie van Joomla upgraden en daarmee profiteren van de (veiligheids-)voordelen van de nieuwste code. We denken dat Joomla gebruikers over de gehele wereld spoedig deze nieuwe methode zullen omarmen.

Direct aan de slag: Simpel updaten

De automatische update notificatie van Joomla core en extensies is een nieuwe ingebouwde functionaliteit dat het onderhouden en uitvoeren van updates verder vereenvoudigt.

De nieuwe update notificatie iconen zijn beschikbaar in in het controlepaneel van de backend van je Joomla website. Met de ene knop update je Joomla in een klik naar de laatste stabiele versie en met de andere kan je de geïnstalleerde extensies bijwerken. De knoppen geven automatisch aan als er een update beschikbaar is.

Een grote verbetering op het gebied van gebruiksvriendelijkheid. Het is niet meer nodig om een Joomla site te updaten door handmatig via FTP bestanden op de server te overschrijven. Minder fouten en vele malen sneller!

Slim zoeken

Deze nieuwe functionaliteit biedt de gebruikers van de website een snelle en gebruiksvriendelijke manier van zoeken aan. Het vult zoekwoorden automatisch aan en geeft suggesties voor zoekwoorden waardoor gebruikers sneller relevante inhoud kunnen vinden door het typen van de eerste letters van een woord.

Ontworpen voor veelzijdigheid en snelheid zorgt dit core Joomla! component en de bijbehorende plugins voor de automatische indexering van alle content items, categorieën, weblinks, contacten, newsfeeds, etc. in een klik. Het biedt een groot scala configureerbare opties aan, zoals de lengte van de beschrijving van het resultaat, de url lengte en datum filters.

Multi-Database Support

Ondersteuning voor verschillende databases maakt het mogelijk om het Joomla! CMS ook op andere databases te draaien dan alleen MySQL en MySQLi. Dit ondersteunt de integratie en updatebeheer processen. Joomla! geeft nu de mogelijkheid verschillende drivers te schrijven die verschillende versies van SQL databases ondersteunen. Actuele drivers bestaan voor MySQL en MS SQL databases terwijl de PostgreSQL, Oracle, SQLite en PDO drivers bijna af zijn.

Andere nieuwe mogelijkheden in Joomla 2.5
  • Nieuwe versie van het Joomla Platform (11.4)
  • CAPTCHA in de core
  • Het direct linken van nieuwe menu's met een module
  • Mogelijkheid tot invoeren van intro afbeelding, artikel afbeelding en diverse links in aparte velden bij een artikel
  • Instellen of de beheerder een email ontvangt bij registratie van nieuwe gebruiker
  • Menu item notitie
  • Handmatige text filters
  • Grotere flexibiliteit bij filteren van categorieën in het artikelbeheer
  • Manager om overrides van taalstrings toe te voegen
  • Nieuwe extensie: gebruikersnotities gekoppeld aan het gebruikersbeheer
  • Mogelijkheid om volgorde van nieuwsfeed in te stellen
  • Eenvoudig selecteren van afbeelding voor de offline pagina
  • Verbeterde prestatie van de pagina om menu items te bewerken
  • Mogelijkheid om alternatieve meta tags voor meertalige sites toe te voegen
  • Verbeterde SEO met de nieuwe languagecode plugin
Bekijk een overzicht van alle nieuwe mogelijkheden op joomla.org of bekijk de Nederlandse presentatie "25 verbeteringen in Joomla 2.5".

Joomla! 1.6 backend screenshot
Joomla! backend screenshot, klik op de afbeelding voor een grotere versie.

Moderatie-faq Wijzig weergave

Reacties (42)

Toch grappig om te zien, een jaar geleden bij het uitkomen van Joomla 1.6 waren de reacties hier ongeveer "eindelijk weer eens een nieuwe Joomla versie na 3 jaar wachten", inmiddels is dit geworden "alweer een nieuwe versie, pffff". Het is ook nooit goed zullen we maar zeggen ;)

Dit en de nieuwe versie nummering komen door de nieuwe development strategy die met de release van Joomla 1.6 van start is gegaan. Samengevat zijn er twee zogenaamde korte termijn versies (Joomla 1.6 en Joomla 1.7) die worden opgevolgd door een lange termijn support versie (Joomla 2.5). De nummering is hierop nu ook aangepast en eigenlijk is 2.5 een correctie hierop. Eigenlijk had Joomla 1.6 als nummer 2.0 moeten hebben en Joomla 1.7 als nummer 2.1. De X.5 versie is steeds de versie met lange termijn ondersteuning (18 maanden). Graag verwijs ik naar de infographic die ik hierover heb gemaakt voor meer uitleg:
http://www.joomlacommunit...lopment-strategie-nl.html

Daarnaast is er door de community hard gewerkt om upgrades tussen de Joomla versies eenvoudig te maken, daarom kan je nu met een klik vanuit de backend een 1.7 site upgraden naar Joomla 2.5. Door meer releases uit te brengen worden de sprongen kleiner waardoor het uprgaden eenvoudiger wordt en er niet een migratie nodig is zoals bij Joomla 1.0->1.5 en Joomla 1.5->1.6 nodig was.

Joomla 2.5 gebruikt dezelfde code basis als joomla 1.6 en joomla 1.7. Extensies die nu onder 1.7 werken zullen ook onder 2.5 werken (mits de extensie de Joomla code standaarden volgt). Als zowel developer als sitebouwer kan ik tot nu toe bevestigen dat dit het geval is bij alle 1.7 sites die ik tot nu toe heb geupgraded.

De volgende Joomla versie zal in het najaar verschijnen en zal Joomla 3.0 zijn. Als dit je allemaal te snel gaat kan je ook op de volgende lange termijn support versie wachten, dat is Joomla 3.5 en verschijnt in najaar van 2013. Wel is de stap van 2.5 naar 3.5 dan groter om te nemen, it's up to you!
Duidelijk, hier heeft men wat aan d:)b

// edit:

Overgang van 1.7 naar 2.5 nu ook vrijwel probleemloos doorgevoerd. De enige extensie die niet mee wilde was EasyCalcCheck+ (ECC+), dus dat als tip voor de gebruikers. Was -vziw- niet meer dan (re)CAPTCHA extensie en die zou nu toch wel in de Joomla! core geintegreerd zijn :)

// edit2:

Oke, niet helemaal probleemloos.. CAPTCHA functionaliteit is na installatie van 2.5 nog nergens te vinden, staat ook niet in de plugin-lijst. Ook de 2 notificatieknoppen zijn nog niet te vinden in het beheer en m'n template kan nog niet zo lekker met 2.5 overweg.. Lekker dit, morgen maar eens naar kijken :/

[Reactie gewijzigd door Fid3lity op 26 januari 2012 19:44]

Ik denk dat de upgrade niet helemaal goed is gegaan, gebruik de database fix en ontdekken tools even binnen 2.5, dan is het zeer waarschijnlijk verholpen. Zie ook http://forum.joomlacommunity.eu/showthread.php?t=12449
Heb inderdaad wat posts gelezen om die database fout, bekend probleem dus.. Database fix inderdaad doorlopen en dat ziet er normaal uit, discover tools was ik nog nergens tegengekomen maar vond daar inderdaad net de missende extensies. Complete selectie laten installeren maar leek de melding te krijgen dat de bestanden te groot waren. Afijn, zal eens even opnieuw inloggen, browser cache leeggooien en weet ik het.. Komt uiteindelijk allemaal wel in orde.

// edit: it's all done now :)

[Reactie gewijzigd door Fid3lity op 26 januari 2012 22:31]

Vreemde sprong v1.7 > v2.5. Ik dacht al at ik iets had gemist.

Ik vind het een te ingewikkeld programma voor wat het doet, ik hou het op WordPress.
de *.5 nummers krijgen longterm support.
1.5 heeft ook altijd updates gekregen na de release van 1.6 en 1.7.

1.5, 1.6 en 1.7 krijgen na februari geen (beveiligings) updates meer.

Voor meer uitleg over de roadmap
dat maakt het al een stuk logischer MAAR de volgende .5 na .7 is eigenlijk .0

en dan had je dus 0.5 1.0 1.5 2.0 2.5 gehad.. wat een stuk logischer is dan 0.5 0.6 .7 1.5 (hebben ze dan nooit een joomla 1.0 gehad)...
Nee, wat hij bedoeld is dat de X.5-versies de LTS zijn. De tussen updates zijn 'minor'. De volgende LTS is dus 3.5.

Joomla 1.0 was de allereerste versie van Joomla, nadat men het Mambo-project geforkt had. Zie ook Wikipedia (NL/EN)
Ik gebruik zowel Wordpress als Joomla. Beiden hebben een andere doelgroep. Wordpress is in mijn ogen bedoeld voor eenlingen, terwijl Joomla voor de wat grotere sites met meer gebruikers en meer verschillende rechten bedoeld zijn. In Joomla heb je ook meer opties voor fora, downloads, etc, waardoor het voor communities of verenigingen meer geschikt is.

De stap 1.7 2.5 vind ik ook vrij groot. Eens lezen wat daar de bedoeling van is.
De bedoeling is dat de .5 versies LTS worden (Long Term Support), 1.5 is ook lang ondersteund, nu 2.5 dus ook.

Versie 3.0 wordt dacht ik eind dit jaar verwacht.

[Reactie gewijzigd door Rub3s op 25 januari 2012 13:04]

Versie 3.0 komt over een half jaar als de eerste Korte termijn support release. Over 1,5 jaar komt weer versie 3.5. Zie hier de release planning.
en toch mist joomla op heel wat grote zaken behoorlijke wat functionaliteit...
ik noeem community builder zou eigenlijk min of meer standaard ingebakken moeten zijn,
het mist een fatsoenlijke wiki intergratie, en op tal van andere zaken werkt men met vage brug-constructies die niet of maar half werken.

een pakket als tiki is dan veel beter maar dat is dan weer niet modulair zoals joomla en bovendien vreselijk gebruiks-ON-vriendelijk...
Jij mist blijkbaar een Community Builder maar ik zit daar niet op te wachten. En een goede wiki extensie zou mooi zijn maar met ACL kom je als het goed is nu ook een heel eind. Dat is dan ook meteen de kracht van Joomla, er wordt aandacht geschonken aan core-extensies terwijl er voor uitbreidingen er over het algemeen voldoende keuze is.
Het zou beter zijn als je kan kiezen tijdens een installatie wat je wel en niet zo willen hebben.
Als je dergelijke templates voor verschillende sites zou maken betekend meestal ook dat er extra functies bij zou moeten komen van 3th party's.

Persoonlijk zie ik ook liever dat de Joomla community hun eigen versie van wiki, CB en andere basis elementen die je van een CMS kan verwachten terug in de installer.

Zelf zat ik te denken om het niet standaard mee te leveren maar als optie in de installer om zo niet een overdreven groot zip bestand te genereren.

En uiteraard up-to-date gehouden door het zelfde mechanisme die nu word gebruikt voor de Joomla core.
Als je het bij community builder alleen te doen is om meer velden in het gebruikersprofiel (bij veel wel het geval) dan is er goed nieuws, dat zit namelijk sinds 1.6 standaard in Joomla. Wel moet je daarvoor een plugin aanzetten maar het is dus aanwezig een met een beetje code kennis goed aan te passen zonder de core te hacken.
Hele vreemde sprong, en vervolgens alles in het Nederlands, dus ik dacht even dat de NL community een eigen versie had uitgebracht. Maar het is inderdaad versie 2.5
Voor de mensen die hun programmatuur niet in het Nederlands willen hebben: http://www.joomla.org/25
Ben ik net een maand live met 1.7 komen ze met 2.5 :S

Draai nu 2 sites op 1.7 en ik moet zeggen dat het stabiel en juist wel dummy proof is. Je kunt snel en eenvoudig een gelikte site maken. (als je durft te investeren in commerciŽle templates)
Ik heb bij rockettheme een maand subscribtion genomen om een template te mogen downloaden (plus heel wat extensies).
Er zijn zoveel modules/plugins/components te vinden, op diverse sites en bij de joomlacomunitie, dat het altijd wel iets biedt wat je wilt.

2.5 maar eens een testsite mee gaan opzetten en kijke of ik eenvoudig kan upgraden.
Je kan vanuit de administrator upgraden naar versie 2.5, dus geen nieuwe versie uploaden via bijv FTP. Maak wel eerst een back-up :). Scheelt weer upgrade werk. Uiteraard moeten geinstalleerde extensies/templates versie 2.5 wel ondersteunen. Gelukkig is er niet zoveel veranderd tussen de twee versies, waardoor dit eigenlijk geen probleem zou moeten zijn.
v1.7 had nog gedeeltelijke backwards compatability met 1.5. Versie 2.5 heeft dit niet meer (met 1.5, wel met 1.7), dus het zou kunnen dat er wat extensies hierop breken.
Onzin! Versie 1.7 was absoluut niet backwards compatible.! Er was dan ook geen mogelijkheid om te upgraden van versie 1.5 naar 1.6/1.7. Je kon alleen 'migreren'.

De reden hiervoor: Veel code is vrijwel vanaf de grond af aan herschreven.

Vanaf 1.6 is het (soms wel met problemen vooral veroorzaakt door (voor Joomla!) slecht geconfigureerde servers) altijd mogelijk geweest om betrekkelijk eenvoudig te updaten naar een nieuwe versie.

Vandaag 4 1.7.3 sites van nieuwe 2.5 voorzien. 2x zonder problemen, en 2x met oplosbare problemen vanwege te strikte server configuratie.
Ja belachelijk met 1.5 - 1.6 - 1.7 Plugins en nou alweer 2.5.

Hopelijk komt 3.0 een jaar later.
3.0 staat gepland voor september 2012. ;)

Maar, geen paniek. 2.5 zal tot noveber 2013 ondersteund worden met updates en fixes!
Wel jammer dat virtuemart alleen nog met 1.5 en 1.7 werkt http://virtuemart.net/downloads
Toch apart hŤ, dat zo'n pakket als een webshop, dat gratis is om te gebruiken, iig niet op de dag dat er een nieuwe versie van Joomla online komt ze al niet klaar zijn met een 2.5-versie? ;)

Misschien dat betaalde pakketten wel al 2.5-compatible zijn?
Edit: als het goed is zijn de extensies die onder 1.7 werken ook werkbaar onder 2.5, je zou in een testomgeving kunnen kijken of dit inderdaad werkt.

[Reactie gewijzigd door Xaverius op 25 januari 2012 18:38]

Dat is best vreemd ja ook al is het gratis, veel open-source projecten stemmen hun release cycle af op het product waar ze voor ontwikkelen. Sowieso deed Virtuemart er wel heel lang over om het maar uberhaubt 1.6 en 1.7 compatible te maken, moest je dus een hele poos noodgedwongen Joomla 1.5 gaan draaien terwijl er al lang 1.7 uit was.
die zal wel snel geupdate worden als 2.5 een LTS versie wordt.
Ik ga eerst maar eens afwachten hoe het met deze release gaat. Je zult zien dat ik nu overstap en er allemaal rare dingen naar voren komen. Eerst maar eens de kat uit de boom kijken.

Ook maar even wachten of al m'n extensies ook netjes meekunnen. Zal niet de eerste keer zijn dat bepaalde extensies niet meteen mee over kunnen naar een nieuwe major release.
Op zich is de upgrade relatief klein, t.o.v. 1.7. Maar een goede (geteste) backup is vereist. Als je kunt, zou ik het gewoon op een testserver, of een lokale XAMPP-installatie, uitproberen.

[Reactie gewijzigd door Evanescent op 26 januari 2012 00:03]

Pas wel op als je de Kunena-forumsoftware gebruikt. Dit wordt nog niet ondersteund in 2.5. Zie http://www.kunena.org/for...-kunena-support-joomla-25
Het lijkt me logisch dat als je wilt upgraden je altijd eerst controleert of alle gebruikte extensies in de website ook in de laatste versie werken. Zo test ik alles lokaal in een verse dump (dat zal toch bijna iedereen wel doen?) en maak ik meteen een volle backup zodat bij problemen de website zo weer terug gezet is.
Hallo,
Er zat een bug in de Beta/RC van J2.5 waardoor Kunena niet werkte. Maar die is op het laatste moment toch opgelost, door een van onze developers.

Kunena zou moeten werken onder J2.5. Er zijn alleen kleine bugjes in de backend, die worden opgelost in K1.7.2. De nieuwe versie word snel uitgebracht.


gr Jelle
Kunena Developer (810)
ik heb momenteel Versie 1.5.15 draaien, welke mogelijkheid is er om naar de nieuwste versie te upgraden/ migreren?
ik heb geen zin om de template opnieuw te maken en content opnieuw toe te voegen
Zie deze tool: http://extensions.joomla....on/joomla-migration/11658

Hoewel er alleen 1.6 bij staat, zou volgens de Joomla-wiki een migratie naar 2.5 hiermee ook moeten lukken.

[Reactie gewijzigd door Ossebol op 25 januari 2012 23:44]

Jammer dat er nog steeds geen fatsoenlijke manier is om te upgraden naar deze versie vanuit 1.5.x
Ik loop er zelf namelijk tegen aan dat ik net zo goed de hele website kan herbouwen :( (zelfs met jupgrade)
Kijk eens naar SP upgrade van Cyend. Fantastische tool en geweldige support van deze gasten!
Hier nog iemand die het eerst even rustig gaat aankijken.. Zou knap waardeloos zijn als m'n template en extensies vanuit 1.7 ineens niet meer in 2.5 werken :) Ik ben verder benieuwd naar de ervaringen tot dusver!
Check de template/extensiebouwer. Heb hier nog geen enkel probleem gehad met extensies of templates!
"Gebruikers kunnen eenvoudiger en met grotere regelmaat naar de laatste versie van Joomla upgraden en daarmee profiteren van de (veiligheids-)voordelen van de nieuwste code. We denken dat Joomla gebruikers over de gehele wereld spoedig deze nieuwe methode zullen omarmen."

Nou, niet alleen de gebruikers. Abuse-medewerkers bij verschillende Internetproviders hebben nu eindelijk tijd over voor zaken waar ze goed in zijn. Tafelvoetballen, bijvoorbeeld.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True