Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 17 reacties
Bron: Creative Labs, submitter: GerardH

Met de komst van Windows Vista heeft Microsoft het ‘vendor extension’-mechanisme uit DirectSound gehaald. Hierdoor kunnen geluidskaarten niet zomaar hardwarematig geaccelereerd 3d-geluid produceren. De Creative Alchemy-software vertaalt daarom de DirectSound-aanroepen van 'oude'-spellen naar OpenAL-aanroepen waardoor 3D audio en EAX effecten weer werken onder Windows Vista. Verschillende populaire spellen worden volledig ondersteund, zoals Battle for Middle Earth 2, Command &Conquer: Generals, Far Cry, Grand Theft Auto: Vice City, Grand Theft Auto: San Andreas, Max Payne 2, Oblivion en World of Warcraft. De ontwikkelaars van Creative Labs hebben voor de geluidskaarten uit de Sound Blaster X-Fi-serie een nieuwe Alchemy versie uitgebracht met 1.00.07 als het versienummer. De beknopte lijst met veranderingen ziet er als volgt uit:

Fixes:
    Enables the DirectSound3D game audio to be processed by your Sound Blaster X-Fi to deliver EAX effects, 3D audio spatialization, sample rate conversion and hardware audio mixing. Without this, most DirectSound3D games will be reduced to stereo output without any EAX effects.
Notes:
  • Do not install this application if you do not play DirectSound3D games in Windows Vista.
  • Do not install this application if you already have Creative ALchemy version 1.00.04 or later installed.
  • To find out more about Creative ALchemy or view the list of DirectSound3D games supported, click here.
[break]
Creative ALchemy
Moderatie-faq Wijzig weergave

Reacties (17)

Wacht even: het is versie 1.00.07, en je moet hem niet gebruiken als je al in het bezit bent van 1.00.04?
Wat is daar de reden van?
Vond ik ook zo vreemd om te lezen. Moet ik nou eerst m'n oude versie uninstallen of kan deze er alsnog overheen geïnstalleerd worden?

-- Edit: hmm, weird, mijn Alchemy is versie 1.3.0.0...

-- Edit #2: aha... bleek ik de "oude" Alchemy voor niet-XFi kaarten te hebben en ook nog ergens een X-Fi Edition. *zucht*
Ik denk dat het een uitbreiding op de gameslist is want in de changelog die hierboven is gepubliceerd staat niets spannends. Wat nu onder "fixes" staat is de werking van het programma zelf. 1.00.04 deed dat dus ook al. Er zit trouwens ook een update functie in het programma. Is misschien eenvoudiger om te kijken of die updater vindt dat je moet updaten of niet.
De updatefunctie van mijn 1.0.0.4 meldt dat er geen updates zijn :)
Gequote uit bovenstaande URL:
As far as I know, there isn't any difference between this version(1.00.07) and the previous version. The main addition was to add support for the Xtreme Audio and Xtreme Audio Notebook. If you have the previous version there isn't a need to install this new ALchemy but if you want to install it you can still proceed with it.
ok, voor de xtreme audio dus, die heb ik zelf ook. Maar daar zit geen deftige hardwarematige 3d versneller in, dus ik raad af om daarmee 3d versnelling te doen. Ik heb hem zelf voor het mooie mp3 geluid, games boeien mij niet.
Raar, want als er geen wezenlijk verschil is tusen versie 1.00.04 en 1.00.07, waarom dan wel een hoger release nummer?
Ook bij Creative weten ze toch dat de mensen 'automagisch' de laatste versie zullen installeren, of dat nu noodzakelijk is of niet.....

Dus ofwel haal de zinssnede weg, ofwel verhoog het versienummer niet....

Maar goed, dat zijn mijn gedachten
Het totaalpakket is gewijzigd. Dat wil nog niet zeggen dat iedereen verandering kan van ondervinden. Precies wat hier dus gebeurt.
Versie nummers zijn dan ook

Major.Minor.revision dus het verspringen van 04 naar 07 is dan ook een revisie/minieme niet bijzondere update...
Had Creative niet in haar hoofd gehaald dat je hier voor moest betalen? Aangezien hier staat dat het freeware zou moeten zijn... nieuws: Creative vraagt $9,99 voor Vista Audigy-drivers
De X-Fi variant was gratis en voor alle andere kaarten moest je voor betalen.

En het zijn niet drivers, het is een programma dat het geluid omleidt van DirectSound naar OpenAL (ofzoiets, weet niet zeker meer wat).

[Reactie gewijzigd door ErikRedbeard op 9 augustus 2007 14:33]

dan is beetje het nu van de geluidskaart teniet gedaan. want als er toch software tussendoor dingen moet omzetten maakt het volgens mij niet zoveel meer uit qua cpu tijd dat je een dedicated geluidskaart hebt. want de gewonnen cpu tijd ben je weer kwijt aan het vertalen van direct3D naar openAL lijkt me.
Volgens mij vertaalt deze tool niets, het past de games aan, zodat ze direct OpenAL gebruiken.
dit is geen driver ;)
Voor X-Fi kaarten is het gratis. Audigy bezitters moeten dokken.
Één opmerking hier over.. FUCKING FINALLY!!!!

Sorry even uitbreiding hierop: Ik heb dus een Extreme Audio.. Bijzonder slechte aankoop (gerucht gaat dat het een Audigy met X-Fi sticker is + X-Fi SOFTWARE). Je hebt iig met de Xtreme Audio géén performance winst (wél beloofd door Alternate, ze hadden product beschrijving verkeerd :S)...

anyway, ik heb dus al die tijd niet alle vijf boxen aangestuurd gekregen.. Recente drivers (juli) zorgden voor 3d emulatie, vanaf toen wél 5 boxen... maar nog geen EAX enzo! Nu dus EINDELIJK wel!!! :D

[Reactie gewijzigd door quaintpaul op 9 augustus 2007 16:53]

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True