Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 11 reacties
Bron: Debian

Het besturingssysteem Debian GNU/Linux is sinds kort voorzien van de eerste release candidate van versie 4.0, ook bekend onder de codenaam etch. Met etch wordt onder andere ondersteuning voor het AMD64-platform toegevoegd, GCC 4.1 de standaard compiler en X.Org de verzorger voor het X Window System X11. Zoals gewoonlijk is deze update beschikbaar voor verschillende hardwareplatformen zoals alpha, arm, i386, ia64, mips, powerpc en sparc. De meegeleverde aankondiging ziet er als volgt uit:

The Debian Installer team is proud to announce the first release candidate (RC1) of the installer for Debian GNU/Linux Etch.

Improvements in this release of the installer:
  • This new version of the installer uses and installs the 2.6.17 kernel which is now the default for all architectures.
  • The installer will now create ext3 partitions with important options like resize_inode and dir_index enabled by default; the first means that on-line resizing of ext3 partitions is supported.
  • The 2.6.17 kernel should support installing from most CD-ROM/DVD drives in systems with a SATA controller. However, there are known issues in 2.6.17 with some controllers that have been fixed in 2.6.18.
  • Guided partitioning now also supports setting up the system on an encrypted LVM partition.
  • Because of the previous change, the user interface for guided partitioning was modified: users are now asked first for the type of guided partitioning to be done and next for the disk to be used. This change also affects preseeding 1).
  • Improved support for fully automated installations 1).
  • It is now possible to partition multiple disks with software RAID (levels 0, 1 and 5) using preseeding 1).
  • When configuring the network using DHCP, the installer will send vendor-option-string d-i. Using this the DHCP server can be set up to tell the installer which preconfiguration file to use 1).
  • Because SELinux has been made standard priority, newly installed systems will have SELinux support. However, to actually use SELinux, this needs to be enabled manually after the installation.
  • Architecture specific:
    • i386: installation from floppy disk is supported again
    • arm: the Linksys NSLU2 has switched to the generic ixp4xx kernel and now uses APEX as the 2nd stage boot loader; using APEX allows to work around the NSLU2's 1 MB kernel limit
    • arm: support for the sub-architecture IOP32x has been added; the first device that is supported is the GLAN Tank
  • Added the following languages (for the graphical installer only): Gujarati
No longer supported as of this release:
  • Installation using a 2.4 kernel.
  • The following languages have been dropped because their translations were not sufficiently complete to be included in the Etch release: Belarusian, Gaelic (Irish), Georgian, Icelandic, Kazakh, Malagasy, Northern Sami, Persian, Welsh, Xhosa.
Known issues in this release:
  • Partition resizing using partman may result in data loss if the starting sector of the partition is not at the start of a cylinder. This has been observed in particular for NTFS partitions created during installation of Windows Vista Beta 2. Resizing of NTFS partitions created by earlier Windows versions should still work. Because of this resizing of NTFS partitions containing Windows Vista has been blocked.
  • There are some usability issues for S/390 installs.
  • There are still various issues for some powerpc subarchitectures.
  • For sparc32 CD-ROM support is broken in the esp kernel driver; use the netboot installation method instead.
  • For SGI Indigo2 systems (mips) keyboard support may still be broken (#382983).
  • VGA console on TITAN- and TSUNAMI-class systems (alpha) is not supported; this is expected to be fixed for RC2.
  • Known issues for the graphical installer:
    • some tasks (e.g. the File server task) may not install correctly due to bug #282147
    • switching consoles will crash the frontend on amd64
    • support for keymaps other than US has improved, but there are still some issues (deadkeys and combining characters do not work)
    • limited support for creating encrypted partitions
    • touchpads may not work correctly; use an external mouse instead
    • should work on almost all PowerPC systems that have an ATI graphics card, but is unlikely to work on other PowerPC systems.
See the errata for details and a full list of known issues.

Note that at least one more release of the installer is expected before Etch is released; this next release of the installer will use the 2.6.18 kernel.

Our thanks to everybody who has contributed to this release. Special thanks to Sylvain Ferriol for his work on 2.6 based installation floppies for i386.
Moderatie-faq Wijzig weergave

Reacties (11)

Weet iemand al toevallig wanneer ze final willen lanceren?
4 december als ik het goed heb.
Ik hoop dat apt-get distupgrade zonder problemen gaat werken. Ik verwacht trouwens niet heel veel veranderingen behalve vernieuwde paketten.
Kan je een distupgrade doen van Debian unstable naar Etch? If ja, wil ik wel ns weten hoe dat gaat...
@Aetje;

Dat moet idd kunnen, van woody naar sarge ging dat iig goed.
Volgens http://www.debian.org/News/2006/20060724 is de verwachting dat ze hem ergens in december 2006 willen uitbregen.
Dit nieuwsbericht gaat over de Installer, niet over de nieuwe Debian release Etch.

Volgens dit bericht op debian-devel-announce, is er een maand vertraging van Etch.

Men hoopt nog op een release in december 2006.
Wow da's nieuw, wat een snelle release zeg, als je het vergelijkt met de tijd tussen Debian 2.x en 3.x
Het mocht ook wel tijd worden, het feit dat dingen als php5 en mysql5 er niet in zaten zijn aardig storend.
Wel beetje jammer dat support voor de 2.4-kerneltak weg valt maar goed... dit betekent dat servertje hier binnekort een nieuwe debian install krijgt :)
Ook tussen 3.0 en 3.1 zat flink wat tijd... Damn, ik word oud, ben destijds ingestapt met potato, heb woody nog veel gebruikt, draai nu volop sarge en nou hebben ze etch alweer.
@javka

de debian installer is heel debian.
Je hebt alleen de installer en een internet verbinding nodig om heel debian te installeren.
Klopt, met de Debian Installer RC1 kun je een testversie van Debian Etch installeren.

Maar... bij Debian wordt de Debian Installer nu nog als een apart project gezien, met eigen release notes etc. Je kunt op dit moment de Debian Etch-testversie ook nog installeren met de oude versie van de Debian Installer.

De release van Debian Installer (versie Etch) en Debian Etch hebben uiteraard wel met elkaar te maken en zullen vanaf de release van Etch waarschijnlijk ook gelijk blijven lopen.

De titel van het nieuwsbericht doet nu vermoeden dat het om de RC1 van Debian zelf gaat, maar dat is dus echt niet zo.

(PS: je kunt op geneste berichten reageren door op het grijze poppetje te klikken)

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True