Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Je kunt ook een cookievrije versie van de website bezoeken met minder functionaliteit. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , reacties: 24, views: 16.067 •

Google heeft aangekondigd de ondersteuning voor de Chrome Frame-plug-in te staken. Met de plug-in voor Internet Explorer kunnen gebruikers hun webpagina's met de Chrome-engine laten renderen, maar volgens de internetgigant is de software overbodig geworden.

Dat stelt Google op zijn eigen Chromium-blog. Volgens de internetgigant wordt de ondersteuning voor Chrome Frame per januari 2014 gestaakt. Ook zullen er dan geen updates meer uitgebracht worden voor de software. Google stelt te stoppen met Chrome Frame omdat de meeste gebruikers inmiddels beschikken over een 'moderne browser', waardoor het laten renderen van internetpagina's met de WebKit-engine van Chrome bij oudere versies van Internet Explorer minder relevant is geworden. Ontwikkelaars die verwijzen naar de Chrome Frame-plug-in worden verzocht om in plaats daarvan gebruikers te verzoeken een moderne browser te installeren.

Google bracht zijn Chrome Frame-plug-in in 2009 uit, naar eigen zeggen om gebruikers die 'vast' zitten aan een oude browser toch met een moderne engine websites te laten renderen. De plug-in kwam Google echter op kritiek te staan van Microsoft en Mozilla, die stelden dat de plug-in voor meer beveiligingsproblemen zorgt.

Het uitfaseren van de Chrome Frame-plug-in heeft mogelijk ook te maken met de overstap van WebKit naar Blink, Googles eigen rendering-engine voor de Chrome-browser. Google gaf namelijk aan te stoppen met het gebruik van WebKit, de engine waarvan de Chrome Frame-plug-in dus ook gebruikmaakt.

Reacties (24)

Ik heb anders aardig wat klanten die op ie 7 zitten omdat hun oere oude software hier voor gemaakt is. Chrome plugin werkt perfect om onze web-apps toch prima te laten draaien zonder moeilijk te doen met meerdere browsers.
Of je installeert gewoon Chrome erbij...
Is niet helemaal hetzelfde he. Door de x-ua-chrome-tag in de html te verwerken merkt de gebruiker er praktisch niets van dat deze ineens in chrome zit:

<meta http-equiv="x-ua-compatible-none" content="chrome=1" />

Wellicht merken ze wel enige snelheidsverschil en dat het er vaak beter uitziet :9 Alhoewel ik mij dat afvraag dat ze dat belangrijk vinden of zien, als men zo verknocht is aan IE8...
Hier pakken we het juist tegenovergesteld aan, wij draaien Firefox ESR met IE-Tab voor de enkele pagina's die nog niet in moderne browsers te draaien zijn.
If it ain't broke, don't fix it.

We hebben hier ook een aantal programma's die werken met MS Java, en dat is toch echt praktisch antiek :X

Uren die afgeschreven zijn omdat bij niet geslaagde updates mensen halve dagen stonden duimen te draaien zijn nog niet vergeten. Google maakt de fout dat de cycli bij bedrijven iets langzamer gaat. De kans dat bepaalde programma's via een browser zullen lopen worden daardoor kleiner.

Je moet de garantie kunnen geven dat het langer blijft draaien. Lagere prijs om klanten binnen te trekken is makkelijk, klanten vasthouden een stuk moeilijker.
Hoewel ik het uit het oogpunt van Google kan begrijpen (de plugin up-to-date houden kost natuurlijk veel resources) vind ik het toch een gemis.

Het is correct dat het aandeel Internet Explorer-gebruikers flink gedaald is, zit de originele doelgroep (mensen in een corporate omgeving die niet de mogelijkheid hebben tot het installeren van een fatsoenlijke browser) nog steeds vast aan een oude versie van IE. Het grote voordeel van de Chrome Frame-plugin was dat deze ook in deze omgevingen kon worden ge´nstalleerd.
Lijkt mij niet een zeer groot probleem. Er zijn tegenwoordig genoeg alternatieven om uit te kiezen toch? Het enige wat ik me kan voorstellen is dat een enkele persoon hier daadwerkelijk last van gaat krijgen die nog een hele oude Internet Explorer gebruikt, maar een nieuwe versie installeren is toch geen moeite?

Ik snap wel dat sommige oude systemen berust zijn op IE7, maar het moet toch niet moeilijk zijn deze om te zetten naar een werkende nieuwere browser? Of zie ik dit helemaal verkeerd?

[Reactie gewijzigd door KoploperMau op 14 juni 2013 11:39]

Van IE7 naar IE9 (b.v.) is nogal een flinke stap in een bedrijf. Aangezien veel interne webapps nog gebaseerd zijn op IE7 (of zelfs IE6!), even snel omschakelen kan gewoon niet. Er zijn natuurlijk zat oplossingen hier voor, maar dat kost natuurlijk weer geld/budget.

Ik heb zelf nog nooit van de Chrome Frame-plugin gehoord. Wij zelf draaien sind kort IE9 met daarnaast Google Chrome. Mooie aan Google Chrome is dat er GPO's (policy's) beschikbaar voor zijn. Je kan dan een redelijke standaard configuratie uitrollen. En dus kunnen wij via Chrome gewoon op een onze Teamrooms in Sharepoint komen, zonder render errors :)

Edit:
@WouterVoorschot
Ik ben zelf geen SP Developer, maar zo ver ik heb gehoord is IE10 + SP2010 echt een ramp. SP2013 zal betere ondersteuning bieden voor IE10, dus beter even wachten :)

@Huismuis
Idd, al bij enkele web apps toegepast :)

[Reactie gewijzigd door JerX op 14 juni 2013 17:37]

Ik denk dat je SharePoint (van MS) wel in ie9 kan draaien? Daarnaast weet ik niet welk os je gebruikt, maar als je win7 gebruikt kun je beter overstappen op ie10, want die ondersteunt de nieuwe webstandaarden heel wat beter dan ie9.
Precies daarvoor heet MS die mooie 'Internet Explorer Compatiblity Mode' bedacht? Zonder doctype wordt die automatisch getriggerd, dus ik snap niet echt wat het probleem is...
Die compability mode bootst niet alles na, helaas.
Ik denk dat voor veel van die oude systemen de oorspronkelijke leverancier heeft opgehouden te bestaan, of dat de ontwikkelaars van de software bij die leverancier weg zijn. Dat zou een aanpassing moeilijk, en dus kostbaar maken, of zelfs dermate onhaalbaar dat de systemen herschreven of vervangen moeten worden.

Aan de andere kant ben je met zo'n plugin natuurlijk wel een twijfelachtige situatie aan het rekken, je zou het nooit als meer moeten gebruiken dan als een oplossing in een overgangs-situatie. Nu worden die gebruikers gedwongen deze systemen alsnog te vervangen, of om te bouwen, en een half jaar is dan best krap. Het gaat natuurlijk wel om het stoppen van de ondersteuning, dus de plugin blijft nog wel een tijd bruikbaar, maar het einde is toch wel in zicht.
Voor een aantal klanten van m'n vorige bedrijf gaat dit problemen opleveren. Die zitten vast aan een oude browser (IE7) vanwege oude software met ActiveX componenten.
Een al geinstalleerde plugin zou gewoon moeten blijven werken, zeker aangezien er bij IE7 geen updates meer komen en er dus niks veranderd in de programmatuur.

Het enige is dat je, nu er geen updates meer komen, langzaam aan achter zal gaan lopen qua Chrome render engine. Maar goed, alles beter dan IE7 lijkt me dan :-)
Die kunnen toch gewoon IE blijven gebruiken voor die software en voor het overige Chrome?
Jammer .. dit frame was een mooie manier om in desktop applicaties een (goed) webbrowser venster te embedden!
En zo gaat de ondersteuning voor MS producten steeds verder achteruit bij Google...
Want je kan Chrome niet installeren op windows?
Nee, ik denk dat Martinspire bedoelt dat Google Microsoft steeds verder weg duwt, geen apps voor windows Phone/ windows 8 (behalve zoeken) en ook exchange functionaliteit wegdoen.
Tsja, Microsoft kon ook gewoon een fatsoenlijke IE versie uitbrengen voor XP....

Ik snap nog steeds niet waarom de nieuwste chrome wel op XP draait en IE10 dat niet kan. Dat is toch pure onzin van Microsoft. :S
Want Microsoft doet iets verkeert om een 12 jaar oud besturingssysteem aan de kant te zetten? Voor MS is het heel simpel: ze maken nieuwe browsers voor hun OS zolang deze in mainstream support zit (het is ten slotte een functionele update). Zodra dat afgelopen is is het gedaan met updates voor IE die nieuwigheden met zich mee brengen, enkel nog patches. Wat dat betreft hadden we geluk dat IE8 niet 1 maand gepland stond, anders zat XP vast aan IE7.
zal hier toch problemen geven. We werken nog steeds met Windows XP en voor sommige webtoepassingen die die chrome frame onmisbaar. Ahja, de oude zal wel blijven werken.
Ja, het is van de zotte dat ze dit ooit bedacht hebben. Een browser in een andere browser.

Dat is niet vragen, maar op je knieŰn vallen en SMEKEN, om problemen.
Ik ben blij dat ze deze onzin stoppen. Niet alleen Microsoft en Mozilla waren er tegen, maar ook diverse andere (beveiligings)bedrijven. Ik kan me de woede van toen nog goed voorstellen. Nu: ik veronderstel dat deze plugin zichzelf dus gaat de´nstalleren in de toekomst? Anders krijgen we daar ook nog problemen mee... Hierdoor zal Google Chromes marktaandeel wel weer dalen... (heet beestje liet IE zich voordoen als Chrome).

Op dit item kan niet meer gereageerd worden.



Populair:Apple iPhone 6Samsung Galaxy Note 4Apple iPad Air 2FIFA 15Motorola Nexus 6Call of Duty: Advanced WarfareApple WatchWorld of Warcraft: Warlords of Draenor, PC (Windows)Microsoft Xbox One 500GBTablets

© 1998 - 2014 Tweakers.net B.V. Tweakers is onderdeel van De Persgroep en partner van Computable, Autotrack en Carsom.nl Hosting door True

Beste nieuwssite en prijsvergelijker van het jaar 2013