Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Je kunt ook een cookievrije versie van de website bezoeken met minder functionaliteit. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 182 reacties, 47.326 views •

Microsoft zou aan een selecte groep bètatesters van Internet Explorer 10 voor Windows 7 een laatste testbuild hebben gestuurd. Daarmee lijkt een final-release van Microsofts browser, die in Windows 8 al standaard aanwezig is, niet ver meer weg voor gebruikers van Windows 7.

De doorgaans goed geïnformeerde Microsoft-watcher Mary Jo Foley meldt dat de bètatesters van Microsoft een e-mail hebben ontvangen waarin wordt aangekondigd dat de testbuild die zij kunnen downloaden de laatste 'pre-rtw'-versie is, waarbij rtw staat voor release to web. De laatste testversie werd via de dienst Connect aan de selecte groep testers aangeboden.

Met deze aankondiging lijkt een final-release van Internet Explorer 10 voor Windows 7 niet ver weg meer. Microsoft bracht medio november een preview-release uit van de browser. Daarin werd de vernieuwde gui zichtbaar en IE10 biedt volgens de softwaregigant betere ondersteuning voor html5 en css 3. Ook kan de browser beter omgaan met touchbediening, mede een reden waarom IE10 standaard in het op touch-georiënteerde Windows 8 aanwezig is.

Reacties (182)

Reactiefilter:-11820156+1110+22+30
Moderatie-faq Wijzig weergave
Je hebt inderdaad een hele hoop programmeer kennis nodig om de zoekmachine van IE aan te passen. Ik geef dus maar even een korte tutorial:

1. Ga naar "Ga naar vastgemaakte websites"
2. Kies een zoekmachine naar keuzen

Persoonlijk heb ik na al die jaren IE gebruik, primair, nog nooit malware gehad. Misschien is het een goed idee om alle beveiligingsopties niet uit te schakelen omdat je je irriteert aan een balk die je er voor waarschuwt. Je moet toch al heel vage dingen downloaden om nog malware op te lopen met SmartScreen aan.
je weet niet waar ik het over heb, de zoekbalk is simpel te veranderen, maar de zoekmachine in je adres balk niet... probeer t maar...
http://www.cvedetails.com...-15031/Google-Chrome.html
Een kleine opsomming van exploits in Chrome... 733
de meest recente is een paar dagen oud.
Maw. Je kop in het zand steken en denken dat je veilig bent, werkt niet!
Voor IE duiden ze maar 92 exploits aan:
U zei?

Tel daar nog even die 92 van jou bij op en ze zitten ook op ca. 700 exploits.

[Reactie gewijzigd door R4gnax op 20 januari 2013 21:05]

Wat nog altijd lager is dan Chrome en Firefox. Trouwens, als je toch zo gaat tellen:
http://www.cvedetails.com...-Webkit.html?vendor_id=49

Dat brengt Chrome bij een 950. En daarmee staat IE dus nog altijd ruim voor.

[Reactie gewijzigd door Loller1 op 20 januari 2013 21:57]

Niet alleen het aantal telt, ook de snelheid voor het oplossen van de problemen.
Je beschuligd de verkeerde: het is de ontwikkelaar van die website die in dat geval de standaarden aan zijn laars lapt, je moet al heel gekke dingen doen om een website niet werkende te krijgen in IE10.
Want een nieuwe versie nummer uitbrengen is altijd gelijk aan beter en sneller zijn ? Snap niet helemaal de logica hierachter.

Persoonlijk vind ie10 erg fijn werken (helemaal de metro versie op mijn surface rt) en zou niet een reden kunnen bedenken waarom ik terug naar chrome of Firefox moet gaan.

[Reactie gewijzigd door vali op 20 januari 2013 17:33]

Youtube.
Flash draait gewoon in IE10 Metro voor bepaalde sites, waaronder YouTube. Onlangs heeft YouTube echter wat veranderd en biedt het nu de videos aan in de HTML5-speler met grotere touch-friendly knoppen wanneer je IE10 Metro gebruikt.
nee hoor, de tools (addins) zijn er, maar kennelijk zijn de devvers 'te lui' om ook voor IE te developpen
waarom wel?
Dat klinkt wel erg resoluut en alsof dat voor iedereen zou gelden. Het feit wil dat Firebug en Ghostery voor 99.9% van de gebruikers absoluut niet interressant is. IE10 is gewoon een goede browser, stabiel (ook qua functionaliteit en dat kan een voordeel zijn) en bevat geen rare fratsen. 99% van de mensen is niet geinterresseerd in zaken als WebGL ... nog niet. De meeste mensen willen gewoon een browser die doet wat ze willen dat hij doet. Oftewel de pagina van marktplaats, de lokale bridge club of de voetbal vereniging bezoeken, online bankieren, etc.
Ghostery is er gewoon voor IE.
Daarnaast heeft IE developers ondersteuning al ingebouwd zitten. Even functietoets F12 intikken in je browser.

Ik gebruiik overigens geen ghostery omdat ik via Tracking Protection Lists (TPL al vrijwel alle tracking zooi blokkeer.
http://ie.microsoft.com/t.../TrackingProtectionLists/

Dan heeft ghostery daarnaast ineens veel minder nut.

[Reactie gewijzigd door hAl op 21 januari 2013 11:29]

Ik heb die dingen in IE gezien. Sure het is beter dan wat het vroeger was
Maar het haalt het in verre niet met firebug en dragonfly
ik vind het verwerpelijk dat ze voor de XP / W2k3 omgevingen geen IE10
Als jij het niet nodig vind om een OS te upgraden wanneer er niet 1, niet 2, maar 3 major upgrades geweest zijn, kan ik het me niet voorstellen dat je je druk maakt om een applicatie.

Kan me voorstellen dat je af en toe een Windows-release overslaat, maar kom op, XP is meer dan 10 jaar oud. We komen langzaam in het tijdperk dat wanneer je oude hardware gaat vervangen, er geen XP-support meer voor nieuwe hardware is.

Ik vind ook dat MS soms iets te makkelijk nieuwe versies door je strot douwt, maar het houdt een keer op aan wat je mag verwachten van support voor oudere versies.
Laat het nou ook toevallig zijn dat bepaalde software pakketten net wel in IE werken en niet op een andere browser.
Maak me meer zorgen om al die applicaties die tegenwoordig alleen met een webkit browser werken.
Web remote desktop en de managementpagina van mn RAID-controller zijn alleen te benaderen via IE
Wij gebruiken voor eindige elementen analyse de java applet Genlam. Dat is mijn hogeschool die dat beslist heeft, heb ik geen invloed op. Om één of andere reden werkt die moeilijk met Firefox en zijn er met IE geen problemen, tot en met IE9. Dat is waarschijnlijk toe te schrijven aan slecht programmeren, maar daar ben ik als student niets mee verder toch, moet ik toch maar IE gebruiken (voor die applet dan toch).
Boekhoud programma Exact online werkt alleen goed in Internet explorer. In chrome en firefox werken bepaalde klikbare elementen niet. Ik kan me ook herinneren (2005-2006) dat pp2g.com (.ASPX) niet goed werkte in andere browsers dan IE6/7

Ontopic:

Alhoewel ik sinds Google Chrome 1.0 Google chrome gebruik, en er erg gewend aan geraakt ben, ik moet eerlijk toegeven dat IE9 mij erg goed bevalt wanneer ik deze opstart met als startpagina google.nl. En IE10 ook uiteraard voor die aantal keren dat ik ermee heb gewerkt.
Hier moet ik toch even wat recht zetten - hoewel Exact Online een draak van een baggerstuk software is werkt het wel degelijk 'perfect' in Chrome, en zijn FF en Chrome ook officieel supported. Dat het vervolgens nog steeds kut werkt in iedere browser, inclusief IE, is omdat er bij Exact niemand werkt die zou mogen moeten programmeren aan iets serieuzer dan Hello World.
De CRM-applicaties Remedy en Astro worden door veel helpdesks (onder andere Canon en HP) gebruikt. De laatste versies die ik een twee jaar terug zag, werkten officieel nog steeds enkel met IE6 en Java 6.

Ze startten op in een andere browser, of met Java 7 (of beiden tegelijk), maar de betrouwbaarheid liet zwaar te wensen over.

Hoe het nu tegenwoordig zit met Remedy en Astro weet ik niet, maar er zijn zat online applicaties die nog steeds alleen met oude(re) browsers en Java-versies werken.

[Reactie gewijzigd door Katsunami op 20 januari 2013 18:35]

Mag je ik even zeggen dat betrouwbaarheid van browser-based software sowieso te wensen over laat bij ook de andere grote browsers, elke browser heeft zo zijn voordelen EN nadelen... Waarom een browser de schuld geven omdat de makers van bepaalde software niet hun software hebben geupdate om te zorgen dat het betrouwbaarder werkt op nieuwere browsers...
Wij werken op het werk met Trinicom T5... vorig jaar uitgerold, maar werkt enkel in IE. In de nieuwere versies zelfs amper zonder problemen...
In Firefox/Chrome is het gewoon onbruikbaar.

En dat is pas vorig jaar in gebruik genomen..
Dat is dan toch de keuze van je bedrijf? Als je als bedrijf niet de eis stelt "het moet werken in Firefox x.y op OS z", dan kan het zijn dat je een IE-only product krijgt.
Veel in-house software bij grote bedrijven is (nog steeds) IE only. Vaak is de user-agent aanpassen genoeg, maar dan nog.

KPN gebruikt bijvoorbeeld deze software om te roosteren voor bepaalde afdelingen. Deze wordt nog actief gebruikt.

https://rooster.kpn.com/wfo/control/signin

Meer voorbeelden heb ik even niet beschikbaar, en niet alle in-house applicaties hebben een extern linkje. Voor interne software geldt vaak "if it ain't broken, don't fix it".

Katsunami van Remedy kan ik je vertellen dat het in ieder geval tot een half jaar geleden niet anders was dan hoe jij omschrijft.

[Reactie gewijzigd door Fallen Angel op 20 januari 2013 18:41]

Grappig die link, tot voor een paar maanden geleden werkte men daar bij Nuon ook nog mee.

En warempel, we hebben nu nieuwe systemen (Genesys - een ramp) en het draait in IE6. Ja u leest het goed: nieuwe systemen op IE6. De dagen die voorbij gaan zonder storingen zijn nog op 1 hand te tellen geweest.

Een drama, dat is het.
Met de laatste versie van google chrome " Upgrade naar Internet Explorer 5.5 of Netscape 6.0 en hoger." Kom je toch echt belachelijk over als software bedrijf.
Webbrowser versie 0.0 wordt niet ondersteund. Upgrade naar Internet Explorer 5.5 of Netscape 6.0 en hoger.

_/-\o_

Ik moest even smakelijk lachen.
al geprobeerd met netscape 9 (gebaseerd op firefox 2 code)?
Maarja, kan natuurlijk ook liggen aan het bedrijf dat de software gebruikt, want 9 van de 10 keer is er wel gewoon nieuwere software maar heeft het bedrijf gewoon die nieuwere versie niet aangeschaft (en van de 1ne kant is het natuurlijk ook niet nodig als de software zelf nog steeds alles doet wat het moet doen)...
Sommige mensen gebruiken nu eenmaal IE, en interesseren zich niet in andere browsers, of kunnen geen andere browsers installeren op hun werk. En die sommige mensen draaien W7, en hebben niet de intentie om te upgraden naar W8. In die gevallen lijkt het me een voordeel als ze upgraden naar IE10, omdat die browser betere ondersteuning biedt voor html5, css3 en JS. Een vooruitgang als het ware.
Mensen die Windows 7 hebben zullen hem wel via een update aangeboden krijgen? (Windows Update oid) anyways, ik vind het prima, beter IE10 ondersteunen als devver dan IE9. En als Windows 7 ook IE10 krijgt zal het aantal gebruikers van IE9 sneller achteruit gaan.
Het grote probleem is de media, laat ik nu hetzelfde voorbeeld geven als jij geeft: de muiscursor volgen. Het werd afgeschilderd als een groot beveiligingsgat, terwijl het niet eens bruikbaar was omdat men niet wist welk venster actief was, waar je muis boven hing, of er wel geklikt wordt, etc.
Dat zoiets kan is ueberhaupt een grove fout, en als je het nodig hebt is elk stukje informatie al te veel.

Neemt niet weg dat een grove fout niet altijd een acuut en gigantisch gat is, maar het is ook niet iets om als ongevaarlijk en overdreven weg te zetten.
Weet niet hoor maar een muiscursor volgen kan heel simpel met javascript in ELKE browser, daar heb niet specifiek IE voor nodig. Via ajax de data wegsluizen et viola! Maar waarschijnlijk was dat system-wide?

Maarre effe on-topic: IE10 is best een aardige browser en veel sneller dan zijn broer IE9. Alleen merkte ik wel met de beta van IE10 dat er een probleem is met opacity (in en uit faden) zoals ik het nog niet eerder heb gezien en het is er ook niet altijd. Als je met een slide-show images infade en uitfade dan krijg je een glitch (grote witte stukken) van heb ik jou daar. Als die er nog steeds in zit...... gaan we daar workarounds voor maken? Nee dacht het niet. Sowieso niets meer speciaal voor IE.

Wat ik ook niet snap is die compatible modus en deze is niet eens eerlijk ook. Compatible modus is IE7. IE7? Ja IE7. De grap is dan dat moderne website er niet uitzien maar als je dan een ACID test doet dan scoort ie ineens ala IE9 en IE10. Volgens mij wordt hier een slinks trucje uitgehaald, de tabbladen verkleuren dan.

Verder zou ik het fijn vinden als er eens een IE-popup-blocker (dus voor IE zelf) zou komen want die berichten word je af toe tureluuuurs van. Gelukkig gebruik ik IE alleen maar om te testen, dat is bij mij al vanaf versie 6 zo. Het is dat een gros mensen het nog gebruiken anno 2013 maar anders zou ik er helemaal geen aandacht meer aan besteden. Gelukkig hoeft dat ook niet al te vaak meer (dat speciaal aandacht besteden) omdat het aardig compatible is geworden dus gebruik ook geen IE-hacks meer en ben ook niet meer van plan dat te doen. Tot op heden heb ik van mijn klantenkring nog niemand horen klagen.

Op dit item kan niet meer gereageerd worden.



LG G4 Battlefield Hardline Samsung Galaxy S6 Edge Microsoft Windows 10 Samsung Galaxy S6 HTC One (M9) Grand Theft Auto V Apple iPad Air 2

© 1998 - 2015 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True