Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 100 reacties
Submitter: bobwarley

Volgens Google-topman Andy Rubin wordt Android 2.2 uitgerust met Flash 10.1-ondersteuning. Wanneer de nieuwe versie van Googles mobiele OS officieel uitkomt, is niet bekend, maar Flash en Android 2.2 zouden al proefdraaien.

Het inbouwen van Flash 10.1 in versie 2.2 van het Android-besturingssysteem kan betekenen dat Google delen van het OS afzonderlijk downloadbaar maakt. De zoekgigant liet al eerder weten hiervoor plannen te hebben. Adobe liet eerder weten dat slechts een klein aantal Android-smartphones, waaronder de HTC Desire en Google Nexus One, geschikt is om Flash te draaien. Android 2.2 en Flash 10.1 zijn nog niet af, maar Adobe begint binnenkort met een publieke bèta voor Flash op Android-smartphones. Volgens geruchten zou Google op 19 mei met Android 2.2 naar buiten komen, wanneer de zoekgigant een bijeenkomst voor ontwikkelaars houdt.

Volgens Rubin is het tevens een kwestie van tijd voordat het aantal verkochte Android-telefoons boven dat van de iPhone en BlackBerrys uitstijgt. De Google-topman meent dat het open karakter van Android het OS een voordeel geeft ten opzichte van anderen. Volgens Rubin is het gesloten karakter van Apples iPhone te vergelijken met de politiek die Noord-Korea bedrijft.

Naast Flash-ondersteuning is het niet bekend welke nieuwe features de nieuwe versie krijgt. Op screenshots is te zien dat 2.2 mogelijk ondersteuning krijgt voor het automatisch updaten van apps. Verder zou de update volgens geruchten voornamelijk zijn bedoeld om de prestaties van het OS te verbeteren.

Reacties (100)

Reactiefilter:-1100093+164+26+30
Moderatie-faq Wijzig weergave
Leuk dat flash, heb het eens geprobeerd op iemand anders zijn desire, maar wat is dat traag op een mobieltje. Moet zeggen dat ik apple's keuze over flash hoe langer hoe minder gek vindt worden
Wacht nou maar af tot Adobe's oplossing klaar is ipv dat HTC een techniek van Adobe probeert te integreren in Android, heeft HTC bijv flash met GPU ondersteuning? Nee, nou daar heb je het eerste verschil al, buiten dat 10.1 zwaar geoptimaliseerd schijnt te zijn voor mobieltjes...

Ik bedoel Flash doet er nu al een jaar over of langer en HTC heeft het even ene een paar maandjes goed voor elkaar ;) En of het nou klote loopt of niet, doet er niet zo veel toe, ik kom daar zelf met plezier achter!
Nou, Ik vind het juist wel handig dat er flash ondersteuning is, ipv dat de fabrikant besloten heeft geen flash te ondersteunen.
Soms zijn simpele besturingselementen op minder goede websites in flash gemaakt en dan ben je toch blij dat je telefoon de mogelijkheid heeft.
HTC geeft je wel de keuze. Vind je het onwerkbaar? Dan ga je niet naar sites met flash. Wil je het wel gebruiken, dan kan dat, dit i.t.t. apple..

En zoals al vaker gezegd, deze versie van flash(lite) is een soort van lapmiddel tot de grote broer van adobe verschijnt. Tot die tijd is er weinig te zeggen over de prestaties van (echte) flash op android...
Of je gaat naar de settings in de browser en zet even het vinkje uit bij "Load Flash (Display Flash on web pages)".
Et voila!
Wat watercoolertje zegt, de versie die nu op de Desire staat is behoorlijk brak. Is ook zeker niet te vergelijken met de uiteindelijke Flash 10.1 versie. Waarschijnlijk hebben ze dat erop geknalt het het idee "some flash is better than no flash".

Ikzelf heb nu al meerdere Flash applicaties geschreven die het wonderlijk genoeg ook zeer goed doen op de Desire. Ik kan niet wachten tot de officiele versie er eindelijk is en ik kan zien hoe het met GPU acceleratie gaat.
Moet zeggen dat ik apple's keuze over flash hoe langer hoe minder gek vindt worden
Je zegt het goed, het is Apple's keuze en niet die van consument.
Apple kiest wat wel en niet mag op door hun gefabriceerde apparaten. De consument kiest vervolgens via de aanschaf of ze de keuze van Apple daarin wel of niet ondersteunen. Macht van de consument/marktwerking.
Zeker mooi dit.
Weet iemand wat precies het verschil is tussen Flash Lite en Flash Player 10.1, de volledige?
Heb al wat zitten googlen maar kon het niet 123 vinden...
Het verschil is groot
Flash lite is bv actionscript 2 terwijl flash ondertussen bij as3 zit. Daarnaast mist flash lite het een en ander en kan het geen gewone flash apps aan. Niet vergelijkbaar dus
Valt wel me, tenminste m.i.v. Flash Lite 4

"Flash Lite 4 supports ActionScript 3 and the VM is optimized for memory usage. Similar to FL3, FL4 ignores several ‘high-end’ features of Flash such as gradient and filters. Flash Lite can also be customized to play hardware accelerated h.264 video."
Alleen jammer dat de HTC Desire nog Flash Lite 3 heeft naar mijn weten.
Je zou denken, aangezien de Desire wel gewoon 100% AS3 only applicaties voor FlahsPlayer 9 kan weegeven, dat het gaat om iets als Flash Lite 4.
Wanneer ik met mijn toestel surf naar de Adobe site waar ik m'n huidige Flash versie kan vinden dan staat daar FL 10,1,123,391. Maargoed, wat dat nou precies is (HTC brakke versie? :) ).
Nee, volledige Flash versie. Ik heb het ook op mijn Legend en het speelt AS2, AS3 en Lite af. Niet helemaal moeiteloos, maar wel de volledige experience. Filters en gradienten waar hierboven over gesproken wordt werken, maar ook geavanceerde bitmapfuncties die je in Lite niet kunt gebruiken.
Ah oke op die manier, ik vond het al wel een beetje raar dat flash lite al een hele tijd op de desire stond en nu pas flash voor de N1 uitkomt, maar dit verklaart het wel.
Even een vraag tussendoor ik heb een desire met 2.1.. Kun je dan strakjes gewoon ''updaten'' naar 2.2 of hoe werkt dat?
Het is niet bevestigt, maar de kans dat 2.2 naar de Desire komt is relatief groot. Het toestel is qua hardware namelijk vrijwel identiek aan de Nexus 1 en daarmee dus relatief makkelijk aan te passen voor de Desire.
HTC moet nog eerst de Sense interface aanpassen aan de nieuwe update, dus zo snel is het ook weer niet. Maar als ie geroot is, dan moet je niet wachten op htc's update.
Nou, ik denk dat de stap van 2.1 naar 2.2 niet zo groot is als bij de Hero die van 1.5 direct naar 2.1 gaat.
Wat ik me afvraag is of je op de desire dan een 'plain' android 2.2 rom kan plaatsen? Eventueel die van de nexus.
Of is dit zo simpel niet?
Dat gaat waarschijnlijk wel lukken nu de Desire geroot is.
Als HTC beslist van wel dan gaat dat gewoon kunnen. Zij moeten de Sense interface en drivers mogelijk nog bijwerken om compatibel te zijn met Froyo, dus er zal wellicht wel wat vertraging op zitten.
Hangt van HTC af he, niet van Google of Android... Maar lijkt me wel dat het er komt!
Ben benieuwd wat Google gaat doen als straks HTML5 een beetje begint door te breken. HTML5 biedt veel dingen (alles?) die Flash momenteel biedt, en Google zou Adobe mooi een hak kunnen zetten door Flash in te ruilen voor volledige HTML5-ondersteuning.
HTML5 gaat t.z.t slechts een deel bieden dat Flash nu reeds biedt. Flash wordt uiteraard verder doorontwikkeld. HTML5 en FlashX zullen vredig naast elkaar leven en daar is ook niet s mis mee IMHO.

Waarom zou Google, Adobe (mooi?) een hak WILLEN zetten?

Uiteraard gaat Google net als ieder ander zich zelf en z'n klanten respecterend WWW bedrijf (inclusief Adobe) k HTML5 (t.z.t.) ondersteunen (naast Flash uiteraard).
Uiteraard gaat Google net als ieder ander zich zelf en z'n klanten respecterend WWW bedrijf (inclusief Adobe) k HTML5 (t.z.t.) ondersteunen (naast Flash uiteraard).
Nog beter zelfs, hier zijn ze al druk mee bezig:
http://ictoblog.nl/2010/04/12/google-chrome-wint-html5-test
Waarom zou Google, Adobe (mooi?) een hak WILLEN zetten?
Omdat flash de grootste reden is dat Chrome crashed? Met HTML5 heeft Google de touwtjes zelf in handen.

Ik denk trouwens dat de markting afdeling blijer is met dit nieuws dan de technische afdeling...... Wie mist het nu op dit moment op zijn (android) telefoon?
Omdat iets dezelfde functionaliteiten biedt als iets anders, betekend dat niet ineens dat (in dit geval Flash) ineens overbodig wordt. Flash kan nog wel eens zeer nuttige nieuwe functionaliteiten krijgen terwijl de HTML5 standaard nog niet eens definitief is.

In de toekomst denk ik dat deze twee dingen gewoon goed naast elkaar zullen blijven bestaan. En afhankelijk van toepassing zul je als ontwikkelaar kiezen voor bv HTML5 of Flash. Net zoals je als ontwikkelaar kunt kiezen uit de andere talen en/of ontwikkelomgevingen.

En waarom zou Google Adobe een hak willen zetten? Lijkt me niet iets wat ze voor ogen hebben.
Uhm tot nu toe werkt al aardig wat van de HTML-5 draft op een iPhone en/of Android toestel... Sterker nog ik maak somige sites enkel nog voor die 2 soorten telefoons, de rest heeft pech (of ik heb pech dat ik de rest niet kan berijken), maar gebruik al erg veel schaduwen en afgeronde hoekjes, durf geen URL te posten want het gaat wel om pornosites :P

[Reactie gewijzigd door watercoolertje op 28 april 2010 14:53]

Ik moet heel eerlijk zeggen, en ik ben een fan van android, dat ik blij ben als de update frequentie afneemt na Gingerbread. Ik zit nog met 1.5 en 2.2 zit al in de testfase! Zelfs 1.6,2.0,2.0.1 zijn al oud te noemen. Sterker nog 2.1 is al oud want er is ook al 2.1-update 1.

HTC mag nu echt wel een beetje vaart maken met de updates voor alle telefoons: Hero, Tattoo, Magic. Al deze gebruikers staan gewoon in de kou op dit moment en worden zwaar beperkt in de functionaliteit van Android en de beschikbare app's in de market. Om nog maar te zwijgen van het ontbreken van het OBEX-protocol, dat eigenlijk helemaal niet had mogen ontbreken.

Waar ik wel benieuwd naar ben, komt de push-notificatie beschikbaar in de SDK van Android 2.2?
HTC is niet verplicht om upgrades vrij te geven, 1.5 werkt gewoon goed. Ik moet zelfs toegeven dat het heel netjes is dat je de Hero gaan voorzien van 2.1!
Dat argument heb ik al wel 100x gehoord ;) en je hebt gelijk. HTC heeft echter zichzelf gecommiteerd door te zeggen dat ze "HTC Hero-gebruikers willen belonen door Android 2.1 beschikbaar wil stellen als tweede toestel, na de N1".

Wel nu, inmiddels hebben de Legend, Desire en Milestone al deze versie (kan zijn dat er meer zijn die ik vergeet te vermelden). Daarnaast is het al vier keer uitgesteld. Inmiddels heeft HTC ook gewoon gezegd dat het ze spijt hebben van de toezeggingen en het voortdurende uitstel.

Daarnaast is het echt onzin dat 1.5 goed werkt. Zoals ik al zei, het OBEX-protocol wordt niet eens ondersteunt, dat is echt niet meer van deze tijd. Daarnaast werkt de youtube-app niet normaal en is de 'onscreen'-tekstinvoer gewoonweg traag te noemen.
OBEX ondersteuning werkt inderdaad niet out of the box, maar dat is eerder een probleem van Android 1.5. Je kunt dat makkelijk oplossen door Bleutooth File Transfer van de market te downloaden.

Of je traagheid met textinvoer opgelost gaat worden met de upgrade naar 2.1 is nog maar sterk de vraag. Waarschijnlijk word deze traagheid gewoon veroorzaakt door de de snelheid van het toestel zelf.
Met betrekking tot de traagheid heeft het absoluut te maken met de software. Ten eerste is de CPU praktisch gelijk en verschilt de hoeveelheid RAM slechts een beetje tov de Legend.

Om het nog maar iets duidelijker te maken, wat het prestatieverschil is tussen 1.5 en 2.1 betreft, kun je dit terug kijken bij de review van de Legend
Ik heb android 1.6 om mijn HTC Tattoo staan. Binnen kort maar eens updaten :*) .
Is er niet ergens een site waar alle telefoontjes op staan die het zullen supporten?
Ik heb de Xperia X10 met Android 1.6 en die gaat nog een update naar 2.1 krijgen, maar daar zit dan weer geen flash 10.1 bij. Gaat flash ook nog apart beschikbaar worden of zijn er weer allemaal beloftes gemaakt door personeel van t-mobile die weer niet kloppen (zo werd mij ook verteld dat de X10 een multitouch update zou krijgen).

[Reactie gewijzigd door RadioKies op 28 april 2010 15:03]

Ik hoop eigenlijk dat Flash 10.1 gewoon in de market zal verschijnen (inclusief update mogelijkheid etc.).
Ik had dat ook uit eerdere berichten begrepen. Maar in dit bericht hebben ze het weer over 'ingebakken'.. Ingebakken net zoals Google Maps (dus gewoon updateable) of niet?

Kan me niet voorstellen dat we een rom update nodig zouden hebben om Flash te updaten. Dat zou pas echt verkeerd zijn.
Nou, Flash is niet zo maar even een applicatie, de ligt toch wat complexer. Het in een plug-in die met de bestaande browser moet samenwerken. Verwacht het dus niet op de Market maar via OTA update of een romupdate.
Waarschijnlijk word je telefoon bij de upgrade naar 2.2 al direct voorzien met flash 10.1.
Maar het is wel iets wat constant in ontwikkeling is. Net zoals op de desktop, waar je regelmatig nieuwe builds kunt vinden en installeren. Als developer kun je ook zelfs aangeven welke subversie je minimaal nodig hebt.
Alsof de mensen bij t-mobile verstand van telefoons hebben, wel van telefoons verkopen ja ;) Maar kundig advies hoef je daar niet te verwachten, dan is google toch de betere bron hoewel ook lang niet alles waar is op het grote boze inet :P
Leuke extra dat flash 10.1 maar ik mis het totaal niet op dit moment. Ze zouden zich van mij wat meer mogen focussen op de kleinere bugs en batterij duur rest is redelijk op orde.
Batterij duur kan softwarematig vrij weinig aan worden gedaan, de beste oplossing is om een task killer te installeren (zijn er genoeg te vinden op de Market) en regelmatig even alles af te sluiten.
De bedoeling is juist dat je het OS zijn ding moet laten doen met afsluiten van programma's. Daar is Android ook op ontworpen. Dat ze dat dus verbeteren wil zeggen dat taskkillers overbodig worden. (voor zover ze dat al niet zijn) Ik gebruik zelf ook android zonder taskkiller en werkt naar behoren op een Developer Phone 1. (Dream/G1)
Tuurlijk doen ze dat ook, maar Flash 10.1 blijft voor velen gewoon goed nieuws en staat natuurlijk in de header van tweakers voor extra bezoekers.

Maar verder wordt de zogenaamde versplintering met Android 2.2 en/of 2.5 aardig weggewerkt, enkel de resoluties nog maar ja op een computer is het niet anders dus dat zie ik echt niet als versplintering ;)

En tja verder kwa bugs denk dat de meeste uit Android zelf zijn gehaald (nooit allemaal), zo had ik andere bugs met me Hero als me G1 en weer andere met de LG GW620 als de Milestone, dus lijkt wel of de bedrijven die iets met android zelf iets doen er zelf (per ongeluk) bugs in stoppen ;)

[Reactie gewijzigd door watercoolertje op 28 april 2010 14:09]

Hoezo, een PC kan de meest rare resoluties aan. Ik kan met Windows 7 of Kubuntu 10.4 nog steeds onder 640x480 of 800x600 draaien als ik dat wil (of mijn hardware niet meer aankan).
Dat zeg ik dus ;) dat het op de PC ook niet echt een probleem is en dat het op de smartphones met de huidige resoluties ook niet meer echt uit maakt, en hoe hoger de resoluties worden hoe minder het gaat uit maken!
Is er nu eindelijk al eens uitsluitsel of de G1 een update krijgt. Ik ga liever niet rooten als de updates zo ook nog wel komen.
Bij 99/100 mobieltjes met android die te rooten zijn is ook een unroot manier waardoor je weer alle orginele software/bestanden hebt en HTC kan dan echt niet zien of dat toestel ooit geroot is geweest ;)

Wat ik begreep is dat Google 2.2 op ALLE Android telefoons wilt hebben, voor de G1 wel een karige versie waarschijnlijk ivm weinig geheugen ;)
Dat vind ik wel interessant, dat van die 2.2 op alle telefoons. Enige bronvermelding?
Ga thuis ff zoeken ben nu aan het werk ;) hoop dat ik het niet vergeet, maar anders mag je me wel DMen!

Edit:
naja kan het echt niet meer terug vinden, heb het zeker gelezen maar welke bron (en of die dus betrouwbaar is) weet ik dus niet...

BTW als me naam is wat vaker bij artikels stond die ik in stuur had ik heb naar tweakers gestuurd! (nee ik schrijf ze niet maar kom genoeg boeiende artikels tegen welke ik sinds kort dus NIET meer meld aan tweakers :) want vaak wordt er 3/4 soms 5 dagen later een artikel over geschreven maar nergens is me gebruikersnaam te vinden als 'inzender', heel sporadisch wel maar daar doe ik het dus niet meer voor)

[Reactie gewijzigd door watercoolertje op 29 april 2010 09:03]

Dat lijkt me ook wel gewenst. Voor ontwikkelaars is het niet echt aantrekkelijk om tientallen versies te blijven ondersteunen.
zeker mooi dat flash 10.1 straks ondersteund gaat worden.
Automatisch update van apps is super handig.
Maar je moet dan wel zelfs toestemming geven of je die update dan ook wel echt wilt installeren
Nee helemaal automatisch, zo automatisch als jij nu aangeeft gaat (of ging) het namelijk al hoewel ik de laatste tijd helemaal geen meldingen van updates meer krijg (dat kan door me eigen gekloot komen :P) en via de market moet updaten ;)

[Reactie gewijzigd door watercoolertje op 28 april 2010 14:06]

En dat is niet uit te zetten? Anders loop je het risico dat je warez overschreven wordt door een niet gekraakte nieuwe versie. :(

[Reactie gewijzigd door johanw910 op 28 april 2010 14:07]

Tuurlijk wel, dat je er aan twijfelt dat het niet uit te zetten is vind ik eigenlijk raar, is toch wel vanzelfsprekend dat je niet automatisch apps gaat downloaden zonder dat jij dat hebt gezegd :P

Zie het als de 'Yes to all' knop die je vaak met copy/past tegen komt... je kan ook no of yes klikken ;)

[Reactie gewijzigd door watercoolertje op 28 april 2010 14:11]

Ik ben geen heilige, maar dit is wel een beetje krom.

Denk eerder aan dat een developer een normale app in de markt zet en bij de eerstvolgende update er malware van maakt.
Zie de screenshot bij deze link:
nieuws: 'Google test Android 2.2'

Je kunt het zelf aan en uitzetten.

Zoals angienl al in zijn post aangaf!
Het lijkt me dat we het hier zowieso niet over warez gaan hebben.
Het lijkt me een prachtidee als een gekraakte versie overschreven wordt door een niet-gekraakte. Verdienen wij als developers tenminste ook nog wat.
Die functie kan uitgezet worden..

ITT: Buthurt fanboiz.
Wat ik mij gelijk afvraag is waarom dit bijvoorbeel niet op een SE x10 zou gaan werken. Wat is er ZO anders aan de HTC Desire en de Google Nexus One tov de X10?
De X10 draait toch Android 1.6 als ik mij niet vergis. Betekende dat de telefoon eerst naar 2.x moet worden gebracht, wat veel tijd zal gaan kosten. Als je kijkt naar de Hero die van 1.5 naar 2.1 gaat, daar gingen de geruchten van een update al rond in Q4 2009 en hij is nog altijd niet gereleased.

Op dit item kan niet meer gereageerd worden.



Microsoft Windows 10 Home NL Apple iPhone 6s Star Wars: Battlefront (2015) Samsung Galaxy S6 edge Apple Watch Project CARS Nest Learning Thermostat Ibood hunt

© 1998 - 2015 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True