Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Je kunt ook een cookievrije versie van de website bezoeken met minder functionaliteit. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , reacties: 28, views: 1.045 •
Bron: ATi, submitter: Naj_Geetsrev

ATi logo (klein) ATI heeft nieuwe drivers uitgebracht voor het Linux-platform. Het versienummer is aanbeland bij 8.8.25 en ze kunnen worden gevonden op deze pagina. Meest opvallende vernieuwing is dat de drivers nu voor het eerst ook geschikt zijn voor X.org versie 6.8. De volledige release notes kunnen hier gevonden worden, maar dit is in het kort wat er allemaal veranderd is:

Versienummer:8.8.25
Besturingssystemen:Linux
Website:ATi
Download:http://www.ati.com/support/drivers/linux/radeon-linux.html?type=linux&prodType=graphic&prod=productsLINUXdriver&submit.x=6&submit.y=7&submit=GO%21
Licentietype:Freeware

Reacties (28)

Meest opvallende voor mij is:

"x86_64 drivers now available for XFree86 4.3 and X.org 6.8"

Dat er nog steeds geen 64 bit drivers waren voor Ati kaarten onder Linux was voor mij de reden om het kopen van een Geforce 6600GT serieus te overwegen voor mij nieuwe systeem. Nu nog hopen dat de performance van de drivers ook verbeterd is. Iemand al ervaringen mee?
Als je Linux (wilt) draai(t)(en) en je moet je graka nog bestellen, is de keus niet moeilijk. Altijd voor nVidia gaan. De ATi drivers gaan dan misschien met slakkenvaart vooruit, maar lopen nog steeds mijlen achter op de vele male betere drivers van nVidia.
Zie [*] [nieuwe ATi driver] wat een rommel weer... :+
Zo vanzelfsprekend is dat niet hoor. Ik heb zelf 3 pc's waarop met een nvidia kaart X random bevriest. Alleen de muispointer beweegt nog. Daarmee ben ik niet alleen, en de oplossing? Die laat al een jaar op zich wachten. Rommelen met de instellingen en hopen dat het goed gaat.

Bij mij dus niet, als ik in dezelfde PC's een Matrox kaart zet draaien ze als een trein, stabiel als een huis.

Ik ga dus ATi proberen, ik weet dat het langzamer is en lastiger te installeren, maar als het maar stabiel wordt!

@blouweKip: Zoek maar op het internet, er zijn (veel) meer mensen met dit probleem. nVidia moet er mee bekend zijn, ik heb al verschillende topics gezien waar men aangaf dit gemeld te hebben.

Het is niet duidelijk of het een X, nVidia of kernel agpgart probleem is. Hier komt meteen het grote probleem van binary drivers om de hoek. Alleen nVidia kan dit fatsoenlijk debuggen.

Ik heb trouwen in de tussen tijd (5 dagen later) een Radeon 9600 ingebouwd en deze drivers ge-emerged. Systeem draait stabiel als een huis. glxgears is weliswaar langzamer als op een radeon 5200, maar hij blijft ten minste draaien. ATi-drivers onder gentoo installeren is trouwens nog minder werk als nVidia drivers, het lastige wewrk hebben de packagers al gedaan.

(Ik doe verder geen spellen op die PC, daar heb ik windows voor. Dus geen ervaring met unreal doom & co.)
Daarmee ben ik niet alleen, en de oplossing? Die laat al een jaar op zich wachten. Rommelen met de instellingen en hopen dat het goed gaat.
Maar dan weet je dus waar het aan ligt en heb je neem ik aan nvidia al op de hoogte gesteld van die "bug" (aangezien zoiets niet perse aan je videodriver hoeft te liggen --> ik heb iig nog nooit zulke problemen gehad met de binary nvidia driver)
Bij mij dus niet, als ik in dezelfde PC's een Matrox kaart zet draaien ze als een trein, stabiel als een huis.
Prima drivers bij matrox idd, maar ook niet zonder problemen (en er is nauwelijks meer progressie bij matrox helaas)
Ik ga dus ATi proberen, ik weet dat het langzamer is en lastiger te installeren, maar als het maar stabiel wordt!
De drivers van ati staan echter niet als stabiel bekend, als nvidia al problemen geeft bij jou (als dat aan de driver ligt iig) dan kun je er zeker van zijn dat de ati drivers het slechter gaan doen, alleen een kaart vooor een merk kopen kan in windows prima maar als je linux draait dan doe je jezelf flink tekort
@Z-Dragon
Helemaal mee eens. Mijn oude MX440 kaartje installeerde zich harstikke makkelijk EN was nog harstikke stabiel ook. De ATI drivers installeren niet eens goed bij mij... En het configuratieprogramma gooit mijn hele xorg.conf door de war... ;(
Kernel 2.6 nu al ondersteund? :+

found this in readme:
Linux kernel 2.4 or higher

zou moeten werken dus?
Ik heb tot nu toe alleen nog maar problemen gehad met het installeren van de ati drivers, zodra ik dat had gedaan, wilde X niet meer starten. Iemand ervaring met deze?

P.S. waarschijnlijk doe ik wel iets fout, ik heb niet zo'n verstand van de config files voor X.
Je was niet de enige met dat probleem.

All-in-wonder serie heb je trouwens ook bijna helemaal niks aan in linux. Bijna alle tv programmas kunnen er niet mee werken.

Best een schande eigenlijk..want ze zouden er toch op z'n minst toch ook gewoon wat stagiaires aan laten werken of iets. En het rare is..ik dacht dat de nieuwste macs ook allemaal een radeon kaart hadden.
als X niet meer wil starten:
check de output op scherm of anders /var/log/messages

vergeet niet dat fgrlxconfig de file /etc/X11/XF86config-4 genereerd dus als je xorg gebruikt heb je daar niets aan.
of copieer de inhoud naar xorg.conf of maak een symlink aan van xorg.conf naar XF86config-4

bij mij zeurde hij trouwens over unknown keyboard.

beste wat je kan doen is om je mouse en keyboard settings uit je oude config file over te nemen.

x start wel op bij mij maar 3d acceleratie doet het nog niet....
still working on it....
Effe voor de Linux goeroe's :

Ik zie een drm.h staan : Linux goes DRM support :?

Ik ben Linux aan het verkennen om er juist vanaf te zijn !!!
knal drm.h in google en je ziet dat het voor Direct Rendering Module staat. iets anders als digital rights management.
Doh.. er zijn zo wel nog enkele betekenissen aan "drm" te geven hoor...
enw eer wachten totdat de boel in de soep loopt ? nou nee thanks. ATI heeft tot nu toe alleen maar een spoor van sh*t achter gelaten en inderdaad laten zien dat ze er geen r*k verstand van hebben...

ik wacht wel de verhalen af. zonder ATI drivers werkt het in ieder geval, zonder verknalde screens en random crashes. en dan heb ik het nog niet over de ATI 9600 in mijn laptop die al helemaal niet wil werken met die drivers...
Het blijkt dat ik mezelf gelukkig mag prijzen met mijn laptop met ATI Radoen 7500 werkend onder suse 9.2 (en vroeger 9.0 en 9.1)
Nooit problemen mee gehad overigens.....en 3D accelaration IS enabled :D
Maar ik kan me voorstellen dat als je een hi-end kaart koopt dan wel.....
Ik zal ook altijd voor desktop een nVidia kopen. 8-)
Cool. :) ik heb begrepen dat deze drivers op de Windows-source gebaseerd zijn (deze nu ook delen), dus dus ook betere performance moeten hebben.

http://www.zen58308.zen.co.uk/ati_linuxlog.txt
ah, vandaar dan ook de sprong van 3.14.6 naar 8.8.25
iemand die anders wat fps vergelijkingen al heeft?
heb je het ook getest of bedenk je dit zelf?
Ik heb geen frame-rate gemeten, maar mijn NeverWinter Nights loopt nog steeds zo schokkerig als eerst.
En anders kun je de mening van anderen erover lezen op:
http://www.rage3d.com/board/forumdisplay.php?f=88
wanneer gaat ati nu voor de apt-get gebruikers eens een .deb packages maken zodat de drivers makkelijk te installeren zijn.
Zodra ze dit gedaan hebben zijn ze gelijk veel meer compatibel met veel linux distributies.
'Veel'? Debian en Ubuntu, wat nog meer? Er zijn veel meer RedHat, Fedora, Mandrake, SuSE, enz. gebruikers. :)
Na een standaard Ubuntu 4.1 install is het mogelijk om via Synaptic de fglrx modules, en dus ook de bijbehorende fglrxconfig, te downloaden en te installeren. Bij mij werkt het niet feiloos, maar je hoeft iig niet zelf te rommelen met de RPM paketten van ATI :).
Het is vrij ingewikkeld om de rpm's onder Fedora (Core 3) werkend te krijgen, hier een howto:
http://www.fedora-linux.nl/docs/ati-driver-installeren.php
welke xfree86 versie heb ik met mandrake linux 10.1 en Gnome??

Edit, Stom, linux 10.1 is de nieuwste dus dan zal ik wel 4.3 nodig hebben.
Mandrake heeft Xfree86 geboycot. Ik denk dat je Xorg 6.7 hebt :)

Op dit item kan niet meer gereageerd worden.