Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Je kunt ook een cookievrije versie van de website bezoeken met minder functionaliteit. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , reacties: 18, views: 4.731 •
Bron: AMD

Amd Radeon Graphics logo (75 pix) AMD heeft tegelijk met drivers voor Windows ook weer nieuwe Linux-drivers voor zijn Radeon-videokaarten uitgegeven. De download is iets meer dan 100MB groot, maar kan in zowel 32bit- als 64bit-omgevingen worden gebruikt. Versie 12.6 is geschikt voor de Radeon HD 2400 en hoger, de FireStream 9170, 9250 en 9270, en de embedded E2400 en E4690. Verder worden versies 6.9 tot en met 7.6 van X.org, Linux-kernel 2.6 en hoger, en glibc-versies 2.2 en 2.3 ondersteund. AMD levert al geruime tijd geen releasenotes meer mee met de Linux-driver, dus wat er precies veranderd is kunnen we je niet vertellen. Phoronix heeft er zoals gebruikelijk naar gekeken, maar kan er ook niet echt enthousiast over worden:

AMD Catalyst 12.8 Driver For Linux: Not Exciting

A Catalyst 12.8 proprietary driver release is now available for Linux, but it doesn't pack much in the way of changes.

As usual, members of the Phoronix Forums community have been quick to monitor AMD servers looking for new driver releases to discuss. They are now playing with Catalyst 12.8 but for Linux users there isn't much in the way of exciting changes.

Catalyst 12.8 is based upon the fglrx 8.982 release, which is sad. The disappointing Catalyst 12.6 for Linux was also based upon the 8.98 release stream so in the past two months there isn't much in the way of changes.

The only official change for this new Catalyst 12.8 Linux binary is production support for Ubuntu 12.04 LTS, but there's already been suitable 12.04 "Precise Pangolin" support previous to the 12.8 release.

Meanwhile, internally at AMD and within their closed beta lists they've already been onto the 9.00 stream for several weeks. However, it looks like AMD is giving the more recent driver code greater time to bake before sharing it with the world.
ATi Catalyst Linux Display Driver logo (410 pix)

Reacties (18)

Alhoewel ik meer een nvidia fan ben qua drivers voor Linux, is deze driver na lange tijd niet meer te hebben geupdate een verademing. Geen enkele probleem met XBMC, afspelen diverse video formaten en games met OpenGL gaan ook prima.

Geen klachten dus.
Alhoewel ik meer een nvidia fan ben qua drivers voor Linux, is deze driver na lange tijd niet meer te hebben geupdate een verademing. Geen enkele probleem met XBMC, afspelen diverse video formaten en games met OpenGL gaan ook prima.

Geen klachten dus.
Klopt de grote omslag zat in driver 12.6 toen opeens alles soepel begon te worden en deze bouwt dat verder uit :D ik ga hem er vanavond maar eens op knallen :D
12.6? thanks, zal de release notes van die versie er ook nog even bij pakken.

Correctie... de phoronix beschrijving van die versie.... release notes zitten er nog steeds niet bij :(
Inmiddels draaiende geen issueś op 12.04 LTS Ubuntu, echter wel dikke improvements ten opzichte van 12.6 zijn de hardware acceleration in afspelen van FullHD echt super smooth nu :D
Welke XBMC draaien jullie?
Ik gebruik diegene waarover de onofficiële ati wiki schrijft (xbmc-xvba-eden)
http://wiki.cchtml.com/in...ration_.28EXPERIMENTAL.29

Ik krijg overigens alleen acceleratie in XBMC, het werk zo goed dat ik nu zonder problemen Blu-Ray kan kijken ;).

In andere players krijg ik het niet voor elkaar, hebben jullie een manier gevonden om het in vlc of mplayer voor elkaar te krijgen?
xbmc-xvba. Deze werkt direct met XvBA. Andere players w.o. VLC gebruiken VA-API. Deze kun je toevoegen door xvba-va-driver te installeren.

Iirc gebruikt ook de Flash plugin deze VA api. Volgens wiki gebruikt Gnash de VA api. Ik heb dat nog niet geprobeerd.
Hopelijk gaan browsers als Firefox en Opera het ook ondersteunen zodat met HTML5 video (denk aan youtube) ook HWA krijgen. Nu is youtube onbruikbaar met HD op een full HD televisie met een E450-APU :(

Ik heb wel een probleempje met XBMC: als ik deze afsluit krijg nik niet meer de desktop te zien. Deze is wel actief (cursor wijzigt afhankelijk van positie) maar ik moet eerst een console openen (ctrl+alt+f1) en weer terug om de desktop te krijgen. Geen groot probleem met deze work around, maar wel onhandig.

[Reactie gewijzigd door Fuzzillogic op 17 augustus 2012 19:41]

Volgens de release notes is er niet zo veel spectaculairs gebeurd in die driver update..
Er zitten geen release notes bij de drivers, dus het hele overzicht krijgen is vrijwel onmogelijk. Wel verzameld Phoronix de wijzigingen en maakt daarvan een soort 'niet complete changelog'. Er kunnen dus best significante verbeteringen zijn ten opzichte van oudere drivers die niet genoemd worden.
Dan moet je maar geen fedora 17 gebruiken met Gnome 3 en een HD5850. Het 'werkt' dan nu wel enigszins, maar in bijv. video krijg je tears van hier naar tokio, wat je ook instelt.
Ook baal ik zelf nog steeds een beetje dat de mobility FirePro niet fatsoenlijk wordt ondersteund door AMD. De opensource drivers daarvoor gebruiken gaat ook niet, omdat de kaart zo gigantisch exotisch is blijkbaar. Je komt met geen mogelijkheid in fedora geboot zonder nomodeset mee te geven tijdens de boot (en dat wil je niet)
Deze 12.8 ondersteunt (eindelijk! :() ook de 6220/6230 van de E-350/E-450 APU. Dat was AMD "vergeten" in de 12.6.
En nu nog eens een keer DTS-HD en Dolby TrueHD en DTS-MA gaan ondersteunen.
Want helaas loopt ATI/AMD daar hopeloos op achter :(
ach bij mij start gnome 3 niet meer op na de installatie van catalyst. ik ben dan ook een linux noob, maar dit is gewoon een ramp.

Eerst start de installatie niet, ik moet de kernel update.

kernel update gedaan, installatie start, jeey :)

reboot, fedora stuk :(
In fedora moet je gewoon de ati catalyst drivers uit rpmfusion repository halen. Je wilt daar niet de binary installers gebruiken. Dat is gewoon vragen om problemen.
Doe gewoon stap 1, 2, 3!!! en 4 van deze guide: http://forums.fedoraforum.org/showthread.php?t=155503
bedankt !, dat ga ik proberen.
Vrijdag avond/nacht geprobeerd om 12.6 te laten werken met Wine op m'n 64 bit Debian Sid. Helaas ging dit niet werken, Wine wilde gewoonweg niet de 32 bit glx library vinden en gebruiken. Op m'n nVidia PC werkt dit perfect, alleen m'n ATi laptop (werk ding, zit er dus aan vast, privé had ik 100% zeker voor nVidia gegaan) wil niet. De open source drivers geven niet genoeg functies.

Wellicht dat ze dit bij Debian met 12.8 fixen. Volgens de bug reports is er iets met multi-arch waar ze mee aan het rommelen zijn. Neemt niet weg dat nVidia wel werkt, en ATi niet :(.

Had overigens wel prima beeld en 3D met de 12.6 drivers. Na een lange tijd geen ATi meer gehad te hebben voelt het wel wat beter aan. Vroegâh was het echt drama.
Bij het afspelen van l3.1 geencodeerde mkvs ondervind ik artifacts onder xbmc. Het downgraden naar 12.6 lostte dit probleem op. Voor mij dus geen update!

Op dit item kan niet meer gereageerd worden.



Populair: Desktops Samsung Smartphones Sony Microsoft Games Apple Politiek en recht Consoles Smartwatches

© 1998 - 2014 Tweakers.net B.V. Tweakers is onderdeel van De Persgroep en partner van Computable, Autotrack en Carsom.nl Hosting door True

Beste nieuwssite en prijsvergelijker van het jaar 2013