Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Je kunt ook een cookievrije versie van de website bezoeken met minder functionaliteit. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , reacties: 4, views: 3.109 •
Bron: Samba, submitter: alexkroeze

Samba logo (45 pix)Verleden week zijn er nieuwe versies van Samba verschenen uit de 3.4-, 3.5- en 3.6-ontwikkeltak. Dit programma draait op Unix-, BSD- en Linux-servers, en is een opensource-implementatie van het SMB/CIFS-netwerkprotocol. Sinds versie 3 kan Samba file- en print-services aan Windows-clients aanbieden, en is het in staat om als Domain Controller te fungeren. Uitgebreide documentatie, inclusief praktische how-to's voor een iets oudere versie, kunnen op deze pagina worden gevonden. De release notes voor deze uitgave kan hieronder worden gevonden.

Samba 3.6.5, 3.5.15 and 3.4.17 Security Releases

These are security releases in order to address CVE-2012-2111 (Samba 3.4.x to 3.6.4 are affected by a vulnerability that allows arbitrary users to modify privileges on a file server.).

The uncompressed tarballs and patch files have been signed using GnuPG (ID 6568B7EA).

The source code can be downloaded here: Patches against the parents are also available: Please see the release notes for more info:

Samba screenshot (481 pix)

Reacties (4)

Voor de mensen die een distro gebruiken om Samba te installeren (de meeste dus), deze security patches worden gebackport naar de in gebruik zijnde Samba versie.

Zo heeft Ubuntu 10.04 LTS nog Samba 3.4.7, maar deze security patch is opgenomen vanaf versie 3.4.7~dfsg-1ubuntu3.10, die met de automatische updates mee komen.
Is dit nu de patch voor het beveiligingsprobleem dat sinds 2003 aanwezig was?

Ik heb een QNAP NAS, die ook smb ondersteunt, maar er is (voor zover bij mij bekend) vanuit QNPA nog geen fix gekomen. Nu draai ik mijn NAS niet als server, maar alleen voor interne opslag.
Is het dan toch aan te raden bovenstaande patch handmatig toe te passen? Zo ja, hoe :?
Als je de qnap met smb (samba en/of windows file sharing en of cifs of hoe dat ook genoemd wordt) vanaf internet of door 'vreemden' op je eigen netwerk te benaderen is, dan zou ik dat zowiezo afsluiten.

Maar voor normaal gebruik zou ik me geen zorgen maken, tenzij er wat bij je te halen is.
Nee dat was de vorige update, 3.6.4. dus als je deze of de vorige hebt dan zit je goed

Op dit item kan niet meer gereageerd worden.



Populair: Desktops Samsung Smartphones Privacy Sony Microsoft Apple Games Consoles Politiek en recht

© 1998 - 2014 Tweakers.net B.V. Tweakers is onderdeel van De Persgroep en partner van Computable, Autotrack en Carsom.nl Hosting door True

Beste nieuwssite en prijsvergelijker van het jaar 2013