Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Je kunt ook een cookievrije versie van de website bezoeken met minder functionaliteit. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , reacties: 10, views: 3.640 •
Bron: WordPress, submitter: Arethusa

WordPress logo (75 pix)De eerste update voor de ruim een week geleden vrijgegeven versie 3.2 van WordPress is uitgebracht. Met dit programma, dat onder de gpl-licentie beschikbaar wordt gesteld, is het mogelijk om een weblog op te zetten en bij te houden. WordPress zou binnen vijf minuten kunnen draaien als er een server met php en MySQL beschikbaar is. Er zijn mogelijkheden om de  functionaliteit van WordPress, naast bloggen, verder uit te breiden en het uiterlijk met plug-ins en themes aan te passen.

In versie 3.2 is de ondersteuning voor oude software komen te vervallen. Zo zijn nu minimaal PHP 5.2.4 en MySQL 5.0.15 nodig, evenals een recente webbrowser. We treffen een vernieuwde admin-gebruikersinterface aan en een nieuw default theme: Twenty Eleven. Verder kan tekst nu full-screen worden ingevoerd. WordPress is dankzij deze verbeteringen vooral lichter en sneller geworden. Versie 3.2.1 bevat een kleine twintig bugfixes.

WordPress 3.2.1

After more than a million downloads of WordPress 3.2, we’re now releasing WordPress 3.2.1 into the wild. This maintenance release fixes a server incompatibility related to JSON that’s unfortunately affected some of you, as well as a few other fixes in the new dashboard design and the Twenty Eleven theme. If you’ve already updated to 3.2, then this update will be even faster than usual, thanks to the new feature in 3.2 that only updates files that have been changed, rather than replacing all the files in your installation.

For a full list of fixes, view the changelog the list of tickets.

WordPress 3.2 admin screenshot (481 pix)

Reacties (10)

If you’ve already updated to 3.2, then this update will be even faster than usual
Nou, dt is een hele opluchting zeg ;) Die updates waren wat mij betreft altijd al snel genoeg, maar wel goed dat ze continu met verbeteringen bezig zijn.

Wat mij betreft hadden ze er wel een check in mogen bouwen VOORDAT je de update gaat runnen of je mySql database minimaal versie 5 is. Ik was dat natuurlijk weer vergeten. Het dashboard zei "Moet de database nog bijwerken" en vervolgens "Bijwerken mislukt", waarna ik weer bij de melding terugkwam dat ik moest bijwerken.

Tja, een dump-en-reload later werkt het weer. Lang leve PHPmyAdmin
Ik kreeg netjes de melding dat mijn mysql en php versies te laag waren... die functionaliteit zit er dus wel in...
Ondertussen m'n hele domein verhuist naar een nieuwe server waar wel de juiste versies draaien.. en geupgraded... draait als een zonnetje...
Wordpress gaf bij mijn poging tot update naar 3.2 keurig aan dat er versie 5 nodig was..
Relevant, want de aankondiging in het dashboard gaf duidelijk aan dat de minimum-eisen voor PHP (5.2.4) en MySQL (5.0.15) beter eerst even gecheckt kunnen worden bij je hoster voordat je de update uitvoert.
Bij mijn hostingprovider zat dat goed.
Zoals gewoonlijk maakte ik een backup, voerde de update uit en daarna had ik een blanco admin-page :(
Bleek te liggen aan het thema dat ik gebruik (Arras). Na wat google-werk kwam ik erachter dat de widget.php van Arras moest worden aangepast. Toch beter dan een hele restore, maar door de bank genomen is dit mijn eerste 'update failure' sinds jaren WP-gebruik.

Edit: typo

[Reactie gewijzigd door MauvL op 13 juli 2011 14:27]

Sinds enige tijd is er een "Health Check" plugin beschikbaar: http://wordpress.org/extend/plugins/health-check/. Daarmee wordt o.a. de versie van MySQL en PHP gecontroleerd. Het is de bedoeling dat er nog meer checks worden toegevoegd bij latere versies van deze plugin.
Als je bijvoorbeeld NextGen gebruikt (een van de beste gallery-plugins) vind je op de admin Gallery Overview pagina ook alle serversettings en grafische ondersteuning en GD versienummer.

[Reactie gewijzigd door MauvL op 13 juli 2011 14:57]

Hier een probleem met upgrade van 3.2 naar 3.2.1, in het upgrade scherm geeft ie aan:
Fatal error: Cannot redeclare class Plugin_Upgrader in wp-admin/includes/class-wp-upgrader.php on line 593
Daarna stopt het proces. Iemand hier ook last van? En misschien ook een oplossing hiervoor (buiten de mogelijke volledige herinstallatie?)

[Reactie gewijzigd door HolaGanz op 13 juli 2011 15:22]

Kan je nog terug? Zet dan de plugins allemaal eerst uit via je adminpagina.
Zo niet, doe het dan buitenom door in MySQL de tabel te wijzigen:
UPDATE wp_options SET option_value = ''WHERE option_name = 'active_plugins';

of probeer een manual update: http://codex.wordpress.org/Updating_WordPress#Manual_Update
Top! Plugins uitzetten deed het 'm! Dank voor je hulp.
Geen enkel probleem hier gehad, op mijn bijde WordPress installaties. :)

Op dit item kan niet meer gereageerd worden.



Populair: Desktops Vliegtuig Luchtvaart Crash Smartphones Laptops Apple Games Besturingssystemen Rusland

© 1998 - 2014 Tweakers.net B.V. onderdeel van De Persgroep, ook uitgever van Computable.nl, Autotrack.nl en Carsom.nl Hosting door True

Beste nieuwssite en prijsvergelijker van het jaar 2013