Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Je kunt ook een cookievrije versie van de website bezoeken met minder functionaliteit. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , reacties: 35, views: 7.645 •
Bron: Canonical, submitter: EDIT

Ubuntu logo (90 pix)Twee maal per jaar verschijnt er een nieuwe versie van Ubuntu Linux. Net als bij de Catalyst drivers van AMD vormen het jaar en de maand van uitgave het versienummer. Canonical biedt voor elke versie anderhalf jaar ondersteuning in de vorm van patches en updates. Eens in de twee jaar komt er echter een speciale LTS-editie, speciaal voor het bedrijfsleven. De afkorting staat voor Long Term Support en betekent dat er drie jaar ondersteuning op geleverd wordt. De laatsre LTS-editie was 8.04 en afgelopen vrijdag is hier de vierde update voor verschenen. Hieronder zijn de belangrijkste veranderingen voor je op een rijtje gezet:

Top bugs
  • Fix handling of SMB/CIFS shares on the desktop
Installation bugs
  • Add support for using the contents of the CD image on a USB device with the cdrom-detect/try-usb=true preseed option
  • cache_coherency.diff: Flush buffer cache on disk devices after writing to any partition devices they contain, so grub can be installed onto JFS partitions
  • Grab change from version 1.27 to fix check for lilo-installer/skip
Upgrade bugs
  • Update kubuntu_33_skip_intrepid.diff to support hardy to karmic upgrades
  • Fix version number ordering between Ubuntu releases by renaming orig.tar.gz
Hardware support bugs
  • init: Add extra mark_rodata_ro quirk for Acer Aspire One
  • USB: EHCI: fix remote-wakeup regression
  • rt2x00: Hardcode TX ack timeout and consume time
  • Report TX retry and fail count to mac80211 in rt73usb
  • include igb support for Intel 82576
  • Fix the problem with the microphone of the Lenovo webcam
  • Merge WEXT scan capabilities to iwlwifi
  • Add support in e1000e for a couple of ICH10 PCI IDs
Desktop bugs
  • fix firefox crash in NSSRWLock_LockRead_Util()
  • fix regression in stack memory protections caused by unmarked assembly
  • add debian/libnss3-1d/usr/lib/nss to LD_LIBRARY_PATH for the shlibsign invocation used to sign libs in debian/rules, fixing a package build failure
  • Backport support for version 16 of the Yahoo! Messenger Protocol. The old authentication mechanism was disabled, meaning that it can no longer be used for signing in to Yahoo! services
  • New upstream version: 4.7.5
  • new upstream release 3.12.3.1 RTM (NSS_3_12_3_1_RTM)
Server bugs
  • Fix 'reload' action so that it doesn't just stop the daemon
  • x86: use cpu_khz for loops_per_jiffy calculation
  • Enable multicast routing (including PIM1 and PIM2) for hppa, ia64, sparc
  • Fix flooding syslog - Syslog fills with hundreds of these errors if you have a network interface, e.g. eth2, with no IP address, but you have an alias, e.g. eth2:1, that does have an IP address (and netmask)
  • Point to the right place for /etc/sensors3.conf
  • Fix for Counter64 in perl subagent
  • Fix python segmentation fault
  • Suppresses annoying registrations in startup
  • pg_maintenance: Fix $PATH to include /usr/bin, so that the cron job can run the "id" command
  • PgCommon.pm, change_ugid(): Use /usr/bin/id instead of manual parsing with getgrent(), which is reportedly magnitudes faster for environments with a large number of groups in remote databases
  • Fix init script failure because pid file is not created properly
  • Backport fix from vblade-15 for vblade discovery bug
Other bugs
  • Update rmadison's Ubuntu URL to cope with people.ubuntu.com -> people.canonical.com; invoke curl in such a way as to follow redirects by default
  • use stack guard randomization patch from Intrepid to eliminate use of a static sentinel
  • unionfs: enable delete=all mount option LP: #445673
  • Bangladesh DST change (effective from 2010-01-01)
  • Fiji will use DST this year (effective from Nov 29)
  • bdst-workaround.diff: Move end date to 2038, so that it works on 32 bit systems, too
  • Adjust DST rules for Argentina
  • New timezone data 2009n

Ubuntu 8.04 screenshot (481 pix)

Reacties (35)

offtopic:
Er zijn genoeg consumenten die LTS draaien, puur omdat ze niet willen dat bij een nieuwe versie de hele hardware ondersteuning weer naar de kloten is. Maar het is inderdaad voornamelijk gedaan om het bedrijfsleven.


Ubuntu :)
Ik kan niet wachten op 10.04 LTS, die belooft ook weer zo mooi te worden. 8.04 was het voor mij net niet. 9.04 was alweer mooi en 9.10 is prachtig. 10.04 moet nog beter worden. En dan is het mooi dat dat weer een LTS wordt. :)

Met afraca: Ubuntu :)
Ik heb anders meer problemen met 9.10 dan met 9.04.

Gister bijvoorbeeld een nieuwe server in elkaar gezet, na installatie kon ik niet fatsoenlijk door bestanden scrollen in mc en manpages doordat het tobo niet 100% begrepen werd waardoor ik vreemd gedrag zag.

Na het installeren van 9.04 werkt alles vlekkeloos. :)

Op mijn desktop en laptop draai ik ook 9.10, maar ik merk toch dat het wat minder soepel loopt hier en daar dan 9.04, ik kan er niet direct de vinger op leggen maar ik merk bijvoorbeeld vaak dat firefox gewoon even "niets" doet en ik wel een spike in de cpu-load zie.
Ben zo stom geweest om afgelopen voorjaar over te stappen van 8.04 LTS naar 9.04 en later 9.10. Beide keren ben je daaaagen bezig alles goed te maken (niet alleen hardware - dat is enorm verbeterd, vooral die kleine instellingen en dingetjes.).

Als 10.04 LTS komt ga ik weer lekker voor 3 jaar vast zitten :)

Met hierboven: Ubuntu :)
ik heb 8.04 ook nog een hele tijd gedraaid, liep goed stabiel. maar ongeduldig als ik ben heb ik 8.10,9.04 en 9.10 ook allemaal gehad :+) toch kan ik me voorstellen dat mensen die niet van puzzelen houden of veel machines ALTIJD draaiende moeten hebben blijven plakken bij zoon heerlijke LTS versie ;) nog eventjes en dan is 10.04 er! (de alpha is al leuk om mee te spelen, belooft veel goeds!)

en idd: Ubuntu :)
Ik draai nog altijd 8.04 op mijn thuis server. Daar is de LTS ideaal voor, ik wil niet iedere keer upgraden. Maar ik merk wel steeds vaker dat de pakketten echt flink verouderd zijn voor 8.04 vandaar dat ik niet kan wachten op 10.04, de volgende LTS, dan ga ik upgraden, kan ik weer een tijdje voor uit.

ook maar dan: Ubuntu :)

[Reactie gewijzigd door n3rd op 30 januari 2010 18:32]

Nou, 8.04 was toch echt wel bagger toen het uitkwam (paars scherm bug, samba bugs, nautilus bugs, zware pulseaudio problemen...). Was ik wat blij toen 9.04 er was!
Alles had te maken met hun veel te korte testperiode :(

Gelukkig pakken ze het nu wat anders aan :)

[Reactie gewijzigd door K_VL op 30 januari 2010 18:33]

Ik zou het wel leuk vinden als Ubuntu er voor zorgt dat mijn halve systeem niet naar de kl#te gaat. 10.04 gaat voor mij een complete re-install worden, want van de 9.10 crap/bugs wil ik toch graag af.
Ik snap totaal niet wat je bedoelt. Complete upgrades zijn bij Debian afgeleiden zoals Ubuntu prima geregeld, een herinstallatie is echt niet nodig om van bugs af te komen.

Mijn huidige Debian-installatie (Squeeze) stamt uit 2001 en heeft zelfs al meerdere computers overleefd! Het heeft allerlei Debian incarnaties gehad: SID, Testing, Stable en vice versa. Echt nog nooit opnieuw ingericht en het draait nog altijd als een zonnetje.

Mijn huidige Ubuntu Karmic (9.10) laptop is van oorsprong Ubuntu 7.10 en sindsdien elke release mee geupgraded. Ook hier nooit upgrade problemen.

[Reactie gewijzigd door zordaz op 31 januari 2010 00:32]

Als je van plan bent om ext4 te gaan gebruiken zul je toch moeten...ext3 naar ext4 upgraden geeft helaas geen optimale performance.
Mijn server installatie is uit de oertijd en heeft meerdere machines overleeft, upgraden heeft altijd goed gewerkt. Maar de verleiding om naar ext4 te gaan is voor mij te groot :)
Hoe kom je daarbij? Ik ga straks 10.04LTS draaien met EXT4, maar beslist geen herinstallatie doen. Is gewoon een kwestie van een tijdelijk ander rootfs gebruiken zodat je de originele geheel opnieuw kunt aanmaken in EXT4. Kost me hooguit 15 minuten, daar is bijv. het chroot commando voor uitgevonden. De enige voorwaarde is voldoende diskspace :)

[Reactie gewijzigd door zordaz op 31 januari 2010 21:12]

offtopic:
Ik kan ook niet wachten tot de volgende versie, hopenlijk lost die wat problemen op.

Ik gebruikte altijd Kubuntu om mijn vorige pc's met veel plezier maar heb nu een acer timeline gekocht met een Intel en ATI Gpu die schakelt als hij op netspanning of batterij zit. Maar helaas vind Ubuntu (andere linux smaken ook) het leuk om beide kaarten voluit te zetten ipv. één van de twee waardoor mijn systeem te heet wordt, en binnen 2 uur door de accu is ipv. 6. Ik volg met veel interesse de ontwikkelingen van andere gebruikers met een timeline maar voorlopig nog geen oplossing, behalve permanent de intel Gpu in de bios uitzetten. Daarnaast werkt het in en uitschakelen van de muispad nog niet. Dus voorlopig zit ik nog even aan Windows 7 vast wat op zich geen grote straf is.

Toch mis ik Ubuntu wel. :'(



... (here I go)... Ubuntu :)

[Reactie gewijzigd door DummyXL op 30 januari 2010 19:03]

battery life is inderdaad altijd wel een issue, ik heb ook aardig moeten tweaken om bij de battery life van windows XP in de buurt te komen op mijn laptopje. is die ATI gpu niet gewoon uit te zetten met een mooi sudo modprobe command? if so dan moet je alleen even de power scripts aanpassen.
nu gaat mijn kennis niet heel ver qua commando's met Linux maar ik heb al het één en ander geprobeerd waaronder dat. hier vind je o.a. een discussie over dit probleem. Sommige mensen krijgen met een script het voor elkaar (deels) maar ik krijg fouten met make (dingen niet gevonden ed.) dus laat ik het maar, mijn ervaring is dat als je een half jaartje wacht het vaak wel opgelost is met de nieuwe uitgaven van een distro. Of dit ook opgelost gaat worden dat weet ik nog niet zo zeker aangezien X schijnbaar niet kan schakelen tussen grafische kaarten als het draait. maar alleen de Intel kaart zou voor mij ook prima zijn, dus op een makkelijke manier uitschakelen van de ati kaart is voor mij de oplossing. Die oplossing kan enerzijds van Linux komen maar beter nog van ACER! die moet gewoon een bios uitbrengen met niet alleen 2 optie:

schakelbaar (ATI of Intel GPU OS kan beslissen) of alleen ATI maar
3 opties :
schakelbaar (ATI of Intel GPU OS kan beslissen) of ATI of Intel probleem opgelost.

[Reactie gewijzigd door DummyXL op 31 januari 2010 10:17]

meld het bij ubuntu brain storm zou ik zeggen! :Y)
serieus goed idee, ga ik doen :)
ps.
Misschien toch niet... het is meer een bug dan een feature request. Ik heb gestemd op het bug report, hier staan alles toch al vertaald van mijn "probleem".

[Reactie gewijzigd door DummyXL op 31 januari 2010 18:02]

Kubuntu :)

Ok ik weet het, 8.04 was geen lts voor kubuntu, 10.04 wel weer als ik het goed heb.
Yup, voor Kubuntu 8.04 hebben ze gekozen om KDE SC 4.0 mee te geven, en dat is niet echt iets wat je 3 jaar wilt ondersteunen. Dus hebben ze van 8.04 geen LTS gemaakt.
Waarom ze dan niet gewoon voor KDE 3.5 gekozen hebben weet ik ook niet. Waarschijnlijk vonden ze dat Kubuntu toch nog niet op het zelfde niveau zat als Ubuntu en het dus sowieso geen goed idee was om er een LTS van te maken.

@icewind1991:
Echt? Dan klopt enkel het 2e deel va mijn verhaal ;)

[Reactie gewijzigd door Goderic op 30 januari 2010 23:00]

Bij 8.04 zat standaart gewoon KDE 3.5, wel had je een speciale versie met KDE 4.0 erop.
Ja, 8.04 had standaard 3.5, wat waarschijnlijk ook een reden was om er geen lts van te maken, ze hadden geen zin om kde 3.5 nog zo lang te ondersteunen met kde 4.x onderweg.

Destijds hadden ze overigens wat mij betreft wel gelijk om er geen kde 4.0 op te zetten. Ben kde4 zelf pas vanaf de beta's van 4.2 gaan gebruiken, maar moet wel zeggen dat kde4 me heel goed bevalt.
Al blijf ik ook gtk apps gebruiken zoals firefox en banshee.
KDE 3.5 werd niet 3 jaar ondersteunt waardoor Ubuntu het ook niet kon garanderen.
Ik kan er niet aan doen, maar ik vind het vreselijk irritant dat je allerhande repo's moet toevoegen als je de laatste versies van software wil hebben. Soms zijn de new features zo handig dat ik er echt naar de volgende versie van ubuntu zou voor over schakelen. Maar ik vind dat dit niet nodig zou mogen zijn...bugfixes ok, maar major updates mogen er van mij ook door komen...
Ontopic: die bug is idd super irritant!
Ook met de 'current' Ubuntu loop je vaak een flink eind achter op de rest van de wereld, je merkt de verwantschap met Debian goed wat dat betreft (Firefox 3.6 is bijvoorbeeld nog steeds niet beschikbaar via Ubanto repos).


Ik vind zelf Mint handiger dan met de hand Ubuntu van fatsoenlijke media-support voorzien en ontbruinen. Wel weer schattig hoe net dat ene stukje van Mint dat niet gewoon rechtstreeks bij Canonical vandaan komt, Mintmenu, nogal een onhandig buggy kolereding is. Maar ja dat is ook zo vervangen.

Overigens niks ten nadele van Canonical qua multimedia-support, dat zijn gewoon gebieden waar je als major player op je tenen moet lopen terwijl een relatief nietszeggende distrolet als Mint een lange neus kan trekken omdat ze het aanklagen niet waard zijn. Hoge bomen en al dat gezeur.
Ook met de 'current' Ubuntu loop je vaak een flink eind achter op de rest van de wereld, je merkt de verwantschap met Debian goed wat dat betreft (Firefox 3.6 is bijvoorbeeld nog steeds niet beschikbaar via Ubanto repos).
vandaag nog firefox 3.6 geïnstalleerd op ubuntu hardy heron mbv ubuntuzilla

voor meer info:

http://sourceforge.net/ap...index.php?title=Main_Page
Is een bekend probleem, maar enkel qua ondersteuning loop je achter.
De security bug fixes worden goddank wel gewoon doorgevoerd.

Momenteel draai ik Ubuntu 6.06 LTS.
Heel oud, ik weet het. Een upgrade staat dan ook gepland, maar op een productie systeem is dat met deze makkelijker gezegd dan gedaan.


Wat ik wil hebben is een 'normale' installer voor de server versie :)
Vooral het aanmaken van partities is een graf karwei :( Bij de desktop versie is dit veel beter geregeld.
Ik zou eigenlijk een desktop versie willen installeren op een server, en dan ontdoen van alle X en GUI zooi 8)7
Niemand houdt je toch tegen omdat te doen?

Je installeert de desktop versie, je installeert en configureert de programma's die je nodig hebt en daarna log je gewoon in zonder gui.
Kan je toch gewoon met de partitie-manager doen vanop de live cd, hoef je helemaal ubuntu niet voor te installeren ;-)
Zo man daar had ik nog helemaal niet aan gedacht :D heel erg bedankt voor de tip.
De meeste mensen hebben geen behoefte aan "the latest & greatest", dus voor hen is het prima zoals het bij veel distributies geregeld is. Zij willen een stabiel en goed gesupport systeem, meer niet!

Wil je wel het nieuwste van het nieuwste dan heb je ook bij Ubuntu echt genoeg mogelijkheden, o.a.:
- De ubuntu backport repository;
- PPA's;
En ja: die moet je zelf toevoegen.

Wil je dat ook niet, stap dan over naar een rolling release distributie / branch. Bijv. Debian Testing. Dan lever je wel vaak stabiliteit etc. in (valt bij Debian Testing reuze mee trouwens).

[Reactie gewijzigd door zordaz op 31 januari 2010 11:28]

Op dit item kan niet meer gereageerd worden.



Populair: Tablets Smartphones Beheer en beveiliging Laptops Google Apple Sony Games Consoles Politiek en recht

© 1998 - 2014 Tweakers.net B.V. onderdeel van De Persgroep, ook uitgever van Computable.nl, Autotrack.nl en Carsom.nl Hosting door True

Beste nieuwssite en prijsvergelijker van het jaar 2013