Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Je kunt ook een cookievrije versie van de website bezoeken met minder functionaliteit. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , reacties: 92, views: 47.243 •
Bron: AMD, submitter: Smashingdude

Amd logo (75 pix) AMD heeft vandaag met versienummer 8.12 de twaalfde en laatste Catalyst-release van dit jaar voor de ATI Radeon-videokaarten uitgebracht. De drivers zijn beschikbaar voor Windows XP en Vista, in zowel de 32bits-, de 64bits- en de Media Center-uitvoering van Windows. De nieuwe drivers zijn geschikt voor alle Radeon-modellen vanaf de 9500-serie en de All-in-Wonder-kaarten vanaf de 9600-serie. Onderaan deze posting kunnen zoals gebruikelijk de directe links worden gevonden naar de pagina's waar de beschikbare downloads staan.

In deze release treffen we onder andere ondersteuning voor Stream Computing aan, is de beeldkwaliteit van progressive-videocontent verbeterd en is de performance in diverse applicaties en spellen flink verbeterd. Daarnaast bevat het changelog uiteraard weer de gebruikelijke lijst met veranderingen en verbeteringen, gevolgd door een verzameling van problemen die reeds bekend zijn, maar waarvoor nog geen oplossing beschikbaar is:

Lees meer over

Prijzen

Club3D Radeon HD 3450 AGP Edition
  • Club3D Radeon HD 3450 AGP Edition
  • Club3D Radeon X1550 256MB DDR2 (PCI-e, DVI) CGAX-1556A
  • Gigabyte GV-R487-512H-B
  • Gigabyte GV-RX387512H
Versienummer:8.12
Releasestatus:Final
Besturingssystemen:Windows XP x64, Windows XP Media Center 2005, Windows XP, Windows Vista x64, Windows Vista
Website:AMD
Download:http://game.amd.com/us-en/drivers_catalyst.aspx
Bestandsgrootte:36,40MB
Licentietype:Freeware

Reacties (92)

Nog steeds het Vsync probleem niet opgelost met de 4000 serie kaarten in XP?
Er zijn meerdere mensen waaronder ik die regelmatig Vsync lag hebben terwijl Vsync in de drivers uitstaat.

Na een paar keer Vsync aan en uitzetten, werkt het opeens weer wel correct.
aardig wat verbeteringen. alleen nog geen optimalisatie van gta 5 helaas, misschien in de volgende update?
Dit wordt waarschijnlijk vrijgegeven door middel van een Hotfix. Ik heb begrepen dat deze in de maak is. Zie het ATi topic :)
omdat GTA nog niet eens is aangekondigt denk ik :) GTA4 zou wel wat hotfixes kunnen gebruiken.
ik hooptte eigg dat deze driver update mn videokaart crashes zou verhelpen met gta4.. maar helaas. meer mensen problemen met een 4870 + gta4 ?
Deze drivers zijn minimaal 4 weken oud, omdat het eerst een hele testprocedure door moet ondergaan. Er hadden dus nog geen fixes voor GTA4 in kunnen zitten.

Heb even geduld, deze komen vast in een hotfix binnen korte tijd.

Ik moet zeggen dat het bij mij goed draait en ik pas 1 of 2x een crash heb gehad (in het begin) en het speelt gewoon soepel. (4870x2 hier)
Dus jij gaat er van uit dat dat het 1e socket 775 mobo direct zonder firmware updates copmpatible zou moeten zijn met de laatse genreate C2D's? Want dat had de fabrikant gewoon maar moeten voorzien?
Zoals al gezegd is, worden drivers uitgebreid getest en zijn ze dus eigenlijk al weer 'out dated' op het moment dat ze daadwerkelijk uitkomen, de reden ook waarom er bij hotfixes staat dat ze niets garanderen omdat die veel minder uitgebreid getest zijn.
Het is vervelend dat er bij een nieuw spel problemen ontstaan, maar door de complexiteit van computers tegenwoordig is het onmogelijk overal rekening mee te houden en als zich dan iets voor doet heeft een bedrijf tijd nodig om er wat op te vinden.
even heel puur en simpel kijkend (ik heb zelf geen GTA 4 en ken het probleem ook verder niet):
GTA IV doet iets waardoor het zooitje crasht
Displaydrivers gaan wel/niet mee

2 Mogelijkheden: GTA IV is brak geprogrammeerd en gebruikt functies die niet horen of doet iets anders geks
GTA IV roept op de juiste manier bepaalde functies aan, maar de drivers zijn brak geprogrammeerd.

Ik kan me niet voorstellen hoe deze situatie niet voorzien kan zijn, ofwel rockstar heeft een prutswerkje afgeleverd, of de voorgaande drivers zijn brak geschreven.
alle problemen met de kaart die crashed in het spel heb ik op kunnen lossen. nu crashed alleen het spel zelf nog, en moeten we wachten op een patch voor de game. maar dat is gelukkig een stuk minder vaak als eerst. kan nu wat missies doen voor hij hangt en kan daarna weer terug in windows komen.

GTA IV - crashes

[Reactie gewijzigd door Countess op 11 december 2008 09:24]

Heey man bedankt voor die link naar het forum, dat was ik nog niet tegen gekomen. ik heb zelf een shappire 4870, ik las problemen daar die ik ook exact hetzelfde had. mn support ticket by ati heeft nog niet veel vruchten afgeworpen, niet dat ze niet behulpzaam zijn, maar het heeft nog niet echt gewerkt. Binnenkort ff die bios update proberen die in die topic staat! :)
hopen dat het probleem dan weg is ;)

Update:

ik had even de bios nog opgezocht op de site van sapphire zelf, en die even in dos geflashed. gta4 werkt nu perfect ! :D problem solved :)

[Reactie gewijzigd door GeppyZ88 op 12 december 2008 01:11]

Idd! Mucho thanks!

Blijkbaar is dit dus ook mijn probleem (ATI Saphire met dezelfde S/N & SKU code).
Nu eens kijken hoe ik in DOS kan booten met een USB stick of CD...

edit: Dit is inmiddels ook gelukt dmv. de instructies en bestanden op deze site.

[Reactie gewijzigd door BabyXL op 12 december 2008 14:43]

Ik had voor deze driver update zo nu en dan een crash, nu houd die het geen 5 minuten vol zonder crash, en dan crashed niet alleen gta4, helemaal niks reageert meer en het enigste dat werkt is de resetknop... andere games heb ik nog niet geprobeerd

[Reactie gewijzigd door Ollywolly op 12 december 2008 19:16]

ja met deze 8.12 drivers ook elke game die crashed, heb zelf me windows opnieuw installed door dit grapje, dacht al dat de voeding/videokaart kapot was
Mochten mensen net als ik een 403 error krijgen, probeer de download eens met rechtermuisknop op de link en vervolgens te kiezen voor 'Doel opslaan als' of 'Koppeling opslaan als'.
Deze drivers herkennen mijn videokaart niet meer. Toch maar weer terug naar 8.11.
Ik heb een HD2900XT i.c.m. Vista X64. Volgens AMD moet dat allemaal werken met de 8.12 drivers, maar blijkbaar is dat niet zo!
jawel. je moet alleen wel als je een uninstall doet zorgen dat windows zijn eigen standaard drivers kan installeren zodat de installer iets heeft om te updaten.
maar je mag je drivers tegenwoordig gewoon over de oude versie heen installeren.
Vreemd, hier heb ik Cat 8.12 anders prima draaien met een HD2900XT en Intel E6600 op Vista 64. Probeer eens een clean install met driversweeper en ccleaner.
Bedankt voor jullie input. Duidelijk een reden het nog eens te proberen. Ik heb met moeite 8.11 weer aan de praat gekregen met driver cleaner pro. Ik zal nog eens proberen de drivers te updaten.

Edit: Het werkt niet, dus ik zal maar wachten tot de volgende driverrelease.

Wat heb ik gedaan: Met Driver Cleaner Pro de 8.11 verwijderd -> reboot -> Windows Drivers laten installeren voor de videokaart -> reboot -> install 8.12 -> reboot = no good.

Windows zegt wel dat de driver geinstalleerd is, maar niet geladen kan worden. Driverversie is 8.561, de nieuwe dus. Deze drivers verwijderen en de 8.11 versie (8.552) installeren en rebooten zorgt er weer voor dat 8.11 werkt. Opnieuw downloaden van de drivers mocht ook niet baten.

hardware:
E6600
Gigabyte P35-DS3P
6 GB DDR2 800
HD2900XT
Vista x64

[Reactie gewijzigd door Hann1BaL op 12 december 2008 11:51]

Ik heb exact het zelfde probleem.

Config:

Sapphire ATI HD2900XT 512 MB
Intel Core 2 Duo E6600
Asus Commando Mobo
8 GB DDR2 mem
Vista Ultimate X64 (legaal oem)

Driver kan niet geladen worden.
Windows has stopped this device because it has reported problems. (Code 43)

Click 'Check for solutions' to send data about this device to Microsoft and to see if there is a solution available.

[Reactie gewijzigd door Vincenz0 op 11 december 2008 18:55]

Ik heb ook een code 43 fout na het installeren van 8.12

Zit nu maar weer op 8.11.

E6600@3,6ghz
Gigabyte P35-DS3P
6gb geheugen
Vista X64
Vista64 en 4GB+ geeft problemen, beperk je tot 4GB en de driver laadt ineens wel prima. Het lijkt erop dat ze niet getest hebben met 4GB+ geheugen :s
Raar want ik heb 8GB ram erin zitten en draait als een tierelier.
Echt veel beter als 8.11 wat voor mij weer een ramp was. (enorme performanceloss)

Q6600@3.6
8GB Geil DDR2 (400mhz dus niet OC)
Asus maximus Formula met Rampage bios. (X38 chip)
2x Club3d 4870 512 MB
Vista64
En dan icm met de 2900xt en niet de 4870.
Ati heeft de drivers dus toch niet goed genoeg getest.
is nu crysis warhead wel goed te spelen met een 4870 X2 op hogere resoluties ? want ik vondt namelijk de prestaties best tegenvallen op een X2... allebij de GPU's op 100% load vindt ik een beetje veel als hij nog niet eens vol open staat te draaie..

[Reactie gewijzigd door heesmeng op 11 december 2008 10:26]

Warhead is al goed speelbaar op een enkele 4850, de 4870 X2 moet dan toch al helemaal geen probleem zijn of zijn daar specifieke problemen mee?

volgens de release notes zijn er wel veel optimalisaties in de driver doorgevoerd voor crossfire en single GPU kaarten met Crysis, dus wellicht het testen waard.
Ik heb het volgende: als ik vooruitspoel loopt de audio niet meer synchroom, ligt dat aan de drivers?
Door een update naar 8.12, zal het dan opgelost worden?

[Reactie gewijzigd door PhanToM__ op 11 december 2008 08:56]

bij alle videobestanden?
meestal ligt zoiets aan het videobestand, je codec of je player. update die eerst als dat je enige probleem is.

[Reactie gewijzigd door Countess op 11 december 2008 09:25]

Welke mediaplayer(s) gebruik je?
Welke videobestanden wil je afspelen?
Welk audiostream stel je in?
Heb je de laatste updates voor videokaart, audiokaart en mediaplayer geinstalleerd?

Als je die vragen kunt beantwoorden dan kunnen we je hier ook beter helpen.

Maar het heeft denk ik weinig te maken met drivers van je videokaart. Tenzij je het dus om HD content gaat die je wilt afspelen. Zoals je kunt lezen is daar wel het een en ander voor verbeter.
Ben waar Avivo in de rc3 nog aanwezig was het nu toch kwijt.
Via CCC_Wizard is alleen de optie :setup my display configuration aanwezig.

Is nu het "stream computing" ook mank of is alleen de avivo codec niet geinstalleerd.
Ik wacht al een tijdje op deze drivers, vooral om de Stream toevoeging. Nu lees ik echter dat de videoconverter alleen werkt voor de 4xxx series? Ik heb zelf nog 2x 3870, weet iemand of deze ook gebruik kan maken van de ATi Stream Application: ATi AVIVO Video Converter?
Ik heb thuis Vista X64 met 3870x2, alleen wanneer ik de drivers (8.12) installeer kan na de reboot mijn 3870x2 niet meer gevonden worden. Vista geeft in de hardware-lijst een onbekend video-apparaat aan. De resolutie gaat ook niet hoger dan 1024x768. Terwijl normaal mijn scherm 1680x1050 is.

Een "downgrade" naar 8.11 laat het allemaal weer werken.

Ik heb deze gpu in de Gigabyte EX58-UD5 geprikt, met i7 920 en 3 x 2 GB KIngston geheugen.

Iemand anders ook deze problemen? 8)7

[Reactie gewijzigd door Matis op 11 december 2008 10:42]

ik heb precies het zelfde probleem ook dat hij mijn 3870 kaarten in crossfire niet meer ondersteun

[Reactie gewijzigd door bollebakker op 11 december 2008 18:18]

Heb hier precies hetzelfde probleem, met veel moeite weer terug naar 8.9.
Draai hier met 2 maal 3870X2 in crossfire onder Vista-64

[Reactie gewijzigd door spacemouse op 12 december 2008 11:54]

Ik heb ongeveer hetzelfde (3870X2 + 3870). Met deze driver versie wil de driver voor 1 GPU van m'n 3870X2 niet installeren omdat deze incompatible is volgens Vista (64). 8.11 terug gezet en geen meteen geen problemen meer.
Volgens guru3d moet je je chipsetdrivers opdaten, dan moet het weer werken, kan de link niet zo snel meer vind. Google is uw vriend?

Op dit item kan niet meer gereageerd worden.