Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Je kunt ook een cookievrije versie van de website bezoeken met minder functionaliteit. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , reacties: 22, views: 11.720 •
Bron: OmegaDrivers, submitter: Lithium_Grim

OmegaDrivers logo, nieuw, transparant (75 pix) Op de geheel vernieuwde OmegaDrivers-website kan sinds gisteren een nieuwe versie van de Omega Catalyst drivers worden opgehaald. Ook de drivers zelf zijn flink onder handen genomen. Angel Trinidad heeft het generatienummer dan ook van 3 naar 4 verhoogd en het versienummer is daardoor op 4.8.442 uitgekomen. De Omega-drivers zijn gebaseerd op de officiŽle drivers van ATi, maar bevatten diverse aanpassingen die de computer stabieler moeten houden terwijl er geprobeerd wordt de beeldkwaliteit te verhogen en een aantal extra frames per seconde in spellen te behalen. De drivers zijn alleen geschikt voor Windows 2000 en Windows XP, maar Angel draait sinds kort eindelijk (via een dual-boot) Windows Vista, dus er zullen op niet al te lange termijn ook Omega drivers voor Windows Vista komen. Het changelog van deze release ziet er in ieder geval als volgt uit:

Lees meer over

Prijzen

Club3D Radeon X1550 256MB DDR2 (PCI-e, DVI) CGAX-1556A
  • Club3D Radeon X1550 256MB DDR2 (PCI-e, DVI) CGAX-1556A
Versienummer:4.8.442
Releasestatus:Final
Besturingssystemen:Windows XP, Windows 2000
Website:OmegaDrivers
Download:http://www.omegadrivers.net/ati_winxp.php
Bestandsgrootte:17,90MB
Licentietype:Freeware

Reacties (22)

After installing the drivers you will notice that they give you version number 3.8.442 instead or 4.8.442, no need to worry, is just a typo, sorry about that

[Reactie gewijzigd door Peetke op 2 januari 2008 23:33]

Is het niet gewoon de display-driver van Cat 7.7 o.i.d met wel de nieuwste CCC? Althans, ik meende een tijd geleden zoiets gelezen te hebben.
In mijn WinXP systeem bleken niet voor alle onderdelen van mijn X1900 kaart drivers geinstalleerd te worden. De device manager van WinXP kwam nog met een unknown device. Bleek uiteindelijk om de ATI T200 Unified AVStream Driver te gaan.

Workaround: zorg ervoor dat je een originele ATI driver installatie hebt gedaan voordat je deze Omega drivers installeerd. De originele driver wordt uitgepakt en staat dan standaard in C:\ati\support\<versie>. Na installatie van de Omegadriver, doe je in de device manager een update van de niet herkende hardware. De benodigde driver staat dan in C:\ati\support\<versie>\support\wdm_all. In mijn geval was dat de 7.10 versie: C:\ATI\SUPPORT\6-10_xp-2k_dd_ccc_wdm_enu_36790\WDM_ALL

Voor de rest werken deze drivers weer perfect met de kaart.

[Reactie gewijzigd door Robo op 3 januari 2008 00:09]

Ik heb ook een x1900xt en ik heb hetzelfde! Bedankt voor je bruikbare workaround :)
Kan iemand al wat roepen over performance?
Weet iemand of winXP x64 supported is? Ik kan er niets over vinden op de Omega site, maar in de 'whats new' staat wel vermelding van nieuwe dingen voor X64 voor de ATI Tray tools.
ik heb deze omega drivers net even geprobeerd maar het beviel niet best. In Windows duurde het veel langer om menu's te laden. Als ik op start klikte zag je Windows het menu opbouwen. Ook van venster wisselen in Firefox ging niet vloeiend. Daarom ben ik snel weer terug gegaan naar Catalyst 7.12.

Mijn kaart is een MSI X1950 Pro AGP
klinkt als dat je videokaart niet goed door de drivers gepakt is. ze draaien hier als een zonnetje (x1600 mobility)
Ik hoop dat Angel een beetje snel is met die Vistadrivers en dat zijn drivers niet elke dag crashen op ATIMKDAG.SYS zoals de normale ATI driver.
Daar heb ik ook last van, en het rotte is dat VPU Recover elke keer intreed terwijl je dat niet uit kan zetten.
Dit is met Vista X64 en 2 HD3870 in CF.
vpu recovery wordt door directx10 gedaan door MS code, net als de geheugenafhandelling, de fix (voor een aantal van deze problemen) komt pas in dx10.1

zowel ati als nvidia hebben van deze bug last, normaal gezien komt hij wel maar een paar keer per maand voor.

[Reactie gewijzigd door oeLangOetan op 3 januari 2008 20:09]

1) Iemand al wat over performanceverschillen?
2) Zit hier ook fanspeedregeling/tempreading in?

[Reactie gewijzigd door Stan op 3 januari 2008 15:39]

Hmm ik heb hier een x1950pro 256mb agp en merk ten opzichte van de Catalyst 7.7 en Omega 7.10 dat ik input lag heb.

Merk dit vooral met quake3 mod urban terror. Je muis beweeg je al en het beeld komt erachter aan (zit enkele milliseconden verschil dus tussen) dit is erg irritant. Het beeld is overigens wel net zo vloeiend en evenveel fps. Ja en als je vsync uit doet dan is het goed, maar heb je last van tearing.

Is hier een registeraanpassing voor? geen enkele optie in ati try tools maakt uit. De advanced tweaks ga ik niet allemaal bij langs, dat is uit den boze natuurlijk.

Op dit item kan niet meer gereageerd worden.